Modify

Opened 4 years ago

Closed 3 years ago

#17303 closed defect (moved_to_github)

php5-mod-gd not working in x86

Reported by: nan4k7@… Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: packages Version: Attitude Adjustment 12.09
Keywords: x86 php gd Cc:

Description

I've installed php5-mod-gd in my openwrt x86 and I can't get it to work.

When I take a look at php_error_log I see:

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/gd.so' - (null) in Unknown on line 0

And file is indeed there:

root@OpenWrtX86:/usr/lib/php# ls /usr/lib/php/
ctype.so exif.so gd.so hash.so json.so mysql.so pdo.so session.so
curl.so fileinfo.so gettext.so iconv.so mbstring.so mysqli.so pdo_mysql.so simplexml.so

Attachments (0)

Change History (6)

comment:1 Changed 4 years ago by anonymous

Managed to get more info about the error... When running the command:
/usr/bin/php-fcgi -b 1026

I see the error:
/usr/bin/php-fcgi: symbol 'iconv_open': can't resolve symbol in lib '/usr/lib/php/gd.so'.

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:3 Changed 4 years ago by anonymous

Any solutions?

comment:4 Changed 3 years ago by whotopia@…

Same problem with latest Barrier Breaker on Alix x86.

comment:5 Changed 3 years ago by anonymous

Same problem...

comment:6 Changed 3 years ago by florian

  • Resolution set to moved_to_github
  • Status changed from new to closed

This package has been moved to http://github.com/OpenWrt/packages please report the issue there.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.