Modify

Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#17298 closed defect (duplicate)

Bridge not created after update to BB-RC1

Reported by: herr.ernst@… Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: bridge, uci Cc:

Description

I've upgraded my Linksys E2000 (bcm47xx) from r40772 to 14.07-rc1, r41580 (now using the subdevice mips74k image) keeping my configuration. I'm using OpenWRT as bridged AP, DNS and DHCP being external. After the upgrade, my bridge over Ethernet and Wi-Fi doesn't get created automatically as before, I manually have to execute brctl addif br-lan wl0. Has anything changed in configuration syntax? Here the relevant parts of uci:

network.eth0=switch
network.eth0.name=switch0
network.eth0.reset=1
network.eth0.enable=1
network.eth0.enable_vlan=1
network.eth0_1=switch_vlan
network.eth0_1.device=switch0
network.eth0_1.vlan=1
network.eth0_1.ports=0 1 2 3 4 8
network.lan=interface
network.lan.ifname=eth0
network.lan.type=bridge
network.lan.proto=static
network.lan.hostname=OpenWrt
network.lan.ipaddr=192.168.0.2
network.lan.netmask=255.255.255.0
network.lan.gateway=192.168.0.1
wireless.wl0=wifi-device
wireless.wl0.type=broadcom
wireless.@wifi-iface[0]=wifi-iface
wireless.@wifi-iface[0].device=wl0
wireless.@wifi-iface[0].mode=ap
wireless.@wifi-iface[0].network=lan

I've also posted this in the forum and at least one other use seems to have the same problem.

Attachments (0)

Change History (4)

comment:1 follow-up: Changed 4 years ago by Zajec

Duplicate of #17262 I believe.

comment:2 in reply to: ↑ 1 Changed 4 years ago by anonymous

Replying to Zajec:

Duplicate of #17262 I believe.

You're right, sorry, haven't seen that.

comment:3 Changed 4 years ago by hauke

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #17262

Last edited 4 years ago by hauke (previous) (diff)

comment:4 Changed 3 years ago by anonymous

Can also confim on a later build.

kernel - 3.18.11-1-770e8dc304cf712fbbf46ade335e8bd5
Router - ASUS RT-N16

As a work around, where can I place the command:
brctl addif br-lan wl0
so that it will be excuted to add wl0 to the lan?

I'll place it in /etc/rc.local for now and see, but possibly the wifi if.up type script would be better?
Any further details needed?

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.