Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#17281 closed defect (fixed)

netifd/udhcpc: r41835 renew loop madness

Reported by: Damian Kaczkowski <damian.kaczkowski+openwrt@…> Owned by: developers
Priority: highest Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: Cc: nbd@…

Description

bb trunk, r41835, tl-wr1043nd-v1

r41835 was ok

cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config switch 'switch_0'
        option name 'switch0'
        option reset '1'
        option enable_vlan '0'
        option enable_vlan4k '0'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option stp '1'
        option proto 'dhcp'

cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/ath9k'
        option channel '1'
        option htmode 'HT40+'
        option txpower '17'
        option country 'PL'
        option noscan '1'
        option disabled '0'

config wifi-iface 'wlan0_0'
        option disabled '0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'secret'
        option encryption 'psk2+ccmp'
        option key 'secret'

logread

Sat Jul 26 16:13:29 2014 daemon.notice netifd: lan (1464): Sending renew...
Sat Jul 26 16:13:29 2014 daemon.notice netifd: lan (1464): Performing a DHCP renew
Sat Jul 26 16:13:29 2014 daemon.notice netifd: lan (1464): Sending renew...
Sat Jul 26 16:13:29 2014 daemon.notice netifd: lan (1464): Lease of 192.168.1.253 obtained, lease time 43200
Sat Jul 26 16:13:30 2014 daemon.notice netifd: lan (1464): Performing a DHCP renew
Sat Jul 26 16:13:30 2014 daemon.notice netifd: lan (1464): Sending renew...
Sat Jul 26 16:13:30 2014 daemon.notice netifd: lan (1464): Lease of 192.168.1.253 obtained, lease time 43200
Sat Jul 26 16:13:30 2014 daemon.notice netifd: lan (1464): Performing a DHCP renew
Sat Jul 26 16:13:30 2014 daemon.notice netifd: lan (1464): Sending renew...
Sat Jul 26 16:13:30 2014 daemon.notice netifd: lan (1464): Lease of 192.168.1.253 obtained, lease time 43200
Sat Jul 26 16:13:30 2014 daemon.notice netifd: lan (1464): Performing a DHCP renew
Sat Jul 26 16:13:30 2014 daemon.notice netifd: lan (1464): Sending renew...
Sat Jul 26 16:13:30 2014 daemon.notice netifd: lan (1464): Performing a DHCP renew
Sat Jul 26 16:13:30 2014 daemon.notice netifd: lan (1464): Sending renew...
Sat Jul 26 16:13:30 2014 daemon.notice netifd: lan (1464): Lease of 192.168.1.253 obtained, lease time 43200
Sat Jul 26 16:13:31 2014 daemon.notice netifd: lan (1464): Performing a DHCP renew
Sat Jul 26 16:13:31 2014 daemon.notice netifd: lan (1464): Sending renew...
Sat Jul 26 16:13:31 2014 daemon.notice netifd: lan (1464): Lease of 192.168.1.253 obtained, lease time 43200
Sat Jul 26 16:13:31 2014 daemon.notice netifd: lan (1464): Performing a DHCP renew
Sat Jul 26 16:13:31 2014 daemon.notice netifd: lan (1464): Sending renew...
Sat Jul 26 16:13:31 2014 daemon.notice netifd: lan (1464): Lease of 192.168.1.253 obtained, lease time 43200
Sat Jul 26 16:13:31 2014 daemon.notice netifd: lan (1464): Performing a DHCP renew
Sat Jul 26 16:13:31 2014 daemon.notice netifd: lan (1464): Sending renew...
Sat Jul 26 16:13:31 2014 daemon.notice netifd: lan (1464): Performing a DHCP renew
Sat Jul 26 16:13:31 2014 daemon.notice netifd: lan (1464): Sending renew...
Sat Jul 26 16:13:31 2014 daemon.notice netifd: lan (1464): Lease of 192.168.1.253 obtained, lease time 43200
Sat Jul 26 16:13:31 2014 daemon.notice netifd: lan (1464): Performing a DHCP renew
Sat Jul 26 16:13:31 2014 daemon.notice netifd: lan (1464): Sending renew...
Sat Jul 26 16:13:31 2014 daemon.notice netifd: lan (1464): Lease of 192.168.1.253 obtained, lease time 43200
Sat Jul 26 16:13:32 2014 daemon.notice netifd: lan (1464): Performing a DHCP renew
Sat Jul 26 16:13:32 2014 daemon.notice netifd: lan (1464): Sending renew...
Sat Jul 26 16:13:32 2014 daemon.notice netifd: lan (1464): Lease of 192.168.1.253 obtained, lease time 43200
Sat Jul 26 16:13:32 2014 daemon.notice netifd: lan (1464): Performing a DHCP renew
Sat Jul 26 16:13:32 2014 daemon.notice netifd: lan (1464): Sending renew...
Sat Jul 26 16:13:32 2014 daemon.notice netifd: lan (1464): Performing a DHCP renew
Sat Jul 26 16:13:32 2014 daemon.notice netifd: lan (1464): Sending renew...
Sat Jul 26 16:13:32 2014 daemon.notice netifd: lan (1464): Lease of 192.168.1.253 obtained, lease time 43200
Sat Jul 26 16:13:32 2014 daemon.notice netifd: lan (1464): Performing a DHCP renew
Sat Jul 26 16:13:32 2014 daemon.notice netifd: lan (1464): Sending renew...
Sat Jul 26 16:13:32 2014 daemon.notice netifd: lan (1464): Performing a DHCP renew
Sat Jul 26 16:13:32 2014 daemon.notice netifd: lan (1464): Sending renew...
Sat Jul 26 16:13:32 2014 daemon.notice netifd: lan (1464): Lease of 192.168.1.253 obtained, lease time 43200
Sat Jul 26 16:13:33 2014 daemon.notice netifd: lan (1464): Performing a DHCP renew
Sat Jul 26 16:13:33 2014 daemon.notice netifd: lan (1464): Sending renew...
Sat Jul 26 16:13:33 2014 daemon.notice netifd: lan (1464): Lease of 192.168.1.253 obtained, lease time 43200
Sat Jul 26 16:13:33 2014 daemon.notice netifd: lan (1464): Performing a DHCP renew
Sat Jul 26 16:13:33 2014 daemon.notice netifd: lan (1464): Sending renew...
Sat Jul 26 16:13:33 2014 daemon.notice netifd: lan (1464): Performing a DHCP renew
Sat Jul 26 16:13:33 2014 daemon.notice netifd: lan (1464): Sending renew...
Sat Jul 26 16:13:33 2014 daemon.notice netifd: lan (1464): Lease of 192.168.1.253 obtained, lease time 43200
Sat Jul 26 16:13:33 2014 daemon.notice netifd: lan (1464): Performing a DHCP renew
Sat Jul 26 16:13:33 2014 daemon.notice netifd: lan (1464): Sending renew...
Sat Jul 26 16:13:33 2014 daemon.notice netifd: lan (1464): Lease of 192.168.1.253 obtained, lease time 43200
Sat Jul 26 16:13:33 2014 daemon.notice netifd: lan (1464): Performing a DHCP renew
Sat Jul 26 16:13:33 2014 daemon.notice netifd: lan (1464): Sending renew...
Sat Jul 26 16:13:33 2014 daemon.notice netifd: lan (1464): Lease of 192.168.1.253 obtained, lease time 43200

and so on...

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by Damian Kaczkowski <damian.kaczkowski+openwrt@…>

*r41815 was ok

comment:2 Changed 4 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in r41836

comment:3 Changed 4 years ago by anonymous

Trial and error 4tw.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.