Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#17277 closed defect (not_a_bug)

bad wireless defaults on wdr3600 and maybe others

Reported by: Viper Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: base system Version: Trunk
Keywords: Cc:

Description

The default wireless generated config is missing some options, in Luci wireless band has only one option, the default tx power is set at 30dbm in luci, the default country is 00. I don't know exactly what changeset is guilty, but i've tested a build older then 3 months and had the same problem, also a good one from 2013.
good:

config wifi-device  radio0
	option type     mac80211
	option channel  11
	option hwmode	11ng
	option path	'platform/ar934x_wmac'
	option htmode	HT20
	list ht_capab	LDPC
	list ht_capab	SHORT-GI-20
	list ht_capab	SHORT-GI-40
	list ht_capab	TX-STBC
	list ht_capab	RX-STBC1
	list ht_capab	DSSS_CCK-40
	# REMOVE THIS LINE TO ENABLE WIFI:
	option disabled 1

bad:

config wifi-device radio0
        option type    mac80211
        option channel 11
        option hwmode  11g
        option path    'platform/ar934x_wmac'
        option htmode  HT20
	# REMOVE THIS LINE TO ENABLE WIFI:
	option disabled 1

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by jow

  • Resolution set to not_a_bug
  • Status changed from new to closed

The config looks perfectly fine.

comment:2 Changed 4 years ago by anonymous

Missing the ht_capab, what about the missing options from Luci ? Only one wireless mode listed.. isn't that related to the config? How is this not a bug..

comment:3 Changed 4 years ago by jow

The wifi config changed in trunk. The band in LuCI merely selects between 2.4ghz and 5ghz and if the radio only supports only one band then you see only one choice.

Missing ht_capab is normal as well because its populated automatically in trunk not part of the config anymore.

Enabling/disabling 11n happens by toggling between HT20/HT40 now.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.