Modify

Opened 4 years ago

Last modified 4 years ago

#17208 new defect

USB HDD detected but not mounted - /dev/sdax missing

Reported by: mpaulonic Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: usb sda Cc:

Description

I have a WDR4300 and dmesg seems to work fine regarding usb:

Fri Jul 18 21:43:02 2014 kern.info kernel: [ 4.560000] usbcore: registered new interface driver usbfs
Fri Jul 18 21:43:02 2014 kern.info kernel: [ 4.570000] usbcore: registered new interface driver hub
Fri Jul 18 21:43:02 2014 kern.info kernel: [ 4.580000] usbcore: registered new device driver usb
Fri Jul 18 21:43:02 2014 kern.info kernel: [ 4.590000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
Fri Jul 18 21:43:02 2014 kern.info kernel: [ 4.590000] ehci-platform: EHCI generic platform driver
Fri Jul 18 21:43:02 2014 kern.info kernel: [ 4.600000] ehci-platform ehci-platform: EHCI Host Controller
Fri Jul 18 21:43:02 2014 kern.info kernel: [ 4.600000] ehci-platform ehci-platform: new USB bus registered, assigned bus number 1
Fri Jul 18 21:43:02 2014 kern.info kernel: [ 4.610000] ehci-platform ehci-platform: irq 3, io mem 0x1b000000
Fri Jul 18 21:43:02 2014 kern.info kernel: [ 4.640000] ehci-platform ehci-platform: USB 2.0 started, EHCI 1.00
Fri Jul 18 21:43:02 2014 kern.info kernel: [ 4.640000] hub 1-0:1.0: USB hub found
Fri Jul 18 21:43:02 2014 kern.info kernel: [ 4.650000] hub 1-0:1.0: 1 port detected
Fri Jul 18 21:43:02 2014 kern.info kernel: [ 4.650000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
Fri Jul 18 21:43:02 2014 kern.info kernel: [ 5.010000] usb 1-1: new high-speed USB device number 2 using ehci-platform
Fri Jul 18 21:43:02 2014 kern.info kernel: [ 5.160000] hub 1-1:1.0: USB hub found
Fri Jul 18 21:43:02 2014 kern.info kernel: [ 5.160000] hub 1-1:1.0: 4 ports detected
Fri Jul 18 21:43:02 2014 kern.info kernel: [ 8.260000] usb 1-1.2: new high-speed USB device number 3 using ehci-platform

The lsusb -v command list several attributes about my disk:

Bus 001 Device 003: ID 1221:3234
Device Descriptor:

bLength 18
bDescriptorType 1
bcdUSB 2.00
bDeviceClass 0 (Defined at Interface level)
bDeviceSubClass 0
bDeviceProtocol 0
bMaxPacketSize0 64
idVendor 0x1221
idProduct 0x3234
bcdDevice 0.00
iManufacturer 1 (error)
iProduct 2 USB
iSerial 3 1000000000000AD1
bNumConfigurations 1
Configuration Descriptor:

bLength 9
bDescriptorType 2
wTotalLength 32
bNumInterfaces 1
bConfigurationValue 1
iConfiguration 0
bmAttributes 0x80

(Bus Powered)

MaxPower 100mA
Interface Descriptor:

bLength 9
bDescriptorType 4
bInterfaceNumber 0
bAlternateSetting 0
bNumEndpoints 2
bInterfaceClass 8 Mass Storage
bInterfaceSubClass 6 SCSI
bInterfaceProtocol 80 Bulk-Only
iInterface 0
Endpoint Descriptor:

bLength 7
bDescriptorType 5
bEndpointAddress 0x81 EP 1 IN
bmAttributes 2

Transfer Type Bulk
Synch Type None
Usage Type Data

wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0

Endpoint Descriptor:

bLength 7
bDescriptorType 5
bEndpointAddress 0x01 EP 1 OUT
bmAttributes 2

Transfer Type Bulk
Synch Type None
Usage Type Data

wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0

Device Qualifier (for other device speed):

bLength 10
bDescriptorType 6
bcdUSB 2.00
bDeviceClass 0 (Defined at Interface level)
bDeviceSubClass 0
bDeviceProtocol 0
bMaxPacketSize0 64
bNumConfigurations 1

Device Status: 0x0000

(Bus Powered)

but there is no /dev/sdax. I have installed all the modules needed (so I think). Any help?

Attachments (0)

Change History (6)

comment:1 Changed 4 years ago by anonymous

please list all modules installed

comment:2 Changed 4 years ago by mpaulonic

root@OpenWrt:~# lsmod
arc4 1312 4
ath 19717 3 ath9k
ath9k 88305 0
ath9k_common 11437 1 ath9k
ath9k_hw 314831 2 ath9k
cfg80211 197767 4 ath9k
compat 1988 4 ath9k
crc_ccitt 1019 1 ppp_async
crypto_blkcipher 10375 1 arc4
ehci_hcd 30780 1 ehci_platform
ehci_platform 1872 0
gpio_button_hotplug 4448 0
ip6_tables 9105 3 ip6table_raw
ip6t_REJECT 2032 2
ip6table_filter 608 1
ip6table_mangle 1056 1
ip6table_raw 576 1
ip_tables 9245 4 iptable_nat
ipt_MASQUERADE 1136 1
ipt_REJECT 1808 2
iptable_filter 672 1
iptable_mangle 960 1
iptable_nat 1968 1
iptable_raw 640 1
ipv6 248940 31 ip6t_REJECT
l2tp_core 13838 2 l2tp_ppp
l2tp_netlink 6616 1 l2tp_ppp
l2tp_ppp 12800 0
ledtrig_usbdev 1952 0
mac80211 346353 1 ath9k
nf_conntrack 45438 13 iptable_nat
nf_conntrack_ftp 5120 1 nf_nat_ftp
nf_conntrack_ipv4 5188 8
nf_conntrack_ipv6 5552 3
nf_conntrack_irc 2784 1 nf_nat_irc
nf_defrag_ipv4 790 1 nf_conntrack_ipv4
nf_defrag_ipv6 8711 1 nf_conntrack_ipv6
nf_nat 10560 7 iptable_nat
nf_nat_ftp 1200 0
nf_nat_ipv4 2654 1 iptable_nat
nf_nat_irc 976 0
nls_base 4974 1 usbcore
ohci_hcd 16608 0
ppp_async 6144 0
ppp_generic 19634 4 pppoe
pppoe 7744 0
pppox 1338 2 pppoe
scsi_mod 76866 2 sg
sd_mod 24560 0
sg 19088 0
slhc 4299 1 ppp_generic
tun 14559 0
usb_common 1160 1 usbcore
usbcore 109781 5 usblp
usblp 8448 0
x_tables 10997 25 ipt_MASQUERADE
xt_CT 2272 0
xt_LOG 9488 0
xt_REDIRECT 1056 0
xt_TCPMSS 2672 2
xt_comment 480 39
xt_conntrack 2160 10
xt_limit 992 2
xt_mac 608 0
xt_mark 672 0
xt_multiport 1184 0
xt_nat 1072 0
xt_state 688 0
xt_tcpudp 1680 13
xt_time 1664 0

comment:3 Changed 4 years ago by mpaulonic

Upgraded to kernel 3.10.49

USB packages installed:

kmod-ledtrig-usbdev - 3.10.49-1
kmod-usb-core - 3.10.49-1
kmod-usb-ohci - 3.10.49-1
kmod-usb-storage - 3.10.49-1
kmod-usb2 - 3.10.49-1

Now I have kmod-usb-storage:

root@OpenWrt:~# lsmod

arc4 1312 4
ath 19717 3 ath9k
ath9k 88305 0
ath9k_common 11437 1 ath9k
ath9k_hw 314831 2 ath9k
cfg80211 197767 4 ath9k
compat 1988 4 ath9k
crc_ccitt 1019 1 ppp_async
crypto_blkcipher 10375 1 arc4
ehci_hcd 30780 1 ehci_platform
ehci_platform 1872 0
gpio_button_hotplug 4448 0
ip6_tables 9105 3 ip6table_raw
ip6t_REJECT 2032 2
ip6table_filter 608 1
ip6table_mangle 1056 1
ip6table_raw 576 1
ip_tables 9245 4 iptable_nat
ipt_MASQUERADE 1136 1
ipt_REJECT 1808 2
iptable_filter 672 1
iptable_mangle 960 1
iptable_nat 1968 1
iptable_raw 640 1
ipv6 248940 26 ip6t_REJECT
ledtrig_usbdev 1952 0
mac80211 346353 1 ath9k
nf_conntrack 45438 13 iptable_nat
nf_conntrack_ftp 5120 1 nf_nat_ftp
nf_conntrack_ipv4 5188 8
nf_conntrack_ipv6 5552 3
nf_conntrack_irc 2784 1 nf_nat_irc
nf_defrag_ipv4 790 1 nf_conntrack_ipv4
nf_defrag_ipv6 8711 1 nf_conntrack_ipv6
nf_nat 10560 7 iptable_nat
nf_nat_ftp 1200 0
nf_nat_ipv4 2654 1 iptable_nat
nf_nat_irc 976 0
nls_base 4974 1 usbcore
ohci_hcd 16608 0
ppp_async 6144 0
ppp_generic 19634 3 pppoe
pppoe 7744 0
pppox 1338 1 pppoe
scsi_mod 76866 2 usb_storage
sd_mod 24560 0
slhc 4299 1 ppp_generic
usb_common 1160 1 usbcore
usb_storage 36248 0
usbcore 109781 5 usb_storage
x_tables 10997 25 ipt_MASQUERADE
xt_CT 2272 0
xt_LOG 9488 0
xt_REDIRECT 1056 0
xt_TCPMSS 2672 2
xt_comment 480 37
xt_conntrack 2160 10
xt_limit 992 2
xt_mac 608 0
xt_mark 672 0
xt_multiport 1184 0
xt_nat 1072 0
xt_state 688 0
xt_tcpudp 1680 11
xt_time 1664 0

But still no /dev/sdaX

comment:4 Changed 4 years ago by mpaulonic

Installed package block-mount. Now I have SCSI detected:

Tue Jul 22 17:03:17 2014 kern.info kernel: [ 8.730000] usb-storage 1-1.1:1.0: USB Mass Storage device detected
Tue Jul 22 17:03:17 2014 kern.info kernel: [ 8.740000] scsi0 : usb-storage 1-1.1:1.0
Tue Jul 22 17:03:17 2014 kern.info kernel: [ 8.740000] usbcore: registered new interface driver usb-storage
Tue Jul 22 17:03:17 2014 kern.info kernel: [ 9.000000] eth0: link down
Tue Jul 22 17:03:17 2014 kern.notice kernel: [ 9.740000] scsi 0:0:0:0: Direct-Access 2.0 USB 2.40 PQ: 0 ANSI: 2
Tue Jul 22 17:03:17 2014 kern.notice kernel: [ 9.750000] sd 0:0:0:0: [sda] 8273920 512-byte logical blocks: (4.23 GB/3.94 GiB)
Tue Jul 22 17:03:17 2014 kern.notice kernel: [ 9.760000] sd 0:0:0:0: [sda] Write Protect is off
Tue Jul 22 17:03:17 2014 kern.debug kernel: [ 9.760000] sd 0:0:0:0: [sda] Mode Sense: 0b 00 00 08
Tue Jul 22 17:03:17 2014 kern.err kernel: [ 9.760000] sd 0:0:0:0: [sda] No Caching mode page found
Tue Jul 22 17:03:17 2014 kern.err kernel: [ 9.770000] sd 0:0:0:0: [sda] Assuming drive cache: write through
Tue Jul 22 17:03:17 2014 kern.err kernel: [ 9.780000] sd 0:0:0:0: [sda] No Caching mode page found
Tue Jul 22 17:03:17 2014 kern.err kernel: [ 9.780000] sd 0:0:0:0: [sda] Assuming drive cache: write through
Tue Jul 22 17:03:17 2014 kern.info kernel: [ 9.800000] sda:
Tue Jul 22 17:03:17 2014 kern.err kernel: [ 9.800000] sd 0:0:0:0: [sda] No Caching mode page found
Tue Jul 22 17:03:17 2014 kern.err kernel: [ 9.810000] sd 0:0:0:0: [sda] Assuming drive cache: write through
Tue Jul 22 17:03:17 2014 kern.notice kernel: [ 9.820000] sd 0:0:0:0: [sda] Attached SCSI removable disk

Then a /dev/sda is created as a block device but no /dev/sdaX. And the command

mount -t vfat /dev/sda /mnt/usb

returns
mount: mounting /dev/sda on /mnt/usb failed: No such device

comment:5 Changed 4 years ago by mpaulonic

After no comment or help, I was able to solve it.

comment:6 Changed 4 years ago by anonymous

could you please tell us how you solved that?

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.