Modify

Opened 4 years ago

Last modified 4 years ago

#17200 new defect

Secondary WLAN SSID shuts down automatically on BB trunk

Reported by: banglang Owned by: developers
Priority: high Milestone: Chaos Calmer 15.05
Component: base system Version: Trunk
Keywords: Cc:

Description

On WNDR3800 (Atheros AR9223), secondary SSID that is was being setup as "guest" network shuts downs by itself after 3-4 minutes. The same configuration worked on AA seem to fail on BB. I'm running on "OpenWrt Barrier Breaker r41737"

I tried enabling verbose log_level '0' on wireless but there isn't any more verbose log than the following syslog

Sat Jul 19 22:35:31 2014 daemon.info hostapd: wlan0-1: STA 28:01:5d:4d:67:c5 IEEE 802.11: authenticated
Sat Jul 19 22:35:31 2014 daemon.info hostapd: wlan0-1: STA 28:01:5d:4d:67:c5 IEEE 802.11: associated (aid 2)
Sat Jul 19 22:35:31 2014 daemon.info hostapd: wlan0-1: STA 28:01:5d:4d:67:c5 WPA: pairwise key handshake completed (RSN)
Sat Jul 19 22:37:37 2014 daemon.notice netifd: Network device 'wlan0-1' link is down
Sat Jul 19 22:37:37 2014 daemon.notice netifd: Interface 'guest' has link connectivity loss
Sat Jul 19 22:37:38 2014 daemon.notice netifd: Interface 'guest' is disabled
Sat Jul 19 22:37:40 2014 daemon.notice vnstatd[2927]: Interface "wlan0-1" disabled.

This is my /etc/config/wireless setup:

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '11'
	option hwmode '11ng'
	option htmode 'HT20'
	list ht_capab 'SHORT-GI-40'
	list ht_capab 'TX-STBC'
	list ht_capab 'RX-STBC1'
	list ht_capab 'DSSS_CCK-40'
	option txpower '24'
	option distance '10'
	option country 'US'
	option country_ie '1'
	option noscan '1'
        option log_level '0'

config wifi-iface
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'home network'
	option encryption 'psk2+ccmp'
	option key 'passwordnumber1'

config wifi-iface
	option device 'radio0'
	option network 'guest'
	option mode 'ap'
	option ssid 'guest network'
	option encryption 'psk2+ccmp'
	option key 'passwordnumber2'

There is nothing else on dmesg that explains why the secondary SSID will shutdown. Let me know if you need any further information or if I can try something else to troubleshoot this problem.

Attachments (0)

Change History (8)

comment:1 Changed 4 years ago by nbd

Are you 100% sure that there's nothing on your system that might accidentally change the state of the wlan0-1 device, e.g. ifconfig wlan0-1 down?
How is the 'guest' network configured in /etc/config/network?

I don't remember seeing any similar reports (and multi-SSID isn't exactly a rarely used feature), so I'd like to figure out what's special about your configuration.

comment:2 Changed 4 years ago by banglang

This is the interface section of /etc/config/network:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface lan
	option ifname 'eth0.1'
	option type 'bridge'
	option proto 'static'
	option ipaddr '10.0.0.1'
	option netmask '255.255.255.0'
	
config interface 'wan'
	option ifname 'eth1'
	option proto 'dhcp'

config interface guest
	option proto 'static'
	option ipaddr '10.0.1.1'
	option netmask '255.255.255.0'

I'm pretty sure nothing changed the state of wlan0-1. The same setup runs fine in AA. After the router starts, wlan0-1 will stay up for a few minutes. Client associated with that SSID will be able to access the Internet before it goes down.

The interface can be recovered again by running "wifi down; wifi" but then it is a rinse an repeat.

My setup is based on this guide:

http://wiki.openwrt.org/doc/recipes/guest-wlan

comment:3 Changed 4 years ago by banglang

I tried a few changes. It appears that the additional wireless wlan0-1 will only shutdown by itself if it was configured in the guest interface.

There are no problems if it was placed in the original bridged lan

comment:4 Changed 4 years ago by nbd

please test r41818

comment:5 Changed 4 years ago by banglang

Just tested and it didn't fix the issue:

Thu Jul 24 21:56:11 2014 kern.info kernel: [   79.940000] IPv6: ADDRCONF(NETDEV_UP): wlan0-1: link is not ready
Thu Jul 24 21:56:12 2014 kern.info kernel: [   80.960000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0-1: link becomes ready
Thu Jul 24 21:56:12 2014 daemon.notice netifd: Network device 'wlan0-1' link is up
Thu Jul 24 21:56:13 2014 user.notice firewall: Reloading firewall due to ifup of transient (wlan0-1)
Thu Jul 24 21:56:20 2014 daemon.notice vnstatd[2732]: Monitoring: wlan0-1 br-lan wlan1 wlan0 eth1 
Thu Jul 24 22:24:00 2014 daemon.notice netifd: Network device 'wlan0-1' link is down
Thu Jul 24 22:24:24 2014 daemon.notice vnstatd[2732]: Interface "wlan0-1" disabled.

comment:6 Changed 4 years ago by banglang

Just compiled and tested r41825 with no success.

comment:7 Changed 4 years ago by nbd

Please do this:

set CONFIG_WPA_MSG_MIN_PRIORITY=0 in your .config
rebuild and reinstall wpad(-mini)

On the router:

wifi down
iw phy0 interface add wlan0 type managed
hostapd -d /var/run/hostapd-phy0.conf

In another window:

ubus call network.interface.guest add_device '{ "device": "wlan0-1" }'

Capture the output of hostapd until wlan0-1 goes down again, and send me the complete log.

comment:8 Changed 4 years ago by anonymous

I'm not familiar with the ubus command structure but your ubus command yielded the following invalid error:

# ubus call network.interface.guest add_device '{ "device": "wlan0-1" }'
Command failed: Invalid argument

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.