Modify

Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#17071 closed defect (fixed)

Because of r37163, Asus RT-N13U (v1/B1) buttons are now mismatched and r37163 should be reverted

Reported by: braveheart_leo@… Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: other Version: Trunk
Keywords: rt-n13u button Cc:

Description

Because of r37163, the 'restore' physical button located on the device is now identified as 'wps' button, and the 'wps' physical button is now identified as 'rfkill' button, all in OpenWrt Barrier Breaker r41548.

As per the hardware enablement patch for this device from r34405, specifically https://dev.openwrt.org/browser/trunk/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-rt-n13u.c?rev=34405

#define RT_N13U_GPIO_BUTTON_RESET       10
#define RT_N13U_GPIO_BUTTON_WPS         0

RESET button is GPIO 10 (and not 4 from r37163), and WPS button is GPIO 0 (and not 10 from r37163).

The device only has two physical buttons (RESTORE and WPS) [1-] and a switch (switching from router/ap/repeater modes for stock firwmare) [2-]. I don't know how to make use of this switch in OpenWrt, though. Still, what may be considered the 'rfkill' button on this device?

[1-] http://www.asus.com/Networking/RTN13U_B1/specifications/
[2-] http://www.techinfodepot.info/wiki/File:Asus_RT-N13Uf.jpg

Attachments (0)

Change History (4)

comment:1 Changed 4 years ago by braveheart_leo@…

These are the troubleshooting steps I have taken. I have created /etc/hotplug.d/button/buttons with the following content:

#!/bin/sh
logger $BUTTON
logger $ACTION

Upon pressing the WPS button on the device, I'm getting

Sat Jul 12 01:19:44 2014 user.notice root: rfkill
Sat Jul 12 01:19:44 2014 user.notice root: pressed
Sat Jul 12 01:19:45 2014 user.notice root: rfkill
Sat Jul 12 01:19:45 2014 user.notice root: released

This toggles the wireless radio as per /etc/rc.button/rfkill script.

Upon pressing the RESTORE button on the device, I'm getting

Sat Jul 12 01:23:21 2014 user.notice root: wps
Sat Jul 12 01:23:21 2014 user.notice root: pressed
Sat Jul 12 01:23:22 2014 user.notice root: wps
Sat Jul 12 01:23:22 2014 user.notice root: released

And nothing happens, because there is no corresponding /etc/rc.button/wps script to handle the event.

As seen above, the physical buttons no longer correspond to their correct button labels (RESTORE should be 'reset', WPS should be 'wps'). This makes associating possible actions to the physical buttons a mismatch.

comment:2 Changed 4 years ago by xavier@…

This bug has been confirmed on an Asus RT-N13U B1, running BARRIER BREAKER (Bleeding Edge, r41678).

comment:3 Changed 3 years ago by blogic

  • Resolution set to fixed
  • Status changed from new to closed

comment:4 Changed 3 years ago by braveheart_leo@…

Thank you.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.