Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#17061 closed defect (fixed)

crash on interface change from dhcp to unmanaged

Reported by: cprevotaux@… Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: base system Version: Attitude Adjustment 12.09
Keywords: Cc: nbd@…

Description

on an AR9331 based board I got.

When changing a wlan0 interface from unmanaged to dhcp at the in the context of a stabridge using relayd

platform is latest AA r44550 using Linux dart.rural-network.lan 3.3.8 #1 Tue Jul 8 13:19:32 EDT 2014 mips GNU/Linux

Not sure what you would want me to do about this ? how to report it correctly ?

root@dart:/# [ 21.430000] wlan0: authenticate with 00:40:10:10:00:03
[ 21.440000] wlan0: send auth to 00:40:10:10:00:03 (try 1/3)
[ 21.440000] wlan0: authenticated
[ 21.460000] wlan0: associate with 00:40:10:10:00:03 (try 1/3)
[ 21.460000] wlan0: RX AssocResp from 00:40:10:10:00:03 (capab=0x411 status=0 aid=5)
[ 21.470000] wlan0: associated
[ 107.840000] wlan0: deauthenticating from 00:40:10:10:00:03 by local choice (Reason: 3=DEAUTH_LEAVING)
[ 110.600000] wlan0: authenticate with 00:40:10:10:00:03
[ 110.610000] wlan0: send auth to 00:40:10:10:00:03 (try 1/3)
[ 110.610000] CPU 0 Unable to handle kernel paging request at virtual address 00000040, epc == 83141974, ra == 83105af8
[ 110.620000] Oops#1:
[ 110.620000] Cpu 0
[ 110.620000] $ 0 : 00000000 00b30594 00000000 00000000
[ 110.620000] $ 4 : 00000000 00000000 8334fae8 00000000
[ 110.620000] $ 8 : 00000004 00000000 00000000 000003fe
[ 110.620000] $12 : 00000005 83285c1c 00000001 00000002
[ 110.620000] $16 : 83171000 8334fab8 83288380 831fcac0
[ 110.620000] $20 : 830b8e80 fffffffe 00000000 00000000
[ 110.620000] $24 : 00000010 83141960
[ 110.620000] $28 : 8334e000 8334fa30 00000008 83105af8
[ 110.620000] Hi : 00000000
[ 110.620000] Lo : 0000000a
[ 110.620000] epc : 83141974 minstrel_get_expected_throughput+0x14/0x28 [mac80211]
[ 110.620000] Tainted: G O
[ 110.620000] ra : 83105af8 sta_set_sinfo+0x3e4/0x41c [mac80211]
[ 110.620000] Status: 1000d403 KERNEL EXL IE
[ 110.620000] Cause : 00800008
[ 110.620000] BadVA : 00000040
[ 110.620000] PrId : 00019374 (MIPS 24Kc)
[ 110.620000] Modules linked in: ath79_wdt ledtrig_netdev xt_conntrack xt_CT xt_NOTRACK iptable_raw xt_state nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack ipt_REJECT xt_TCPMSS ipt_LOG xt_comment xt_multiport xt_mac xt_limit iptable_mangle iptable_filter ip_tables xt_tcpudp x_tables ath9k(O) ath9k_common(O) ath9k_hw(O) ath(O) mac80211(O) usbcore usb_common nls_base crc_ccitt cfg80211(O) compat(O) arc4 aes_generic crypto_algapi ledtrig_timer ledtrig_default_on leds_gpio gpio_button_hotplug(O)
[ 110.620000] Process rssileds (pid: 1022, threadinfo=8334e000, task=83b055a0, tls=77191440)
[ 110.620000] Stack : 8305e000 ffffffea 8330c780 8334faa8 0000006e 24e80ecd 83171000 00000000
[ 110.620000] 831fcc18 8334fab0 8334fab0 83117a80 00000000 83313800 83026be4 80192ba4
[ 110.620000] 8330c780 ffffff86 8330c780 00000000 83b5f240 83018a3c 8334fae0 00000000
[ 110.620000] 00000000 83b5f600 8334fab8 80192ba4 8334fab0 8334fab8 83288388 831fc000
[ 110.620000] 00401010 0003001a 030dffc1 00000000 0000000a 00000000 00000000 00000000
[ 110.620000] ...
[ 110.620000] Call Trace:
[ 110.620000] [<83141974>] minstrel_get_expected_throughput+0x14/0x28 [mac80211]
[ 110.620000] [<83105af8>] sta_set_sinfo+0x3e4/0x41c [mac80211]
[ 110.620000] [<83117a80>] ieee80211_dump_station+0x6c/0x94 [mac80211]
[ 110.620000] [<83018a3c>] nl80211_dump_station+0xac/0x13c [cfg80211]
[ 110.620000] [<80222ab8>] netlink_dump+0x70/0x21c
[ 110.620000] [<80223738>] netlink_dump_start+0x134/0x198
[ 110.620000] [<80225ca0>] genl_rcv_msg+0x100/0x214
[ 110.620000] [<80225170>] netlink_rcv_skb+0x6c/0xe8
[ 110.620000] [<80225b90>] genl_rcv+0x24/0x34
[ 110.620000] [<80224ac8>] netlink_unicast+0x15c/0x22c
[ 110.620000] [<80224eb4>] netlink_sendmsg+0x240/0x2d0
[ 110.620000] [<801f2e44>] sock_sendmsg+0x84/0xa4
[ 110.620000] [<801f30d0>] sys_sendmsg+0x1a4/0x24c
[ 110.620000] [<801f49ac>] sys_sendmsg+0x48/0x7c
[ 110.620000] [<8006a804>] stack_done+0x20/0x40
[ 110.620000]
[ 110.620000]
[ 110.620000] Code: 8c830034 70a22002 00831021
[ 110.620000] 24022580 70621002 03e00008 00021282 27bdffd8
[ 110.890000] ---[ end trace f1d02e06243496bf ]---
[ 110.900000] wlan0: authenticated

cat /etc/config/network

config interface 'loopback'

option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'

option _orig_ifname 'eth0 wlan0 wlan0-1'
option _orig_bridge 'true'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option mtu '1500'
option metric '0'
option ifname 'eth0'

config interface 'stabridge'

option proto 'relay'
list network 'lan'
list network 'wwan'

config interface 'wwan'

option _orig_ifname 'wlan0'
option _orig_bridge 'false'
option proto 'dhcp'

ps ax

PID TTY STAT TIME COMMAND

1 ? Ss 0:01 init
2 ? S 0:00 [kthreadd]
3 ? S 0:02 [ksoftirqd/0]
4 ? S 0:00 [kworker/0:0]
5 ? S 0:04 [kworker/u:0]
6 ? S< 0:00 [khelper]
7 ? S 0:03 [kworker/u:1]

61 ? S 0:00 [sync_supers]
63 ? S 0:00 [bdi-default]
65 ? S< 0:00 [kblockd]
96 ? S 0:00 [kswapd0]

144 ? S 0:00 [fsnotify_mark]
173 ? S< 0:00 [ath79-spi]
184 ? S 0:00 [mtdblock0]
189 ? S 0:00 [mtdblock1]
194 ? S 0:00 [mtdblock2]
199 ? S 0:00 [mtdblock3]
204 ? S 0:00 [mtdblock4]
209 ? S 0:00 [mtdblock5]
214 ? S 0:00 [mtdblock6]
219 ? S 0:00 [mtdblock7]
469 ? SN 0:00 [jffs2_gcd_mtd4]
490 ttyATH0 Ss 0:00 /bin/ash --login
524 ? S< 0:00 [cfg80211]
537 ? S 0:00 [khubd]
592 ? Ss 0:00 /sbin/syslogd -l 8 -C16
594 ? Ss 0:00 /sbin/klogd
596 ? S 0:00 /sbin/hotplug2 --override --persistent --set-rules-fi
608 ? Ss 0:00 /sbin/ubusd
613 ? Ss 0:00 /sbin/netifd
726 ? Ss 0:00 /sbin/watchdog -t 5 /dev/watchdog
940 ? Ss 0:00 /usr/sbin/crond -c /etc/crontabs -l 8 -L /dev/null
963 ? Ss 0:00 /usr/sbin/dropbear -P /var/run/dropbear.1.pid -p 22
981 ? Ss 0:00 /usr/sbin/uhttpd -f -h /www -r dart.rural-network.lan

1003 ? Ds 0:27 /usr/sbin/rssileds wlan0 40000 1 alfa:red:signal1 1 7
1012 ? Ss 0:01 /sbin/haveged -w 1024 -d 32 -i 32 -v 1
1020 ? Ss 0:00 /usr/sbin/ntpd -n -p 0.openwrt.pool.ntp.org -p 1.open

17072 ? S 0:00 [kworker/0:2]
17246 ? Ss 0:00 /usr/sbin/relayd -I eth0 -I wlan0 -B -D
17288 ? Ss 0:00 wpa_supplicant -B -P /var/run/wifi-wlan0.pid -D nl802
17350 ? S 0:00 udhcpc -p /var/run/udhcpc-wlan0.pid -s /lib/netifd/dh
27055 ttyATH0 R+ 0:00 ps ax

Let me know if other information are needed

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by nbd

please test if this patch fixes the issue: http://nbd.name/minstrel-crash-fix.patch

comment:2 Changed 4 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in r41801, r41803

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.