Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#16991 closed defect (fixed)

LEDs mapped to wrong GPIOs on WRTSL54GS

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: kernel Version: Trunk
Keywords: wrtsl54gs gpio led leds Cc:

Description

Hello!

I compiled and flashed the lastest OpenWRT trunk revision and encountered a problem with the LEDs on my WRTSL54GS.

Quickly summarized:

  • Wrong GPIOs for WRTSL54GS defined in target/linux/brcm47xx/patches-3.10/140-MIPS-BCM47XX-add-button-and-led-configuration-for-so.patch
  • a WLAN LED is defined, which is not available via GPIO

See attachment for fix.

Additional info:

root@OpenWrt:/sys/class/leds# ls
b43-phy0::radio     b43-phy0::rx        b43-phy0::tx        bcm47xx:orange:wps  bcm47xx:unk:dmz     bcm47xx:unk:power   bcm47xx:unk:wlan    bcm47xx:white:wps

Here is which LED is actually toggled in the above directory:
bcm47xx:unk:dmz -> SES LED (orange)
bcm47xx:unk:wlan -> DMZ
bcm47xx:unk:power -> Power
bcm47xx:*:wps dont affect any LED.

The correct GPIO numbers can be found here:
http://wiki.openwrt.org/toh/linksys/wrtsl54gs#gpio

Attachments (1)

wrtsl54gs-led-fix.patch (942 bytes) - added by anonymous 4 years ago.

Download all attachments as: .zip

Change History (8)

Changed 4 years ago by anonymous

comment:1 Changed 4 years ago by Zajec

Hauke: you added bcm47xx_leds_linksys_wrtsl54gs in 96c10de. It was supposed to be based on broadcom-diag, but I think broadcom-diag never had such entry, see 1e1e587

Do you think we can follow anonymous's patch (just put it in a correct file)?

comment:2 Changed 4 years ago by Zajec

anonymous: what color are power and DMZ LEDs?

comment:3 Changed 4 years ago by anonymous

They are both green. All LEDs are green except SES orange and SES white.

comment:4 follow-up: Changed 4 years ago by anonymous

These wrong GPIO entries match with WRT54G: http://wiki.openwrt.org/oldwiki/port.gpio
So, whoever wrote this code section confused the WRTSL54GS with a WRT54GS, or just assumed they both use the same GPIO layout (which is not the case).

comment:5 Changed 4 years ago by Zajec

Fixed in r41516

comment:6 Changed 4 years ago by hauke

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r41516

comment:7 in reply to: ↑ 4 Changed 4 years ago by anonymous

See ticket #17062 for a problem related to this ticket:
WRT54(G/GL/GS) actually have the GPIO layout of WRTSL54GS, so comment 4 is indeed true.
So, my suspicion from comment 4 was true - they both were accidentally switched.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.