Modify

Opened 11 years ago

Closed 10 years ago

#1677 closed defect (fixed)

alsa does not run correctly on 2.6 kernel

Reported by: john@… Owned by: developers
Priority: normal Milestone:
Component: packages Version:
Keywords: Cc:

Description

alsa-lib needs kmod-alsa, which is only available on 2.4. also nodes are created in /dev and not /dev/snd, which causes apps like aplay to not find any devices

root@OpenWrt:/dev# aplay -l

aplay: device_list:222: no soundcards found...

root@OpenWrt:/dev#

attached patch uses different alsa-libs DEPEND for 2.4 and 2.6 and modifies hotplug2.rules , such that all works smoothly under 2.6

Attachments (1)

alsa.patch (1.3 KB) - added by john@… 11 years ago.

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by john@…

comment:1 Changed 11 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in [7246], thanks !

comment:2 Changed 11 years ago by johncass

  • Resolution fixed deleted
  • Status changed from closed to reopened

Should the timer device also be created in /dev/snd? I think i remember having a problem with this before.
John

comment:3 Changed 11 years ago by florian

Yes, this would be ideal.

comment:4 Changed 10 years ago by blogic

  • Resolution set to fixed
  • Status changed from reopened to closed

closed in [9314]

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.