Modify

Opened 4 years ago

Closed 4 years ago

#16768 closed defect (wontfix)

TL-WR1043ND v1 unable to add DMZ VLAN

Reported by: alejandro_liu@… Owned by: developers
Priority: normal Milestone: Attitude Adjustment 12.09.1
Component: base system Version: Attitude Adjustment 12.09
Keywords: Cc:

Description

I am trying to add a DMZ VLAN to a TL-WR1043ND v1. So, I created VLAN1 (LAN), VLAN2 (WAN) and VLAN3 (DMZ).

VLAN1 on ports 1-4 untagged.
VLAN2 on port 0 untagged and 4 tagged
and VLAN3 on port 4 tagged only.

I can ping my test IP addresses on VLAN1 and VLAN2, but VLAN3 does not seem to work. The LED light does not even blink for port 4.

For troubleshooting I stopped the firewall.

My /etc/config/network looks like this:

config interface 'loopback'
  option ifname 'lo'
  option proto 'static'
  option ipaddr '127.0.0.1'
  option netmask '255.0.0.0'

config interface wan0
    option ifname eth0.2
    option proto dhcp

config interface lan0
    option ifname eth0.1
    option proto static
    option ipaddr 172.18.1.1
    option netmask 255.255.255.0

config interface lan1
    option ifname eth0.3
    option proto static
    option ipaddr 172.18.3.1

config switch
	option name rtl8366rb
	option reset 1
	option enable_vlan 1


config switch_vlan
    option device rtl8366rb
    option vlan 2
    option ports '0 4t 5t'

config switch_vlan
    option device rtl8366rb
    option vlan 1
    option ports '1 2 3 4 5t'

config switch_vlan
    option device rtl8366rb
    option vlan 3
    option ports '4t 5t'

config switch_port
	option port	0
	option pvid	2

config switch_port
	option port	1
	option pvid	1

config switch_port
	option port	2
	option pvid	1

config switch_port
	option port	3
	option pvid	1

config switch_port
	option port	4
	option pvid	1

config switch_port
	option port	5
	option pvid	1


Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by nbd

  • Resolution set to wontfix
  • Status changed from new to closed

configuring a port to be both tagged and untagged at the same time is not supported

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.