Modify

Opened 4 years ago

Last modified 4 years ago

#16721 new defect

uhttpd crashes when libpolarssl is upgraded from 1.3.4-1 to 1.3.7-1

Reported by: anonymous Owned by: developers
Priority: high Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: uhttpd libpolarssl r41037 Cc:

Description

When upgrading from 152-r40756 to 153-r41037, libpolarssl gets upgraded, and uhttpd crashes on start

syslog reports:

Instance uhttpd::instance1 s in a crash loop 6 crashes, 0 seconds since last crash

Upgrading everything _EXCEPT_ libpolarssl works, and uhttpd continues to work. Without this, of course, luci is unavailable - hence raising as high priority

Attachments (0)

Change History (4)

comment:1 Changed 4 years ago by anonymous

NB, I am using luci and luci-ssl

comment:2 Changed 4 years ago by nbd

Are you upgrading packages via opkg? If so, you need to explicitly reinstall libustream-polarssl, since its ABI depends on the one of libpolarssl.

comment:3 Changed 4 years ago by anonymous

OpenWrt Barrier Breaker r41055 (via sysupgrade).
opkg update
opkg install uhttpd
/etc/init.d/uhttpd enable
/etc/init.d/uhttpd start
....
nothing
...
looking up:
ps w | grep uhttp
...
nothing
...
after uncommenting the debugging lines in /etc/init.d/uhttpd and doing
/etc/init.d/uhttpd start
again:

Error: No sockets bound, unable to continue

This also happened before installing px5g -> and libpolarssl.

Now more or less happily using lighttpd.

Why does not OpenWRT use the busybox httpd? It's way smaller.

comment:4 Changed 4 years ago by jow

You probably still have ssl enabled in /etc/config/uhttpd and forgot to install uhttpd-mod-tls

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.