Modify

Opened 4 years ago

Closed 3 years ago

#16697 closed defect (fixed)

802.11s Mesh options are not supported in Trunk?

Reported by: Henning Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: Cc:

Description

Hi, I have been using the /etc/config/wireless file in Attitude Adjustment to set options for a 802.11s mesh. After moving to Trunk, these options are not working anymore.

The following example worked with Attitude Adjustment, but the last line (mesh_fwding) is ignored in Trunk (as far as I can tell with "iw wlan0 get mesh_param").

config wifi-iface

option device radio0
option network WIFI
option mode mesh
option mesh_id confine_mesh
option mesh_fwding 0

Attachments (1)

80211sfix.patch (933 bytes) - added by Henning 3 years ago.
Possible fix for missing mesh_parameters with 802.11s and encryption

Download all attachments as: .zip

Change History (12)

comment:1 Changed 4 years ago by zloop

It is working in trunk (seeing it changed from 1 to 0)

  • your config file seems broken
iw dev wlan0 get mesh_param
...
mesh_fwding = 0
...

my /etc/config/wireless is

config wifi-iface
        option encryption 'none'
        option device 'radio0'
        option mode 'mesh'
        option mesh_id 'meshy'
        option network 'meshy'
        option mesh_fwding '0'

you could write something in the OpenWrt wiki what you are doing with that option, too
http://wiki.openwrt.org/inbox/mesh.80211s

comment:2 Changed 4 years ago by Henning

Okay, I think I got closer to the problem. After adding some debug output to /lib/netifd/wireless/mac80211.sh I noticed an error message:

Wed Jun 11 14:51:38 2014 daemon.notice netifd: radio0 (5020): command failed: Link has been severed (-67)

This seems to be the error message from the "iw dev wlan0 set mesh_param mesh_fwding 0" command, at least it happens exactly between the logging before and after the command:

Wed Jun 11 14:51:37 2014 kern.info kernel: [ 1526.770000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Wed Jun 11 14:51:38 2014 daemon.debug mesh_log: 1
Wed Jun 11 14:51:38 2014 daemon.debug mesh_log: iw dev wlan0 set mesh_param mesh_fwding 0
Wed Jun 11 14:51:38 2014 daemon.notice netifd: radio0 (5020): command failed: Link has been severed (-67)
Wed Jun 11 14:51:38 2014 daemon.debug mesh_log: 1
Wed Jun 11 14:51:38 2014 kern.info kernel: [ 1526.980000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Wed Jun 11 14:51:38 2014 daemon.notice netifd: Network device 'wlan0' link is up

(the "mesh_log" messages are my debugging output, the first two are before the set command, the third one is afterwards)

Maybe there is a race condition in the config-script that tries to set the value too early?

comment:3 Changed 3 years ago by Henning

I have just tested this with the latest barrier breaker on an Ubiquiti Bullet M5... the error is still there and the flag is NOT set during boot.

Any ideas what to do?

comment:4 Changed 3 years ago by cb@…

Just tested this on a Engenius ESR1750: setting the mesh options via uci spews out Link has been severed (-67) messages, setting them manually via iw a bit later works, though. Apparently some timing issue...

comment:5 Changed 3 years ago by nbd

please try current trunk

comment:6 Changed 3 years ago by anonymous

Yeah same issue with r44797.

comment:7 Changed 3 years ago by Henning

I just noticed today that I had (again) this problem. After some experiments I noticed the problem does (for my device, Ubiquity Bullet M2) only happen if I active AES encryption.

Mesh parameters are working well without encryption.

comment:8 Changed 3 years ago by Henning

The attached patch "80211sfix.patch" fixes the problem for me with Barrier Breaker (commit 229d60fdb45c34902d402938e231c006f7c73931).

Changed 3 years ago by Henning

Possible fix for missing mesh_parameters with 802.11s and encryption

comment:9 Changed 3 years ago by cb@…

Confirmed. Aforementioned patch fixes the issue for me.

comment:10 Changed 3 years ago by cb@…

Confirmed. Aforementioned patch fixes the issue for me.

comment:11 Changed 3 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fix committed in r45651

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.