Modify

Opened 11 years ago

Closed 9 years ago

Last modified 4 years ago

#1669 closed defect (worksforme)

Problem getting a WAN IP address via DHCP (Broadcom based routers)

Reported by: kebab Owned by: developers
Priority: highest Milestone: Barrier Breaker 14.07
Component: base system Version:
Keywords: Cc:

Description

My Broadcom based routers are unable to get a WAN IP address via DHCP. I have tested this on both Belkin F5D7231-4P and Buffalo WHR-G54S. Both routers previously ran Whiterussian successfully, but under Kamikaze they have been unable to get a WAN IP address (even with 11th May snapshot). My ADSL router is a Netgear DG824, Kamikaze simply relays DHCP addresses from the ADSL router to wireless clients (PC's, PDA, laptop etc). The same ADSL router was used successfully, when Whiterussian was installed on the Belkin and Buffalo routers.

I found the following thread, detailing similar problems: http://forum.openwrt.org/viewtopic.php?id=8435

The routers run with the standard Kamikaze configuration files i.e. no settings are changed from those in the snapshot firmware image.

Image used:
http://downloads.openwrt.org/snapshots/brcm-2.4/openwrt-brcm-2.4-squashfs.trx

The attached file "Kamikaze WAN DHCP problem.txt" details a process list and ifconfig with the routers WAN port plugged into the ADSL router at boot time. It also details a process list and ifconfig with the routers WAN port disconnected from the ADSL router at boot time.

Attachments (1)

Kamikaze WAN DHCP problem.txt (5.9 KB) - added by anonymous 11 years ago.

Download all attachments as: .zip

Change History (15)

Changed 11 years ago by anonymous

comment:1 Changed 11 years ago by anonymous

I've just tested again, connected to a Draytek 2800 instead of the Netgear DG834 ADSL router, the same problem occurred, the Broadcom routers running Kamikaze could not get a WAN IP address. So the problem does not appear to be related to the particular ADSL router being used.

comment:2 Changed 11 years ago by Sergio B Serafim

Did you found any solution?? I am having the same problem, had to buy another WRT54GS so I can work. :(

comment:3 Changed 11 years ago by anonymous

Could it not be that you have to spoof a mac address in order to get your router working? you can do this by adding 'option maccaddr 11:22:33:44:55:66' into /etc/config/network under 'lan'. change the numbers ofc.

comment:4 Changed 11 years ago by heriyanto binduni

i use kamikaze 7.06 on asus wl500gp and connect to allied telesyn at-ar236e adsl bridge/router and i can get the ip address for my wan via dhcp. maybe it only effect on some adsl modem? i just need my adsl modem being on before i turn on my wl500gp to get it working.

comment:5 Changed 11 years ago by KadettGTE devilboy@…

i had this problem with the wl500gp, just had to change the vlan configuration

comment:6 Changed 11 years ago by nickmit.zheng@…

anyone can give me a datasheet, I'm willing to work out this

comment:7 follow-up: Changed 10 years ago by gerti-openwrt@…

Using the same configuration I was using on a WRT54GL V1.1 on a WRT54G V2.0 I see the same problem, the WAN port does not pick up a DHCP address. I suspect some problem in the VLAN setup.

I can get into the box, if someone has some ideas what to check please let me know.

comment:8 in reply to: ↑ 7 ; follow-up: Changed 10 years ago by anonymous

Replying to gerti-openwrt@bitart.com:

Using the same configuration I was using on a WRT54GL V1.1 on a WRT54G V2.0 I see the same problem, the WAN port does not pick up a DHCP address. I suspect some problem in the VLAN setup.

I can get into the box, if someone has some ideas what to check please let me know.

Note: It does pick up an IP address for the WAN port, it just fails to set it! I have it configured as wireless client. I see DHCP requests on my DHCP server for both the wireless interface (through which I then can connect fine) and the WAN port. The WAN IP never appears to be set:

root@OpenWrt:~# ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:0C:41:D0:2C:61

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:72 errors:0 dropped:0 overruns:0 frame:0
TX packets:90 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:9718 (9.4 KiB) TX bytes:29442 (28.7 KiB)
Interrupt:5

eth0.0 Link encap:Ethernet HWaddr 00:0C:41:D0:2C:61

inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:65 errors:0 dropped:0 overruns:0 frame:0
TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:7997 (7.8 KiB) TX bytes:658 (658.0 B)

eth0.1 Link encap:Ethernet HWaddr 00:0C:41:D0:2C:61

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:89 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:28747 (28.0 KiB)

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wl0 Link encap:Ethernet HWaddr 00:0C:41:D0:2C:63

inet addr:192.168.42.250 Bcast:192.168.42.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:110 errors:0 dropped:0 overruns:0 frame:559
TX packets:47 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:13006 (12.7 KiB) TX bytes:7633 (7.4 KiB)
Interrupt:4 Base address:0x1000

comment:9 in reply to: ↑ 8 Changed 10 years ago by anonymous

Figured it out:

WRT54G V2.0:

option vlan0 "1 2 3 4 5*"
option vlan1 "0 5"

WRT54GL V1.1:

option vlan0 "0 1 2 3 5*"
option vlan1 "4 5"

comment:10 Changed 10 years ago by anonymous

I'm using v3.1 and having this same problem, does anyone have any solutions that work (I tried the v2.0 and v1.1 solutions above with no joy).

comment:11 Changed 10 years ago by anonymous

I am the poster in comment #10 on this ticket.

I found the cause of my problem, my router (ie. the device connected via the "Internet" port on my Linksys which provides me with cable connectivity from my upstream and gives me a DHCP address) needed to be reset. It only is interested in giving DHCP leases to one MAC address, and it seems like when I install kamakazie my MAC is different in some way that it refuses to give a DHCP lease to it.

Solution: restart my cable modem

comment:12 Changed 10 years ago by anonymous

Same problem when upgraded in Tomato firmware, so, there is something related to Busybox 1.10.2

comment:13 Changed 9 years ago by jow

  • Resolution set to worksforme
  • Status changed from new to closed

comment:14 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.