Modify

Opened 4 years ago

Closed 4 years ago

#16632 closed defect (duplicate)

acpid won't compile for x86

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: acpid, x86 Cc:

Description

make[3]: Entering directory `/home/development/src/openwrt-trunk/openwrt/feeds/packages/utils/acpid'
make -C /home/development/src/openwrt-trunk/openwrt/build_dir/target-i386_i486_uClibc-0.9.33.2/acpid-2.0.10 CC="i486-openwrt-linux-uclibc-gcc" LD="i486-openwrt-linux-uclibc-gcc" LDFLAGS="-L/home/development/src/openwrt-trunk/openwrt/staging_dir/target-i386_i486_uClibc-0.9.33.2/usr/lib -L/home/development/src/openwrt-trunk/openwrt/staging_dir/target-i386_i486_uClibc-0.9.33.2/lib -L/home/development/src/openwrt-trunk/openwrt/staging_dir/toolchain-i386_i486_gcc-4.8-linaro_uClibc-0.9.33.2/usr/lib -L/home/development/src/openwrt-trunk/openwrt/staging_dir/toolchain-i386_i486_gcc-4.8-linaro_uClibc-0.9.33.2/lib" all
make[4]: Entering directory `/home/development/src/openwrt-trunk/openwrt/build_dir/target-i386_i486_uClibc-0.9.33.2/acpid-2.0.10'
i486-openwrt-linux-uclibc-gcc -W -Wall -Werror -Wundef -Wshadow -D_GNU_SOURCE -O2 -fno-strict-aliasing -g -DVERSION="\"2.0.10\""   -c -o libnetlink.o libnetlink.c
cc1: note: someone does not honour COPTS correctly, passed 0 times
libnetlink.c: In function 'rtnl_open_byproto':
libnetlink.c:45:23: error: argument to 'sizeof' in 'memset' call is the same expression as the destination; did you mean to dereference it? [-Werror=sizeof-pointer-memaccess]
  memset(rth, 0, sizeof(rth));
                       ^
cc1: all warnings being treated as errors
make[4]: *** [libnetlink.o] Error 1
make[4]: Leaving directory `/home/development/src/openwrt-trunk/openwrt/build_dir/target-i386_i486_uClibc-0.9.33.2/acpid-2.0.10'
make[3]: *** [/home/development/src/openwrt-trunk/openwrt/build_dir/target-i386_i486_uClibc-0.9.33.2/acpid-2.0.10/.built] Error 2
make[3]: Leaving directory `/home/development/src/openwrt-trunk/openwrt/feeds/packages/utils/acpid'
make[2]: *** [package/feeds/packages/acpid/compile] Error 2
make[2]: Leaving directory `/home/development/src/openwrt-trunk/openwrt'
make[1]: *** [/home/development/src/openwrt-trunk/openwrt/staging_dir/target-i386_i486_uClibc-0.9.33.2/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/development/src/openwrt-trunk/openwrt'
make: *** [world] Error 2
development@openwrt-devel:~/src/openwrt-trunk/openwrt$

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by anonymous

Please delete or merge with /ticket/13451.html

comment:2 Changed 4 years ago by slachta

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #13451.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.