Modify

Opened 4 years ago

Closed 4 years ago

#16601 closed defect (duplicate)

ath10k on Archer C7 v2 (USA) has a bogus MAC address

Reported by: amluto Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: kernel Version: Trunk
Keywords: Cc:

Description

ip link says:

11: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master br-lan state UP mode DEFAULT group default qlen 1000
    link/ether 00:03:07:12:34:56 brd ff:ff:ff:ff:ff:ff

The boot logs aren't very interesting:

[   10.410000] Loading modules backported from Linux version master-2014-03-31-1-0-g5c109d2
[   10.420000] Backport generated by backports.git backports-20140221-0-g8e94650
[   10.470000] cfg80211: Calling CRDA to update world regulatory domain
[   10.500000] cfg80211: World regulatory domain updated:
[   10.500000] cfg80211:  DFS Master region: unset
[   10.510000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   10.520000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   10.520000] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   10.530000] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[   10.540000] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   10.550000] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   10.560000] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[   10.590000] ath10k_pci 0000:01:00.0: BAR 0: assigned [mem 0x12000000-0x121fffff 64bit]
[   10.600000] PCI: Enabling device 0000:01:00.0 (0000 -> 0002)
[   10.910000] ath10k: pci irq legacy
[   11.820000] ath10k: qca988x hw2.0 (0x4100016c) fw 10.1.467.2-1 api 2 htt 2.1
[   12.340000] ath: EEPROM regdomain: 0x0
[   12.340000] ath: EEPROM indicates default country code should be used
[   12.340000] ath: doing EEPROM country->regdmn map search
[   12.340000] ath: country maps to regdmn code: 0x3a
[   12.340000] ath: Country alpha2 being used: US
[   12.340000] ath: Regpair used: 0x3a

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by amluto

Duplicate of #16589; please close.

comment:2 Changed 4 years ago by florian

  • Resolution set to duplicate
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.