Modify

Opened 4 years ago

Last modified 2 years ago

#16505 reopened defect

AR9331 USB 2.0 Device issues again on WR710nV1 and other devices

Reported by: anonymous Owned by: developers
Priority: high Milestone: Chaos Calmer 15.05
Component: kernel Version: Trunk
Keywords: AR9331 USB2.0 TIMING ISSUES Cc:

Description

Because of this thread:

https://forum.openwrt.org/viewtopic.php?id=39956

There are still issues with native USB 2.0 devices, like Huawei LTE-Sticks E3276, E3272 and E392/E398. This device need a longer time to initialize completly. The first detection is often after 4-6 seconds (directly after firmwareboot of the device itself)

  • The device is not recognized many times after coldboot
  • Sometimes it is detected, mostly not
  • When plugged in via a extra usb-cable, 30cm long, instead directly to the box, it is more often detected, but this is no final fix
  • Only by using the "old method" - inserting a passive USB2.0 Highspeedhub all problems are finaly fixed!
  • there is NO Power-Problem with the device itself! When there is a power problem, then the hub-method was not working, too
  • i tryed "old_scheme_first" settings - no changes
  • i disabled the ohci-driver completly to not interfer with

the ehci-processes - a little better sometimes, but no final fix

  • sometimes "usbreset" hangs undefinitly and is not working well
  • ath9k and all correcponding drivers are NOT loaded & disabled! So this time it is no "pll-loop/reset" problem, comming from wifi-devices, etc.!

My investigations shows, that when the errors shows up, ONLY a hard-reboot (power on/off) brings the bus back to life often.

But many times 5-10 coldstarts needed, to correctly detecting the stick again.

My stick has no hardwareproblems, because i have many LTE-Sticks and all sticks shows the same results - and are working perfect on brcm-platforms without any problems.

When the stick is detected, normaly i can plug it in and out, and it is every time detected without problems.

Mostly i got reconnection problems, when i directly insert the stick on the box directly - many less problems i have by using a 30cm long usb extending cable.

Devices switch on/off from a working usb-connection results after a new cold start often in not detected again. Again: Only a passive hub finaly fix the usb 2.0 issues.

After coldboot and not detection some times i can manually plug the stick in and out, and with this 2nd try, the detection is working, again better with external usb-cable.

Using TP-link firmware does not have this bug

The Entire Situation on actual trunk is absolutely sporadic and it looks like that some registers left in a tri-state or are not correctly initialized all the times after a reboot ?

There is a big difference between "reboot" and power on/off.
Mostly simple reboots doesn´t solve anything, only hard resstarts.

Eventually there is a timing problem with initialisation/detection of the external devices.

Please note: The HUAWEI E3276 has an internal USB-Switch included for his NDIS and COM-Ports - all USB 2.0! - Why an extra passive HUB fix all this USB2.0 issues i can´t understand. This Hub-Solution was mainly for the lack of USB 1.1-Support, but in this case, there is only a native USB 2.0 Device plugged in!

Here is my dmesg-log after cold boot:

usbcore: registered new interface driver usb-storage
usb 1-1: new high-speed USB device number 2 using ehci-platform
jffs2: notice: (333) jffs2_build_xattr_subsystem: complete building xattr subsystem, 1 of xdatum (0 unchecked, 0 orphan) and 38 of xref (0 dead, 10 orphan) found.
jffs2: notice: (330) jffs2_build_xattr_subsystem: complete building xattr subsystem, 1 of xdatum (0 unchecked, 0 orphan) and 38 of xref (0 dead, 10 orphan) found.
tun: Universal TUN/TAP device driver, 1.6
tun: (C) 1999-2004 Max Krasnyansky <maxk@qualcomm.com>
u32 classifier
    input device check on
    Actions configured
Mirror/redirect action on
nf_conntrack version 0.5.0 (459 buckets, 1836 max)
usbcore: registered new interface driver cdc_wdm
nf_conntrack_rtsp v0.6.21 loading
nf_nat_rtsp v0.6.21 loading
usbcore: registered new interface driver usbserial
usbcore: registered new interface driver usbserial_generic
usbserial: USB Serial support registered for generic
xt_time: kernel timezone is -0000
usbcore: registered new interface driver cdc_ncm
ip_tables: (C) 2000-2006 Netfilter Core Team
PPP generic driver version 2.4.2
NET: Registered protocol family 24
usbcore: registered new interface driver qmi_wwan
usbcore: registered new interface driver cdc_mbim
usbcore: registered new interface driver option
usbserial: USB Serial support registered for GSM modem (1-port)
usb 1-1: device descriptor read/64, error -145
device eth0 entered promiscuous mode
br-lan: port 1(eth0) entered forwarding state
br-lan: port 1(eth0) entered forwarding state
device eth1 entered promiscuous mode
br-lan: port 1(eth0) entered disabled state
eth0: link up (100Mbps/Full duplex)
br-lan: port 1(eth0) entered forwarding state
br-lan: port 1(eth0) entered forwarding state
br-lan: port 1(eth0) entered forwarding state
usb 1-1: device descriptor read/64, error -145
usb 1-1: new high-speed USB device number 3 using ehci-platform
usb 1-1: device descriptor read/64, error -145
usb 1-1: device descriptor read/64, error -145
usb 1-1: new high-speed USB device number 4 using ehci-platform
usb 1-1: device not accepting address 4, error -145
usb 1-1: new high-speed USB device number 5 using ehci-platform
usb 1-1: device not accepting address 5, error -145
hub 1-0:1.0: unable to enumerate USB device on port 1

after manual plugin/plugout directly after firstboot i got this:

root@etechmobile99:~# logread -f
Fri May 16 12:00:13 2014 kern.info kernel: usb 1-1: new high-speed USB device number 6 using ehci-platform
Fri May 16 12:00:24 2014 kern.err kernel: usb 1-1: device not accepting address 6, error -145
Fri May 16 12:00:24 2014 kern.info kernel: usb 1-1: new high-speed USB device number 7 using ehci-platform
Fri May 16 12:00:24 2014 kern.info kernel: usb-storage 1-1:1.0: USB Mass Storage device detected
Fri May 16 12:00:24 2014 kern.info kernel: scsi0 : usb-storage 1-1:1.0
Fri May 16 12:00:24 2014 user.notice usb-modeswitch: 1-1: Manufacturer=HUAWEI_Technology Product=HUAWEI_Mobile Serial=? 12d1 14fe
Fri May 16 12:00:24 2014 user.notice usb-modeswitch: *******************************************************
Fri May 16 12:00:24 2014 user.notice usb-modeswitch: *
Fri May 16 12:00:24 2014 user.notice usb-modeswitch: * Start of Modem Detection and Connection Information
Fri May 16 12:00:24 2014 user.notice usb-modeswitch: *
Fri May 16 12:00:24 2014 user.notice usb-modeswitch: * Product=HUAWEI_Mobile 12d1 14fe
Fri May 16 12:00:24 2014 user.notice usb-modeswitch: *
Fri May 16 12:00:24 2014 user.notice usb-modeswitch: *******************************************************
Fri May 16 12:00:25 2014 kern.info kernel: usb 1-1: USB disconnect, device number 7
Fri May 16 12:00:25 2014 kern.info kernel: usb 1-1: new high-speed USB device number 8 using ehci-platform
Fri May 16 12:00:25 2014 kern.info kernel: option 1-1:1.0: GSM modem (1-port) converter detected
Fri May 16 12:00:25 2014 kern.info kernel: usb 1-1: GSM modem (1-port) converter now attached to ttyUSB0
Fri May 16 12:00:25 2014 kern.info kernel: option 1-1:1.1: GSM modem (1-port) converter detected
Fri May 16 12:00:25 2014 kern.info kernel: usb 1-1: GSM modem (1-port) converter now attached to ttyUSB1
Fri May 16 12:00:25 2014 kern.info kernel: usb 1-1: MAC-Address: 0c:5b:8f:27:9a:64
Fri May 16 12:00:25 2014 kern.info kernel: cdc_ncm 1-1:1.2 wwan0: register 'cdc_ncm' at usb-ehci-platform-1, Mobile Broadband Network Device, 0c:5b:8f:27:9a:64
Fri May 16 12:00:25 2014 daemon.notice netifd: Interface 'wan' is enabled

This shows still errors, but the device is deteced with a 2nd try!

Attachments (0)

Change History (26)

comment:1 Changed 4 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in r40841

comment:2 Changed 4 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

With SVN 41055 the problems on WR710Nv1 are back without a passive HUB :(

usb 1-1: new high-speed USB device number 2 using ehci-platform
usb 1-1: device not accepting address 2, error -145
usb 1-1: new high-speed USB device number 3 using ehci-platform
usb 1-1: device descriptor read/64, error -145
usb 1-1: device descriptor read/64, error -145
usb 1-1: new high-speed USB device number 4 using ehci-platform
usb 1-1: device not accepting address 4, error -145
usb 1-1: new high-speed USB device number 5 using ehci-platform
usb 1-1: device not accepting address 5, error -145
hub 1-0:1.0: unable to enumerate USB device on port 1

comment:3 Changed 4 years ago by anonymous

Tested with an old SVN 40820 it works again

comment:4 Changed 4 years ago by anonymous

Sorry, i was SVN 40842, that was the version with the first AR9331 fix that is working

comment:5 Changed 4 years ago by nbd

Did you do a clean build after updating your tree?

comment:6 Changed 4 years ago by anonymous

after i investigated more devices with SVN 41055 i figured out a "hardware issue" between WR710nV1.1 and WR710nV1.2 !

I tested 5 devices v1.2 (green led) and 2 devices v1.1 (blue led)

And the result is reproduceable on ALL devices:

the v1.2 hardware works always perfect with directly attached LTE-stick
the v1.1 hardware never works WITHOUT an extra attached passive USB 2.0 Hub!

I opened up booth devices and check for different hardware, the flash/ram/cpu
is exactly the same: AR9331-AL3A (Taiwan) - so the cpu is 100% the same!

But i figured out, that the usb-connectors "feeding" is a little bit changed
with extra condensors and a few SMD parts are replaced/changed?

So my conclusion is: There is NO Power-Problem on the v1.1 Model, because
with an extra hub in the middle, this combination consumes more power as without -
but it works this way!

With the older v1.1 model, there is a timing issue, as this results from the "different"
d+/d- coupling/pulldown/pullup, or something else.

So i think it make sense the timing in the ehci-driver to modify and be more relaxed
after a "power" on - There is still the same "streaming" problem as before with SVN < 40842.

Playing with the "gpio8 0/1" trick to switch off usb power works after a coldboot,
but it is far from perfect, because it´s not always working.

This is the result from a v1.1 without passive hub:

Sun Jun  8 18:16:18 2014 kern.info kernel: usb 1-1: new high-speed USB device number 2 using ehci-platform
Sun Jun  8 18:16:18 2014 kern.info kernel: usb-storage 1-1:1.0: USB Mass Storage device detected
Sun Jun  8 18:16:18 2014 kern.info kernel: scsi0 : usb-storage 1-1:1.0
Sun Jun  8 18:16:18 2014 user.notice usb-modeswitch: 1-1: Manufacturer=HUAWEI_Technology Product=HUAWEI_Mobile Serial=? 12d1 14fe
Sun Jun  8 18:16:18 2014 user.notice usb-modeswitch: *******************************************************
Sun Jun  8 18:16:18 2014 user.notice usb-modeswitch: *
Sun Jun  8 18:16:18 2014 user.notice usb-modeswitch: * Start of Modem Detection and Connection Information
Sun Jun  8 18:16:18 2014 user.notice usb-modeswitch: *
Sun Jun  8 18:16:18 2014 user.notice usb-modeswitch: * Product=HUAWEI_Mobile 12d1 14fe
Sun Jun  8 18:16:18 2014 user.notice usb-modeswitch: *
Sun Jun  8 18:16:18 2014 user.notice usb-modeswitch: *******************************************************
Sun Jun  8 18:16:19 2014 kern.info kernel: usb 1-1: USB disconnect, device number 2
Sun Jun  8 18:16:19 2014 kern.info kernel: usb 1-1: new high-speed USB device number 3 using ehci-platform
Sun Jun  8 18:16:28 2014 user.notice usb-modeswitch: *******************************************************
Sun Jun  8 18:16:28 2014 user.notice usb-modeswitch: *
Sun Jun  8 18:16:29 2014 user.notice usb-modeswitch: * Switched to : :
Sun Jun  8 18:16:29 2014 user.notice usb-modeswitch: *
Sun Jun  8 18:16:29 2014 user.notice usb-modeswitch: *******************************************************
Sun Jun  8 18:16:29 2014 user.notice usb-modeswitch: BasePort : 0
Sun Jun  8 18:16:35 2014 kern.err kernel: usb 1-1: device descriptor read/64, error -145
Sun Jun  8 18:16:50 2014 kern.err kernel: usb 1-1: device descriptor read/64, error -145
Sun Jun  8 18:16:50 2014 kern.info kernel: usb 1-1: new high-speed USB device number 4 using ehci-platform
Sun Jun  8 18:16:55 2014 user.notice usb-modeswitch: *******************************************************
Sun Jun  8 18:16:55 2014 user.notice usb-modeswitch: *
Sun Jun  8 18:16:55 2014 user.notice usb-modeswitch: * ProtoFind returns : 0
Sun Jun  8 18:16:55 2014 user.notice usb-modeswitch: *
Sun Jun  8 18:16:55 2014 user.notice usb-modeswitch: *******************************************************
Sun Jun  8 18:16:55 2014 user.notice usb-modeswitch: Ignore Remove after connection 1d6b

This is the result on a v1.1 WITH a passive 2.0 HUB:

Sun Jun  8 18:17:05 2014 kern.info kernel: usb 1-1: new high-speed USB device number 5 using ehci-platform
Sun Jun  8 18:17:06 2014 kern.info kernel: hub 1-1:1.0: USB hub found
Sun Jun  8 18:17:06 2014 kern.info kernel: hub 1-1:1.0: 4 ports detected
Sun Jun  8 18:17:06 2014 user.notice usb-modeswitch: 1-1: Manufacturer=? Product=USB2.0_Hub Serial=? 05e3 0608
Sun Jun  8 18:17:06 2014 user.notice usb-modeswitch: Ignoring Unnamed Hub
Sun Jun  8 18:17:16 2014 kern.info kernel: usb 1-1.3: new high-speed USB device number 6 using ehci-platform
Sun Jun  8 18:17:16 2014 kern.info kernel: usb-storage 1-1.3:1.0: USB Mass Storage device detected
Sun Jun  8 18:17:16 2014 kern.info kernel: scsi1 : usb-storage 1-1.3:1.0
Sun Jun  8 18:17:16 2014 user.notice usb-modeswitch: 1-1.3: Manufacturer=HUAWEI_Technology Product=HUAWEI_Mobile Serial=? 12d1 14fe 
Sun Jun  8 18:17:16 2014 user.notice usb-modeswitch: *******************************************************
Sun Jun  8 18:17:16 2014 user.notice usb-modeswitch: *
Sun Jun  8 18:17:16 2014 user.notice usb-modeswitch: * Start of Modem Detection and Connection Information
Sun Jun  8 18:17:16 2014 user.notice usb-modeswitch: *
Sun Jun  8 18:17:16 2014 user.notice usb-modeswitch: * Product=HUAWEI_Mobile 12d1 14fe
Sun Jun  8 18:17:16 2014 user.notice usb-modeswitch: *
Sun Jun  8 18:17:16 2014 user.notice usb-modeswitch: *******************************************************
Sun Jun  8 18:17:17 2014 kern.info kernel: usb 1-1.3: USB disconnect, device number 6
Sun Jun  8 18:17:17 2014 kern.info kernel: usb 1-1.3: new high-speed USB device number 7 using ehci-platform
Sun Jun  8 18:17:17 2014 kern.info kernel: option 1-1.3:1.0: GSM modem (1-port) converter detected
Sun Jun  8 18:17:17 2014 kern.info kernel: usb 1-1.3: GSM modem (1-port) converter now attached to ttyUSB0
Sun Jun  8 18:17:17 2014 kern.info kernel: option 1-1.3:1.1: GSM modem (1-port) converter detected
Sun Jun  8 18:17:17 2014 kern.info kernel: usb 1-1.3: GSM modem (1-port) converter now attached to ttyUSB1
Sun Jun  8 18:17:17 2014 kern.info kernel: usb 1-1.3: MAC-Address: 0c:5b:8f:27:9a:64
Sun Jun  8 18:17:17 2014 kern.info kernel: cdc_ncm 1-1.3:1.2 wwan0: register 'cdc_ncm' at usb-ehci-platform-1.3, Mobile Broadband Network Device, 0c:5b:8f:27:9a:64
Sun Jun  8 18:17:26 2014 user.notice usb-modeswitch: *******************************************************
Sun Jun  8 18:17:26 2014 user.notice usb-modeswitch: *
Sun Jun  8 18:17:26 2014 user.notice usb-modeswitch: * Switched to : 12d1:1506
Sun Jun  8 18:17:26 2014 user.notice usb-modeswitch: *
Sun Jun  8 18:17:27 2014 user.notice usb-modeswitch: *******************************************************
Sun Jun  8 18:17:27 2014 user.notice usb-modeswitch: BasePort : 0
Sun Jun  8 18:17:27 2014 user.notice usb-modeswitch: *******************************************************
Sun Jun  8 18:17:27 2014 user.notice usb-modeswitch: *
Sun Jun  8 18:17:27 2014 user.notice Script Print : Driver Name : 1 option
Sun Jun  8 18:17:27 2014 user.notice Script Print : Driver Name : 2 option
Sun Jun  8 18:17:27 2014 user.notice Script Print : Driver Name : 3 cdc_ncm
Sun Jun  8 18:17:27 2014 user.notice Script Print : Driver Name : 4 cdc_ncm
Sun Jun  8 18:17:27 2014 user.notice usb-modeswitch: * ProtoFind returns : 6
Sun Jun  8 18:17:27 2014 user.notice usb-modeswitch: *
Sun Jun  8 18:17:27 2014 user.notice usb-modeswitch: *******************************************************
Sun Jun  8 18:17:27 2014 user.notice usb-modeswitch: Modem 1 found
Sun Jun  8 18:17:27 2014 user.notice sierra_set: Connection is active for NCM
Sun Jun  8 18:17:45 2014 daemon.notice netifd: Interface 'wan' is enabled
Sun Jun  8 18:17:45 2014 kern.info kernel: cdc_ncm: wwan0: 43 mbit/s downlink 43 mbit/s uplink
Sun Jun  8 18:17:45 2014 kern.info kernel: cdc_ncm: wwan0: network connection: connected
Sun Jun  8 18:17:45 2014 daemon.notice netifd: Network device 'wwan0' link is up
Sun Jun  8 18:17:45 2014 daemon.notice netifd: Interface 'wan' has link connectivity
Sun Jun  8 18:17:45 2014 daemon.notice netifd: Interface 'wan' is setting up now
Sun Jun  8 18:17:46 2014 daemon.notice netifd: wan (1888): udhcpc (v1.22.1) started
Sun Jun  8 18:17:46 2014 daemon.notice netifd: wan (1888): Sending discover...
Sun Jun  8 18:17:46 2014 daemon.notice netifd: wan (1888): Sending select for 10.35.249.93...
Sun Jun  8 18:17:46 2014 daemon.notice netifd: wan (1888): Lease of 10.35.249.93 obtained, lease time 518400
Sun Jun  8 18:17:46 2014 daemon.notice netifd: Interface 'wan' is now up
Sun Jun  8 18:17:46 2014 user.notice usb-modeswitch: Modem 1 1-1.3 1-1.3 12d1
Sun Jun  8 18:17:46 2014 user.notice usb-modeswitch: Ignore Remove after connection 12d1
Sun Jun  8 18:17:47 2014 user.notice usb-modeswitch: 1-1.3: Manufacturer=HUAWEI_Technology Product=HUAWEI_Mobile Serial=? 12d1 1506 
Sun Jun  8 18:17:47 2014 user.notice usb-modeswitch: Ignoring Modem 1
Sun Jun  8 18:17:47 2014 user.notice firewall: Reloading firewall due to ifup of wan (wwan0)

comment:7 Changed 4 years ago by anonymous

ALL my tests are cleaned builds, to be sure not to have cross-issues ;-)

comment:8 Changed 3 years ago by anonymous

Same issue here with a E3272 on a MR3020.

comment:9 Changed 3 years ago by sanshinron

Those problems with ehci persist for so long I'm starting to think about giving up on OpenWRT. Proper USB support is absolutely basic stuff and we all need it, yet everywhere I look people have problems with ehci-platform being unable to enumerate usb device. It's happening for quite a long time now.

comment:10 Changed 3 years ago by nbd

please test if current trunk with linux 3.14 handles it better.

comment:11 Changed 3 years ago by nbd

  • Resolution set to no_response
  • Status changed from reopened to closed

comment:12 Changed 3 years ago by john410

  • Resolution no_response deleted
  • Status changed from closed to reopened

Latest trunk still doesn't solve the issue.

Tested with a Huawei E3272 on two different TP-Link TL-MR3020 routers (one v1.8, the other v1.9).

comment:13 Changed 3 years ago by john410

Also, let me add that even with a USB HUB, although it works most of the time, it's not totally stable. The problem becomes clearer when using extroot.

comment:14 Changed 3 years ago by john410

Also, let me add that even with a USB HUB, although it works most of the time, it's not totally stable. The problem becomes clearer when using extroot: after a while, a lot of EXT4-errors start to pop up, indicating that it is not available anymore.

Last edited 3 years ago by john410 (previous) (diff)

comment:15 Changed 3 years ago by anonymous

On WR710N-Models there is a big difference between H/W-Version 1.1(blue LED) and 1.2(green LED)!

The 1.2 Version mostly works WITHOUT a hub, the 1.1 Version mostly NEVER works with this stick (without a extra HUB!)

I compared the Hardware inside, and figured out, that on the v1.2 H/W-Version some Resistors are changed on the USB-Parts.

The Main-Problem is NOT Power, it´s the BUS-Communication with usb 2.0 itself with some devices. My bet is a timing problem in the initial-phase after pluggin in the stick...

One fix vom NBD was a backbort on the 3.10 kernel for while, but this don´t solve the problems on the older v1.1 Version. This fix worked great with MR34xx-Series and WDR3600

comment:16 Changed 3 years ago by john410

Any news about this? I can't wait to go back to my MR3020 with OpenWrt awesomeness, but so far this USB issue makes it unreliable for using when on the go.

comment:17 Changed 3 years ago by john410

Last edited 3 years ago by john410 (previous) (diff)

comment:18 Changed 3 years ago by anonymous

Same issue with E3272 and MR3040 or WR842ND. I noticed that if I use an USB cable with a TDK ZCAT1325 ferrite clamp, problem reduces slightly, but it's far from good.

comment:19 Changed 3 years ago by anonymous

Same problem using r45621 snapshot on Archer C7 v2 :

root@OpenWrt:~# logread -f
Thu May  7 17:26:03 2015 kern.info kernel: [ 2928.040000] usb 1-1: new low-speed USB device number 6 using ehci-platform
Thu May  7 17:26:18 2015 kern.err kernel: [ 2943.220000] usb 1-1: device descriptor read/64, error -145
Thu May  7 17:26:33 2015 kern.err kernel: [ 2958.510000] usb 1-1: device descriptor read/64, error -145
Thu May  7 17:26:33 2015 kern.info kernel: [ 2958.740000] usb 1-1: new low-speed USB device number 7 using ehci-platform
Thu May  7 17:26:48 2015 kern.err kernel: [ 2973.920000] usb 1-1: device descriptor read/64, error -145
Thu May  7 17:27:04 2015 kern.err kernel: [ 2989.210000] usb 1-1: device descriptor read/64, error -145
Thu May  7 17:27:04 2015 kern.info kernel: [ 2989.440000] usb 1-1: new low-speed USB device number 8 using ehci-platform
Thu May  7 17:27:14 2015 kern.err kernel: [ 2999.900000] usb 1-1: device not accepting address 8, error -145
Thu May  7 17:27:15 2015 kern.info kernel: [ 3000.020000] usb 1-1: new low-speed USB device number 9 using ehci-platform
Thu May  7 17:27:25 2015 kern.err kernel: [ 3010.480000] usb 1-1: device not accepting address 9, error -145
Thu May  7 17:27:25 2015 kern.err kernel: [ 3010.480000] usb usb1-port1: unable to enumerate USB device
root@OpenWrt:~# dmesg 
[    0.000000] Linux version 3.18.11 (ashkan@localhost.localdomain) (gcc version 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.04 r45621) ) #1 Thu May 7 20:39:57 IRDT 2015
[    0.000000] MyLoader: sysp=b9b9812d, boardp=fdbebcad, parts=47e7a7e9
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 00019750 (MIPS 74Kc)
[    0.000000] SoC: Qualcomm Atheros QCA9558 ver 1 rev 0
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 08000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x00000000-0x07ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x00000000-0x07ffffff]
[    0.000000] Initmem setup node 0 [mem 0x00000000-0x07ffffff]
[    0.000000] On node 0 totalpages: 32768
[    0.000000] free_area_init_node: node 0, pgdat 803560f0, node_mem_map 81000000
[    0.000000]   Normal zone: 256 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 32768 pages, LIFO batch:7
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc: [0] 0 
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 32512
[    0.000000] Kernel command line:  board=ARCHER-C7 console=ttyS0,115200 rootfstype=squashfs,jffs2 noinitrd
[    0.000000] PID hash table entries: 512 (order: -1, 2048 bytes)
[    0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
[    0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
[    0.000000] Writing ErrCtl register=00000000
[    0.000000] Readback ErrCtl register=00000000
[    0.000000] Memory: 125920K/131072K available (2470K kernel code, 124K rwdata, 528K rodata, 260K init, 188K bss, 5152K reserved)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS:51
[    0.000000] Clocks: CPU:720.000MHz, DDR:600.000MHz, AHB:200.000MHz, Ref:40.000MHz
[    0.000000] Calibrating delay loop... 358.80 BogoMIPS (lpj=1794048)
[    0.060000] pid_max: default: 32768 minimum: 301
[    0.060000] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.070000] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.070000] NET: Registered protocol family 16
[    0.080000] MIPS: machine is TP-LINK Archer C7
[    0.080000] ar724x-pci ar724x-pci.0: PCIe link is down
[    0.090000] registering PCI controller with io_map_base unset
[    0.090000] registering PCI controller with io_map_base unset
[    0.540000] PCI host bridge to bus 0000:00
[    0.550000] pci_bus 0000:00: root bus resource [mem 0x10000000-0x11ffffff]
[    0.550000] pci_bus 0000:00: root bus resource [io  0x0000]
[    0.560000] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
[    0.560000] pci_bus 0000:00: busn_res: [bus 00-ff] end is updated to 00
[    0.560000] PCI host bridge to bus 0000:01
[    0.570000] pci_bus 0000:01: root bus resource [mem 0x12000000-0x13ffffff]
[    0.570000] pci_bus 0000:01: root bus resource [io  0x0001]
[    0.580000] pci_bus 0000:01: No busn resource found for root bus, will use [bus 01-ff]
[    0.580000] pci 0000:01:00.0: [168c:003c] type 00 class 0x028000
[    0.580000] pci 0000:01:00.0: reg 0x10: [mem 0x00000000-0x001fffff 64bit]
[    0.580000] pci 0000:01:00.0: reg 0x30: [mem 0x00000000-0x0000ffff pref]
[    0.580000] pci 0000:01:00.0: supports D1 D2
[    0.580000] pci_bus 0000:01: busn_res: [bus 01-ff] end is updated to 01
[    0.580000] pci 0000:01:00.0: BAR 0: assigned [mem 0x12000000-0x121fffff 64bit]
[    0.590000] pci 0000:01:00.0: BAR 6: assigned [mem 0x12200000-0x1220ffff pref]
[    0.590000] pci 0000:01:00.0: using irq 41 for pin 1
[    0.600000] Switched to clocksource MIPS
[    0.600000] NET: Registered protocol family 2
[    0.610000] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[    0.610000] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[    0.620000] TCP: Hash tables configured (established 1024 bind 1024)
[    0.620000] TCP: reno registered
[    0.630000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.630000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.640000] NET: Registered protocol family 1
[    0.640000] PCI: CLS 0 bytes, default 32
[    0.640000] futex hash table entries: 256 (order: -1, 3072 bytes)
[    0.650000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.660000] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.670000] msgmni has been set to 245
[    0.680000] io scheduler noop registered
[    0.690000] io scheduler deadline registered (default)
[    0.690000] Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
[    0.700000] console [ttyS0] disabled
[    0.720000] serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11, base_baud = 2500000) is a 16550A
[    0.730000] console [ttyS0] enabled
[    0.740000] bootconsole [early0] disabled
[    0.750000] m25p80 spi0.0: found s25fl129p1, expected m25p80
[    0.750000] m25p80 spi0.0: s25fl129p1 (16384 Kbytes)
[    0.760000] 5 tp-link partitions found on MTD device spi0.0
[    0.760000] Creating 5 MTD partitions on "spi0.0":
[    0.770000] 0x000000000000-0x000000020000 : "u-boot"
[    0.770000] 0x000000020000-0x0000001349f4 : "kernel"
[    0.780000] mtd: partition "kernel" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[    0.790000] 0x0000001349f4-0x000000ff0000 : "rootfs"
[    0.800000] mtd: partition "rootfs" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[    0.810000] mtd: device 2 (rootfs) set to be root filesystem
[    0.820000] 1 squashfs-split partitions found on MTD device rootfs
[    0.820000] 0x000000390000-0x000000ff0000 : "rootfs_data"
[    0.830000] 0x000000ff0000-0x000001000000 : "art"
[    0.830000] 0x000000020000-0x000000ff0000 : "firmware"
[    0.850000] switch0: Atheros AR8327 rev. 4 switch registered on ag71xx-mdio.0
[    0.940000] libphy: ag71xx_mdio: probed
[    1.540000] ag71xx ag71xx.0: connected to PHY at ag71xx-mdio.0:00 [uid=004dd034, driver=Atheros AR8216/AR8236/AR8316]
[    1.550000] eth0: Atheros AG71xx at 0xb9000000, irq 4, mode:RGMII
[    2.140000] eth1: Atheros AG71xx at 0xba000000, irq 5, mode:SGMII
[    2.140000] TCP: cubic registered
[    2.150000] NET: Registered protocol family 17
[    2.150000] bridge: automatic filtering via arp/ip/ip6tables has been deprecated. Update your scripts to load br_netfilter if you need this.
[    2.160000] 8021q: 802.1Q VLAN Support v1.8
[    2.180000] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
[    2.180000] Freeing unused kernel memory: 260K (8036f000 - 803b0000)
[    3.200000] init: failed to symlink /tmp -> /var
[    3.200000] init: Console is alive
[    3.210000] init: - watchdog -
[    4.470000] usbcore: registered new interface driver usbfs
[    4.470000] usbcore: registered new interface driver hub
[    4.480000] usbcore: registered new device driver usb
[    4.480000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    4.490000] ehci-platform: EHCI generic platform driver
[    4.500000] ehci-platform ehci-platform.0: EHCI Host Controller
[    4.500000] ehci-platform ehci-platform.0: new USB bus registered, assigned bus number 1
[    4.510000] ehci-platform ehci-platform.0: TX-TX IDP fix enabled
[    4.520000] ehci-platform ehci-platform.0: irq 48, io mem 0x1b000000
[    4.550000] ehci-platform ehci-platform.0: USB 2.0 started, EHCI 1.00
[    4.550000] hub 1-0:1.0: USB hub found
[    4.560000] hub 1-0:1.0: 1 port detected
[    4.560000] ehci-platform ehci-platform.1: EHCI Host Controller
[    4.570000] ehci-platform ehci-platform.1: new USB bus registered, assigned bus number 2
[    4.580000] ehci-platform ehci-platform.1: TX-TX IDP fix enabled
[    4.580000] ehci-platform ehci-platform.1: irq 49, io mem 0x1b400000
[    4.610000] ehci-platform ehci-platform.1: USB 2.0 started, EHCI 1.00
[    4.610000] hub 2-0:1.0: USB hub found
[    4.620000] hub 2-0:1.0: 1 port detected
[    4.620000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    4.630000] ohci-platform: OHCI generic platform driver
[    5.210000] init: - preinit -
[    5.700000] eth1: link up (1000Mbps/Full duplex)
[    5.720000] random: procd urandom read with 9 bits of entropy available
[    9.040000] jffs2: notice: (383) jffs2_build_xattr_subsystem: complete building xattr subsystem, 2 of xdatum (2 unchecked, 0 orphan) and 2 of xref (0 dead, 0 orphan) found.
[    9.060000] mount_root: switching to jffs2 overlay
[    9.170000] eth1: link down
[    9.180000] procd: - early -
[    9.180000] procd: - watchdog -
[    9.840000] procd: - ubus -
[   10.860000] procd: - init -
[   11.600000] NET: Registered protocol family 10
[   11.610000] ip6_tables: (C) 2000-2006 Netfilter Core Team
[   11.630000] hidraw: raw HID events driver (C) Jiri Kosina
[   11.640000] Loading modules backported from Linux version master-2015-03-09-0-g141f155
[   11.650000] Backport generated by backports.git backports-20150129-0-gdd4a670
[   11.660000] ip_tables: (C) 2000-2006 Netfilter Core Team
[   11.670000] nf_conntrack version 0.5.0 (1971 buckets, 7884 max)
[   11.700000] usbcore: registered new interface driver usbhid
[   11.700000] usbhid: USB HID core driver
[   11.720000] xt_time: kernel timezone is -0000
[   11.750000] cfg80211: Calling CRDA to update world regulatory domain
[   11.750000] cfg80211: World regulatory domain updated:
[   11.760000] cfg80211:  DFS Master region: unset
[   11.760000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   11.770000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   11.780000] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   11.790000] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[   11.800000] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   11.810000] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[   11.820000] cfg80211:   (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[   11.820000] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   11.830000] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[   11.900000] PPP generic driver version 2.4.2
[   11.910000] NET: Registered protocol family 24
[   11.970000] ath: EEPROM regdomain: 0x0
[   11.970000] ath: EEPROM indicates default country code should be used
[   11.970000] ath: doing EEPROM country->regdmn map search
[   11.970000] ath: country maps to regdmn code: 0x3a
[   11.970000] ath: Country alpha2 being used: US
[   11.970000] ath: Regpair used: 0x3a
[   11.980000] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[   11.980000] ieee80211 phy0: Atheros AR9550 Rev:0 mem=0xb8100000, irq=47
[   11.990000] cfg80211: Calling CRDA for country: US
[   11.990000] cfg80211: Regulatory domain changed to country: US
[   12.000000] cfg80211:  DFS Master region: FCC
[   12.000000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   12.010000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 3000 mBm), (N/A)
[   12.020000] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 1700 mBm), (N/A)
[   12.030000] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2300 mBm), (0 s)
[   12.040000] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 3000 mBm), (N/A)
[   12.050000] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A)
[   19.330000] eth1: link up (1000Mbps/Full duplex)
[   19.340000] device eth1 entered promiscuous mode
[   19.350000] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[   19.360000] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   20.110000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   20.330000] br-lan: port 1(eth1) entered forwarding state
[   20.330000] br-lan: port 1(eth1) entered forwarding state
[   20.350000] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[   20.720000] eth0: link up (1000Mbps/Full duplex)
[   20.720000] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   22.260000] wlan0: authenticate with f8:d1:11:c4:74:40
[   22.280000] wlan0: send auth to f8:d1:11:c4:74:40 (try 1/3)
[   22.290000] wlan0: authenticated
[   22.300000] wlan0: associate with f8:d1:11:c4:74:40 (try 1/3)
[   22.300000] wlan0: RX AssocResp from f8:d1:11:c4:74:40 (capab=0x431 status=0 aid=5)
[   22.310000] wlan0: associated
[   22.320000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   22.330000] br-lan: port 1(eth1) entered forwarding state
[   22.750000] Atheros AR8216/AR8236/AR8316 ag71xx-mdio.0:00: Port 3 is up
[   70.820000] random: nonblocking pool is initialized
[ 2694.140000] usb 1-1: new low-speed USB device number 2 using ehci-platform
[ 2709.320000] usb 1-1: device descriptor read/64, error -145
[ 2724.610000] usb 1-1: device descriptor read/64, error -145
[ 2724.840000] usb 1-1: new low-speed USB device number 3 using ehci-platform
[ 2740.020000] usb 1-1: device descriptor read/64, error -145
[ 2755.310000] usb 1-1: device descriptor read/64, error -145
[ 2755.540000] usb 1-1: new low-speed USB device number 4 using ehci-platform
[ 2766.000000] usb 1-1: device not accepting address 4, error -145
[ 2766.120000] usb 1-1: new low-speed USB device number 5 using ehci-platform
[ 2776.580000] usb 1-1: device not accepting address 5, error -145
[ 2776.580000] usb usb1-port1: unable to enumerate USB device
[ 2928.040000] usb 1-1: new low-speed USB device number 6 using ehci-platform
[ 2943.220000] usb 1-1: device descriptor read/64, error -145
[ 2958.510000] usb 1-1: device descriptor read/64, error -145
[ 2958.740000] usb 1-1: new low-speed USB device number 7 using ehci-platform
[ 2973.920000] usb 1-1: device descriptor read/64, error -145
[ 2989.210000] usb 1-1: device descriptor read/64, error -145
[ 2989.440000] usb 1-1: new low-speed USB device number 8 using ehci-platform
[ 2999.900000] usb 1-1: device not accepting address 8, error -145
[ 3000.020000] usb 1-1: new low-speed USB device number 9 using ehci-platform
[ 3010.480000] usb 1-1: device not accepting address 9, error -145
[ 3010.480000] usb usb1-port1: unable to enumerate USB device
root@OpenWrt:~# cat /etc/device_info 
DEVICE_MANUFACTURER='OpenWrt'
DEVICE_PRODUCT='Generic'
DEVICE_REVISION='v0'
root@OpenWrt:~# cat /etc/openwrt_release 
DISTRIB_ID='OpenWrt'
DISTRIB_RELEASE='Bleeding Edge'
DISTRIB_REVISION='r45621'
DISTRIB_CODENAME='chaos_calmer'
DISTRIB_TARGET='ar71xx/generic'
DISTRIB_DESCRIPTION='OpenWrt Chaos Calmer r45621'
DISTRIB_TAINTS='no-all'
root@OpenWrt:~# 


comment:20 Changed 3 years ago by anonymous

 usb 2-1: new low-speed USB device number 2 using ehci-platform
 usb 2-1: device descriptor read/64, error -145
 usb 2-1: device descriptor read/64, error -145
 usb 2-1: new low-speed USB device number 3 using ehci-platform
 usb 2-1: device descriptor read/64, error -145
 usb 2-1: device descriptor read/64, error -145
 usb 2-1: new low-speed USB device number 4 using ehci-platform
 usb 2-1: device not accepting address 4, error -145
 usb 2-1: new low-speed USB device number 5 using ehci-platform
 usb 2-1: device not accepting address 5, error -145
 usb usb2-port1: unable to enumerate USB device
 usb 2-1: new low-speed USB device number 6 using ehci-platform
 usb 2-1: device descriptor read/64, error -145

comment:21 Changed 3 years ago by john410

I have three MR3020s. One is v1.8 and the two others are v1.9.

The v1.8 and one of the v1.9s present errors with the Huawei E3276 modem:

The other v1.9 works flawlessly with the same modem, always. Never presented an error, ever.

I tried using the PSU+cables of the good modem on the two others, but it didn't solve the issue.

All of them work fine with the stock firmware.

If there's any testing I can do to help, I'm willing to do so.

comment:22 Changed 3 years ago by john410

I have three MR3020s. One is v1.8 and the two others are v1.9.

The v1.8 and one of the v1.9s present errors with the Huawei E3276 modem:

The other v1.9 works flawlessly with the same modem, always. Never presented an error, ever.

I tried using the PSU+cables of the good modem on the two others, but it didn't solve the issue.

All of them work fine with the stock firmware.

If there's any testing I can do to help, I'm willing to do so.

comment:23 Changed 3 years ago by pozega.tomislav@…

i was using RT3070 usb wifi adapter on my MR13U for a long time without issues until there was a need to move router further away from directional antenna.

5m long usb cable that works with my laptop could not init the adapter when connected to the router. so i bought 1.8m y-usb cable and with only main connector the problem persisted but when plugged another into second (power only) usb port i was able to use adapter.

since ports should give 0.5A and 2A output this was unacceptable that i get so little power and can't connect any cable longer than 2m.

i was trying BB latest revision because of some driver tweaks and found out i'll have to try it with CC to be able to test everything i intended (ath9k_htc)

while testing this adapter (WN722N) with CC i was surprised that my RT3070 adapter also works with only one usb connector attached to router, because it never could work this way in AA or BB.

then i flashed back BB image and to my surprise it continued to work with only main usb connector, until there was a heavy thunderstorm and in the middle of testing thunderstruck hit somewhere near maybe a mile or two, my RT3070 adapter reset and usually it would come up after reboot but this time that didn't happen.

the router was running at the battery at that time, i already tried to disconnect main board from battery for a minute, flash image again, restore config but nothing helps i am getting these for all 3 of my ralink adapters and one realtek 8187 adapter

[   22.190000] usb 1-1: device descriptor read/64, error -145
[   37.480000] usb 1-1: device descriptor read/64, error -145
[   37.710000] usb 1-1: new full-speed USB device number 15 using ehci-platform
[   52.890000] usb 1-1: device descriptor read/64, error -145
[   68.180000] usb 1-1: device descriptor read/64, error -145
[   68.410000] usb 1-1: new full-speed USB device number 16 using ehci-platform
[   78.870000] usb 1-1: device not accepting address 16, error -145
[   78.990000] usb 1-1: new full-speed USB device number 17 using ehci-platform
[   89.450000] usb 1-1: device not accepting address 17, error -145
[   89.450000] hub 1-0:1.0: unable to enumerate USB device on port 1

what to do to reset CPU or whatever is needed so this thing can function normally?

the only adapter that is recognized without problem after this storm shit is WN722N and it works properly so i would guess the hardware was not damaged but rather something internal like some sort of controller/register/whatever you call it?

comment:24 Changed 2 years ago by anonymous

Still happening on CC RC3 on Archer C7v2 and E3276:

Thu Sep 3 11:15:44 2015 kern.err kernel: [ 15.720000] usb 2-1: device not accepting address 2, error -145
Thu Sep 3 11:15:44 2015 kern.info kernel: [ 15.840000] usb 2-1: new high-speed USB device number 3 using ehci-platform
Thu Sep 3 11:15:44 2015 kern.info kernel: [ 17.860000] usb 2-1: USB disconnect, device number 3
Thu Sep 3 11:15:44 2015 kern.info kernel: [ 18.300000] usb 2-1: new high-speed USB device number 4 using ehci-platform
Thu Sep 3 11:16:00 2015 kern.err kernel: [ 33.420000] usb 2-1: device descriptor read/64, error -145
Thu Sep 3 11:16:15 2015 kern.err kernel: [ 48.650000] usb 2-1: device descriptor read/64, error -145
Thu Sep 3 11:16:15 2015 kern.info kernel: [ 48.880000] usb 2-1: new high-speed USB device number 5 using ehci-platform
Thu Sep 3 11:16:30 2015 kern.err kernel: [ 64.000000] usb 2-1: device descriptor read/64, error -145
Thu Sep 3 11:16:45 2015 kern.err kernel: [ 79.230000] usb 2-1: device descriptor read/64, error -145
Thu Sep 3 11:16:46 2015 kern.info kernel: [ 79.460000] usb 2-1: new high-speed USB device number 6 using ehci-platform
Thu Sep 3 11:16:56 2015 kern.err kernel: [ 89.950000] usb 2-1: device not accepting address 6, error -145
Thu Sep 3 11:16:56 2015 kern.info kernel: [ 90.070000] usb 2-1: new high-speed USB device number 7 using ehci-platform
Thu Sep 3 11:17:07 2015 kern.err kernel: [ 100.490000] usb 2-1: device not accepting address 7, error -145
Thu Sep 3 11:17:07 2015 kern.err kernel: [ 100.490000] usb usb2-port1: unable to enumerate USB device

comment:25 Changed 2 years ago by anonymous

See #15194 as this may be a hardware (SoC) limitation, and not an issue with OpenWRT or the kernel/driver.

comment:26 Changed 2 years ago by memtix

Ha! This made me laugh (a little bit hysterically) I have been pulling late nights, having rows with my missus turning up late for work etc trying to get this #$@king hard drive with ext4 to work with my archer c7 with BB 14.07 for weeks now.
And I just came across this page half an hour ago. I didnt have a usb hub around so I got an ancient HP monitor with usb ports and used that, just to see if it would work and what do you know - works like a charm. I get better than 2mb/s write speed over the air and it seems reasonably consistent.

So it seems this is probably an issue with the archer chipset, I wonder if this is the only solution to this annoying problem? I guess an extra $10 device attached to the system is not too bad of a solution???

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.