Modify

Opened 4 years ago

Closed 4 years ago

#16502 closed enhancement (not_a_bug)

usb-ohci driver build fix inside kernel, instead as module on ar71xx on TRUNK

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: kernel Version: Trunk
Keywords: OHCI HCD AR71XX NOT AS MODULE Cc:

Description

I noted, that when selecting USB ehci + ohci driver with <*> on ar71xx plattform, the ohci-module is installed "twice".

The general usb-modules are build as modules and are loaded as kernelmodules as expected by modules.d infrastructure

But i see that ohci-hcd driver is build INSIDE the kernel as fixed module and is "useless" extra added as module, which was expected normaly - so it´s useless then.

In this case it was not possible to disable the ohci-driver later, and the driver is still loaded, no matter of the ohci_hcd.ko module is present/deaktivated or not.

Attachments (0)

Change History (5)

comment:1 Changed 4 years ago by nbd

  • Resolution set to not_a_bug
  • Status changed from new to closed

you can fix that by running make clean, that way the .ko will not be added to the filesystem anymore

comment:2 Changed 4 years ago by anonymous

  • Resolution not_a_bug deleted
  • Status changed from closed to reopened

In my case i made a complete new/clean checkout! - not resuse a previous one.
Please recheck this situation with a complete fresh trunk-checkout.

In my config the EHCI & OHCI-modules are marked with <*> in menuconfig. but it is still fix compiled in the kernel AND exported / installed as module, so i cannot unload it anymore from running kernel...

The ehci-module is correctly installed as module and not compiled in.

comment:3 Changed 4 years ago by nbd

I cannot reproduce this.
Please post your build_dir/target-mips_34kc_uClibc-0.9.33.2/linux-ar71xx_generic/linux-3.10.36/.config
Also, did you make any kernel config changes yourself?

comment:4 Changed 4 years ago by anonymous

I think i found the problem:

The problems looks like the /overlay-partition is mounted to late!

the kmod-loader and other scripts have at early boot only access to the rom-part, and here all original modules in /lib/modules and /etc/modules.d are in its original state.

the loading ov the /overlay comes after the kmod-loader, so it´s not possible to
"modify" this directorys to own needs.

the kmod-loader and other importent scripts must come AFTER activating /overlay to use the correct filesystem.

comment:5 Changed 4 years ago by nbd

  • Resolution set to not_a_bug
  • Status changed from reopened to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.