Modify

Opened 4 years ago

Closed 4 years ago

#16413 closed defect (fixed)

gpio-button-hotplug doesn't work with newest version of kernel

Reported by: pepe2k Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: gpio, hotplug, package, button Cc:

Description

Option CONFIG_HOTPLUG doesn't exist in newest versions of the Linux kernel (I'm not sure, probably >= 3.11?), but it's used in gpio-button-hotplug.c (package kmod-gpio-button-hotplug).

After removing "#ifdef CONFIG_HOTPLUG" and whole "#else ... #endif" block, I can again use GPIO buttons on x86_64 target (kernel 3.14).

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by Stefan Hellermann <stefan@…>

comment:2 Changed 4 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in r40838

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.