Modify

Opened 4 years ago

Closed 4 years ago

#16303 closed defect (duplicate)

latest mips compiler breaks rrdtool (no ieee math available)

Reported by: dave.taht@… Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: Cc:

Description

checking if IEEE math works out of the box... no
checking if IEEE math works with the -ieee switch... no
checking if IEEE math works with the -qfloat=nofold switch... no
checking if IEEE math works with the -w -qflttrap=enable:zerodivide... no
checking if IEEE math works with the -mieee switch... no
checking if IEEE math works with the -q float=rndsngl switch... no
checking if IEEE math works with the -OPT:IEEE_NaN_inf=ON switch... no
checking if IEEE math works with the -OPT:IEEE_comparisons=ON switch... no
checking if IEEE math works with fpsetmask(0)... no
checking if IEEE math works with signal(SIGFPE,SIG_IGN)... no
configure: error:
Your Compiler does not do propper IEEE math ... Please find out how to
make IEEE math work with your compiler and let me know (oetiker@…).
Check config.log to see what went wrong ...

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by nbd

Have you tried running make dirclean? If that doesn't help, please post your config.log

comment:2 Changed 4 years ago by hnyman

Duplicate of #12733.

This is an old issue, for which I have filed a bug.
My config.log has been posted to that bug.

The issues happens rarely, and usually after make clean.
I am using Ubuntu x64 platform.

comment:3 Changed 4 years ago by nbd

  • Resolution set to duplicate
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.