Modify

Opened 12 years ago

Closed 12 years ago

#162 closed defect (fixed)

Rev 2785 fails to compile with 2.4-brcm

Reported by: wigyori@… Owned by: florian
Priority: normal Milestone:
Component: toolchain Version:
Keywords: Cc:

Description

After menuconfig, a simple make V=99 fails with the following:


make[3]: Entering directory `/o/openwrt/trunk/openwrt/toolchain/kernel-headers'
mkdir -p /o/openwrt/trunk/openwrt/toolchain_build_mipsel
bzcat /o/openwrt/trunk/openwrt/dl/linux-2.4.32.tar.bz2 | tar -C /o/openwrt/trunk/openwrt/toolchain_build_mipsel -xf - \

linux-2.4.32/include \
linux-2.4.32/Makefile \
linux-2.4.32/Rules.make \
linux-2.4.32/arch/mipsel/Makefile \
linux-2.4.32/scripts \
linux-2.4.32/arch/mipsel/config*.in \
linux-2.4.32/*/*/Config.in \
linux-2.4.32/*/Config.in

tar: linux-2.4.32/arch/mipsel/Makefile: Not found in archive
tar: linux-2.4.32/arch/mipsel/config*.in: Not found in archive
tar: Error exit delayed from previous errors


Readding a " -e 's/mipsel/mips/'" solved this, but it is unclear to me how this affects the future kernel patches regarding Atheros 531x-based devices.

Attachments (0)

Change History (5)

comment:1 Changed 12 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

Corrected in r2792. Thanks !

comment:2 Changed 12 years ago by florian

  • Resolution fixed deleted
  • Status changed from closed to reopened

Excuse me, I closed the ticket too fast.

In fact, there is no mipsel specific config-mipsel.in nor Makefile, but when preparing the headers as shown here :

$(LINUX_HEADERS_DIR)/.configured: $(LINUX_HEADERS_DIR)/.unpacked

-cp -af ./files/config.$(LINUX_HEADERS_ARCH) $(LINUX_HEADERS_DIR)/.config
$(MAKE) -C $(LINUX_HEADERS_DIR) ARCH=$(LINUX_HEADERS_ARCH) oldconfig include/linux/version.h

you have to make the distinction between mips, and mipsel.

I will fix it while the makefile extracts the needed files.

comment:3 Changed 12 years ago by florian

  • Owner changed from developers to florian
  • Status changed from reopened to new

comment:4 Changed 12 years ago by florian

I was unable to reproduce the bug with newer revisions. Could you try and let us know whether it works or not now ?

comment:5 Changed 12 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

I tested newer builds and it know works. So I maintain that #2792 corrected the bug and seems to build usable images.

Thanks !

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.