Modify

Opened 4 years ago

#15817 new defect

Messed up mesh_id when declaring 2 mesh interfaces

Reported by: csandu00@… Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: base system Version: Trunk
Keywords: Cc:

Description

I am using Openwrt BARRIER BREAKER (Bleeding Edge, r40668)

I declare 2 mesh interfaces in /etc/config/wireless:
config wifi-iface mesh0

option device radio0
option network mesh0
option ifname mesh0
option mode mesh
option mesh_id 'Kmesha'
option macaddr '00:ba:ba:be:be:01'
option key 'keykey'
option mesh_hwmp_rootmode 4
option mesh_gate_announcements 1

config wifi-iface mesh1

option device radio0
option network mesh1
option ifname mesh1
option mode mesh
option mesh_id 'Gilgamesh'
option macaddr '00:ba:ba:ce:ce:01'
option key 'keykey'


This results in 2 processes started:

1171 root 2536 S /usr/bin/meshd-nl80211 -i mesh0 -s Gilgamesh -c /var/run/authsae-mesh0.cfg
1191 root 2532 S /usr/bin/meshd-nl80211 -i mesh1 -s Gilgamesh -c /var/run/authsae-mesh1.cfg

So, although the mesh_id is declared differently in /etc/config/wireless, the processes "share" the same mesh_id (of the second interface declared). Same mistake is in /var/run/authsae-mesh0.cfg and /var/run/authsae-mesh1.cfg

Thanks,
Constantin

Attachments (0)

Change History (0)

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.