Modify

Opened 4 years ago

Closed 4 years ago

#15793 closed defect (no_response)

No more virtual WLAN-Interfaces in ifconfig after "wifi" or config reload on WRT610Nv1

Reported by: anonymous Owned by: developers
Priority: high Milestone: Chaos Calmer 15.05
Component: base system Version: Trunk
Keywords: WRT610NV1 VIRTUAL WIRLESS RELOAD PROBLEM Cc:

Description

In the actual trunk, after a reload or the command "wifi" ifconfig shows no more the virtual-wifi interface wl0-x and wl1-x

brctl still shows the virtual interfaces:

# wifi
Press any key to continue...

# ifconfig
br-lan    Link encap:Ethernet  HWaddr 00:23:69:3B:2C:DE
          inet addr:192.168.1.1  Bcast:192.168.2.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3167 errors:0 dropped:69 overruns:0 frame:0
          TX packets:3270 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:350805 (342.5 KiB)  TX bytes:1214074 (1.1 MiB)

br-lan2   Link encap:Ethernet  HWaddr 00:23:69:3B:2C:F5
          inet addr:192.168.10.1  Bcast:192.168.10.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

eth0      Link encap:Ethernet  HWaddr 00:23:69:3B:2C:DE
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3129 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3399 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:417165 (407.3 KiB)  TX bytes:1250564 (1.1 MiB)
          Interrupt:4

eth0.1    Link encap:Ethernet  HWaddr 00:23:69:3B:2C:DE
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3135 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3292 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:348949 (340.7 KiB)  TX bytes:1215658 (1.1 MiB)

eth0.5    Link encap:Ethernet  HWaddr 00:23:69:3B:2C:DE
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:2040 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2040 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:128346 (125.3 KiB)  TX bytes:128346 (125.3 KiB)

wl0       Link encap:Ethernet  HWaddr 00:23:69:3B:2C:F0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:2 overruns:0 frame:12473
          TX packets:0 errors:10 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:6

wl1       Link encap:Ethernet  HWaddr 00:23:69:3B:2C:F1
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:2 overruns:0 frame:0
          TX packets:0 errors:8 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:6 Base address:0x4000

but this looks like OK:

# brctl show
bridge name     bridge id               STP enabled     interfaces
br-lan          7fff.0023693b2cde       no              eth0.1
                                                        wl0
                                                        wl1
br-lan2         7fff.0023693b2cf5       no              eth0.5
                                                        wl0-1
                                                        wl1-1

Attachments (0)

Change History (4)

comment:1 Changed 4 years ago by anonymous

When "wifi" is run a 2nd time, the virtual interfaces comes up again.

For me it looks like, that the init-routines need some delays after bringing up the primary interface(s), then wait a few seconds, then start up the virtual interfaces.
But mac-address settings are still ignored and reset to defaults after run "wifi"

comment:3 Changed 4 years ago by Zajec

This could be fixed by r40749, please re-try the trunk build

comment:4 Changed 4 years ago by nbd

  • Resolution set to no_response
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.