Modify

Opened 4 years ago

Closed 3 years ago

#15785 closed defect (fixed)

wrt610nV1 hangs on Reboot / Switch-Init Problem / WLAN-LEDs off

Reported by: anonymous Owned by: developers
Priority: high Milestone: Chaos Calmer 15.05
Component: kernel Version: Trunk
Keywords: WRT610NV1 Reboot HANG SWITCH PROBLEM WLAN LEDs Cc:

Description

Because of this ticket:
/ticket/14729.html

There is another importent problem, where i asume, this has todo with it.

Mostly the unit hangs on "reboot" command and never reached the reboot-point. I asume a not correctly initialized Switch.
Sometimes the reboot command works, but very often it hangs on actual trunk.

Here is another open thing, that is true for wrt610nV1:

/ticket/10032.html

The WLAN-LEDs are no longer working without this settings:

nvram set pci/1/1/leddc=0x5A000A
nvram set pci/1/2/leddc=0x5A000A

and 3 other Options are complained after coldboot:

nvram set pci/1/1/rxpo2g=0xff
nvram set pci/1/2/rxpo2g=0xff
nvram set pci/1/2/rxpo5g=0xff

This happens, when the nvram is cleared in the CFE by nvram erase to become a clean enviroment. After using dd-wrt or the original-Firmware the problem still exists. On The firmware a lot of pre defined options are missing and not correctly set through the CFE itself, like on other models.

So this 5 Parameters are missing in the initial-Setup + a final fix for the reboot-loop of the b53 switch init without commenting out the switch-name in the network config.

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by anonymous

At this points it hangs on reboot:

root@develope:/# reboot

procd: - shutdown -
root@develope:/# br-lan: port 3(wl1) entered disabled state
br-lan: port 2(wl0) entered disabled state
br-lan: port 1(eth0.1) entered disabled state
device eth0.1 left promiscuous mode
device eth0 left promiscuous mode
br-lan: port 1(eth0.1) entered disabled state
tg3 0000:01:00.0 eth0: Link is down
device wl0 left promiscuous mode
br-lan: port 2(wl0) entered disabled state
device wl1 left promiscuous mode
br-lan: port 3(wl1) entered disabled state
procd: - reboot -Restarting system.

Please stand by while rebooting the system...

...and here is hungs...

comment:2 Changed 4 years ago by Shogo

comment:3 Changed 3 years ago by hauke

  • Resolution set to fixed
  • Status changed from new to closed

The reboot problem was fixed in trunk in r42083, r42088 and for BB in r42086.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.