Modify

Opened 4 years ago

Closed 3 years ago

#15778 closed defect (worksforme)

Kernel panic with QEMU on Malta

Reported by: Chris Hodapp Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

I am attempting to make a build targeting Malta (big-endian) in order to run it on QEMU. This is the diff of the configuration I'm using:

CONFIG_TARGET_malta=y
CONFIG_TARGET_malta_be=y
CONFIG_TARGET_malta_be_Default=y

The .config is also attached.

I am then trying to use the Malta image as described in https://dev.openwrt.org/browser/trunk/target/linux/malta/README with the command:

qemu-system-mips -kernel bin/malta/openwrt-malta-be-vmlinux-initramfs.elf -nographic -m 256

This dies about 1/2 of a second in:

[    0.520000] Kernel panic - not syncing: Attempted to kill init! exitcode=0x0000000b

While this is for the base configuration only modified to change the target to malta, I had the same results when transferring over a 12.09 configuration which I was successfully booting on QEMU in the same manner.

Attachments (1)

.config (140.4 KB) - added by anonymous 4 years ago.

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by anonymous

comment:1 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:2 Changed 3 years ago by jogo

  • Resolution set to worksforme
  • Status changed from new to closed

Apart from the qemu issue from #16881 I can't reproduce it, and malta-be rc3 as well as trunk built with the attached .config boots fine for me.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.