Modify

Opened 4 years ago

Last modified 4 years ago

#15772 new defect

internet connection via l2tp drop when 6in4 tunnel up on trunk r40624

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

I have l2tp internet connection from my provider via dhcp eth1. And i configured henet 6in4 tunnel. when 6in4 tunnel start vpn connection drop.

/etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option cachesize '1500'
	option expandhosts '1'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option nonegcache '1'

config dhcp 'lan'
	option interface 'lan'
	option start '10'
	option limit '240'
	option leasetime '24h'
	option dhcpv6 'hybrid'
	option ra 'hybrid'
	option ndp 'hybrid'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config dhcp 'henet'
	option interface 'henet'
	option ignore '1'
	option dynamicdhcp '0'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'}}}

/etc/config/network

{{{
config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface 'lan'
	option ifname 'eth0'
	option type 'bridge'
	option proto 'static'
	option mtu '1500'
	option ipaddr '192.168.0.1'
	option netmask '255.255.255.0'
	option ip6assign '64'

config interface 'wan'
	option proto 'dhcp'
	option hostname 'OpenWrt_router'
	option reqopts 'routes msstaticroutes'
	option ifname 'eth1'
	option metric '50'
	option ipv6 '0'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 4'

config interface 'l2tp-internet'
	option keepalive '20 5'
	option proto 'l2tp'
	option server 'l2tp.from.provider'
	option username 'user'
	option password 'pass'
	option mtu '1460'
	option peerdns '0'
	option dns '208.67.222.222 208.67.220.220 8.8.8.8 77.88.8.1'
	option metric '0'

config interface 'henet'
	option proto '6in4'
	option auto '0'
	option peeraddr 'xxx.xxx.xxx.xxx'
	option ip6addr '2001:470:1e14:14f::2/64'
	option ip6prefix '2001:470:1e15:14f::/64'
	option mtu '1480'
}}}

syslog when i bring up 6in4 tunnel
{{{Fri May  2 10:51:22 2014 daemon.notice netifd: Interface 'henet' is setting up now
Fri May  2 10:51:22 2014 daemon.notice netifd: Interface 'internet' is setting up now
Fri May  2 10:51:22 2014 daemon.notice netifd: Network device 'l2tp-internet' link is down
Fri May  2 10:51:22 2014 daemon.notice netifd: internet (2839): 00 OK
Fri May  2 10:51:23 2014 daemon.debug xl2tpd[828]: Session 'l2tp-internet' already active!
Fri May  2 10:51:23 2014 daemon.notice netifd: internet (2839): 01 Session 'l2tp-internet' already active!
Fri May  2 10:51:23 2014 daemon.notice netifd: Interface 'henet' is now up
Fri May  2 10:51:23 2014 daemon.notice netifd: IP tunnel '6in4-henet' link is up
Fri May  2 10:51:24 2014 daemon.info dnsmasq[1088]: reading /tmp/resolv.conf.auto
Fri May  2 10:51:24 2014 daemon.info dnsmasq[1088]: using nameserver 85.21.192.3#53
Fri May  2 10:51:24 2014 daemon.info dnsmasq[1088]: using nameserver 213.234.192.8#53
Fri May  2 10:51:24 2014 daemon.info dnsmasq[1088]: using local addresses only for domain lan
Fri May  2 10:51:24 2014 user.notice firewall: Reloading firewall due to ifup of henet (6in4-henet)}}}

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.