Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#15770 closed defect (invalid)

opkg install strongswan-mod-af-alg module Error, cannot satisfy kernel dependencies

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: Cc:

Description

opkg install strongswan-mod-af-alg
Installing strongswan-mod-af-alg (5.1.3-1) to root...
Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/strongswan-mod-af-alg_5.1.3-1_ar71xx.ipk.
Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for strongswan-mod-af-alg:
  • kernel (= 3.10.36-1-9956c8ccf213a466fa9c024a4d968410) * kernel (= 3.10.36-1-9956c8ccf213a466fa9c024a4d968410) * kernel (= 3.10.36-1-9956c8ccf213a466fa9c024a4d968410) * kernel (= 3.10.36-1-9956c8ccf213a466fa9c024a4d968410) *
  • opkg_install_cmd: Cannot install package strongswan-mod-af-alg.

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by hauke

  • Resolution set to invalid
  • Status changed from new to closed

The trunk packages are depending on a specific kernel version, so you have to take the kernel module from the same build as the kernel. You are trying to use an older kernel with a recent module, this will not work. When you want to use trunk you should use the image builder to add kernel modules to your image.

comment:2 Changed 4 years ago by anonymous

thanks for the quick reply. appreciated.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.