Modify

Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#15749 closed defect (fixed)

Wireless instability regression on WZR-HP-G300NH

Reported by: celejar@… Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: kernel Version: Trunk
Keywords: Cc:

Description

I've been running OpenWrt on a Buffalo WZR-HP-G300NH for years. Backfire and Attitude Adjustment (r36088) releases both work fine, with stable wireless; (recent?) trunk builds (e.g., recent Barrier Breaker, Attitude Adjustment r40431) don't: the thing runs, and wireless does work intermittently, but it is so unstable as to render it unusable. Clients frequently disconnect, and even when they are connected, ping times and packet loss are high (varying from 10-50 ms to hundreds or even thousands of ms and from 15% to 85% loss).

Physical configuration is optimal - clients are in the same room as the router, and not far away.

I can provide further information / logs as requested.

Attachments (0)

Change History (14)

comment:1 follow-up: Changed 4 years ago by howard meng

Could you please try r40572? It works great on my wzr-hp-g300nh for several days without any wifi dropout. Although there are 'Failed to stop TX DMA' occurring from dmesg, I didn't notice any impact on wifi speed. And Attitude Adjustment always randomly drops wifi from my experience on wzr-hp-g300nh.

comment:2 Changed 4 years ago by celejar@…

I'll try that release and / or some other recent trunks when I get a chance (this is my working router, so I can only play with it when I have the chance to troubleshoot and revert in case of trouble).

comment:3 Changed 4 years ago by nbd

  • Resolution set to no_response
  • Status changed from new to closed

comment:4 in reply to: ↑ 1 Changed 4 years ago by celejar@…

Replying to howard meng:

Could you please try r40572? It works great on my wzr-hp-g300nh for several days without any wifi dropout. Although there are 'Failed to stop TX DMA' occurring from dmesg, I didn't notice any impact on wifi speed. And Attitude Adjustment always randomly drops wifi from my experience on wzr-hp-g300nh.

I've tried r40572, and it's more stable than the other recent versions I've tried, but the wireless still goes down at least once or twice a day. The router itself still stays functional, however, and I can log in over ethernet and do "/etc/init.d/network restart", which brings the wireless back up. Since this is my production router, I can't afford this type of unreliability, so I'm back on r36088, which is rock-solid stable.

I also tried another recent trunk (forget which one at the moment), and it was utterly unstable - tons of dropped packets, slow pings, disconnects.

comment:5 Changed 4 years ago by celejar@…

  • Resolution no_response deleted
  • Status changed from closed to reopened

comment:6 Changed 4 years ago by nbd

i'd like to know what recent version you used, or even better: please try the current version of trunk and check if it is better.

comment:7 follow-up: Changed 4 years ago by anonymous

Adding what I can to help... (I stumbled on this ticket looking to see if there was a fix, and i think i'm seeing same issue)
I won't have a chance to upgrade again until the weekend but here are my data points from my upgrade history (i keep all my old downloads dated for record keeping):

2014-01-15 rock solid for weeks
2014-04-12 wifi needs restart daily or more (needed to upgrade for heartbleed)
2014-05-16 wifi needs restart 2-3 times weekly

I haven't been tracking (or noticing) pings times or drops, i am only tracking when my wireless devices wont connect any longer until a restart occurs

comment:8 in reply to: ↑ 7 Changed 4 years ago by anonymous

Replying to anonymous:

ok found time to upgrade last night, and found wifi wouldn't connect already when I got home from work.

2014-06-03 (Bleeding Edge, r40982) wifi needed restart in < 1 day.

comment:9 Changed 4 years ago by nbd

please try r41113

comment:10 Changed 4 years ago by anonymous

i've been stable for a week now on r41147. I think you nailed it. Awesome work as always nbd!

comment:11 Changed 4 years ago by nbd

  • Resolution set to fixed
  • Status changed from reopened to closed

thanks for testing

comment:12 Changed 4 years ago by anonymous

"do a chip reset if noise floor calibration fails, should improve stability"? doesnt sound like a fix though to me, more like a dirty workaround for ... something.

comment:13 Changed 4 years ago by nbd

it's not a workaround for software bugs. there are numerous conditions that can cause various parts of the chip to lock up, and the driver needs to do its best to recognize them and kick the hardware out of this state.

comment:14 Changed 3 years ago by tmatth@…

Still reproducible with OpenWrt Chaos Calmer 15.05-rc3 / LuCI Master (git-15.167.71950-8005ecb)

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.