Modify

Opened 11 years ago

Closed 10 years ago

Last modified 4 years ago

#1574 closed defect (worksforme)

WDS interface not getting added to bridge

Reported by: mikeyman77 Owned by: developers
Priority: lowest Milestone: Barrier Breaker 14.07
Component: kernel Version:
Keywords: Cc:

Description

I found a issue with WDS on brcm 2.4 target. I got WDS working on my wrt54g and wrt54gs, they both have r6910 on them. When you setup the wireless and wds interfaces to use "option network lan" in the wireless config, it does not bring the wds interfaces up and does not add them to the "lan" bridge. The only interfaces the bridge has on it is the wifi and lan.

When I manually added the wifi and wds interfaces in the network config the the bridge (see below) and removed the "option network lan" from the wireless config, the wds interfaces were brought up and wds functioned properly.

Here is the network config:
config interface lan

option type bridge
option ifname "eth0.0 wl0 wds0.1 wds0.2"
option proto static
option ipaddr 192.168.1.1
option netmask 255.255.255.0

Attachments (1)

openwrt-broadcom.sh.patch (9.5 KB) - added by camh 11 years ago.
Patch to fix bug

Download all attachments as: .zip

Change History (11)

comment:1 follow-up: Changed 11 years ago by anonymous

try something like this. i think the config format has changed at some time. example below works for me with atheros wifi but should work on broadcom wifi too.

/etc/config/network

# Copyright (C) 2006 OpenWrt.org

config interface loopback
        option ifname   lo
        option proto    static
        option ipaddr   127.0.0.1
        option netmask  255.0.0.0

config interface lan
        option type     bridge
        option ifname   eth0
        option proto    'static'
        option ipaddr   '192.168.1.1'
        option netmask  '255.255.255.0'

/etc/config/wireless

config wifi-device  wifi0
        option type     atheros
        option channel  1
#       option diversity 1
#       option txantenna 0
#       option rxantenna 0
#       option distance  2000
# disable radio to prevent an open ap after reflashing:
        option disabled 0

config wifi-iface
        option device   wifi0
        option network  lan
        option mode     ap
        option ssid     OpenWrt
        option hidden   0
#       option txpower  15
#       option bgscan   enable
        option encryption none

config wifi-iface
       option device   wifi0
       option network  lan
       option mode     wds
       option ssid     OpenWrt-WDS
       option bssid    xx:xx:xx:xx:xx:xx
       option hidden   0
       option encryption none

comment:2 Changed 11 years ago by mikeyman77

That is how I had it when it was not adding the wds interfaces to the lan bridge and was not bringing up the interfaces. I had "option network lan" in the config.

Changed 11 years ago by camh

Patch to fix bug

comment:3 Changed 11 years ago by camh

The attached patch (openwrt-broadcom.sh.patch) is an attempt to fix this bug. It grew larger than I originally anticipated as I did not originally plan to refactor the parts I did. But I found it easier to understand the flow of the end result so I'm submitting it as is.

comment:4 Changed 11 years ago by mikeyman77

Thanks, perhaps they will add this patch into the source to get this bug fixed.

comment:5 Changed 11 years ago by anonymous

How do I download this patch?

comment:6 in reply to: ↑ description Changed 11 years ago by mbm

  • Component changed from packages to kernel
  • Priority changed from normal to lowest
Replying to [ticket:1574 mikeyman77]:
> config interface lan
>         option type     bridge
>         option ifname   "eth0.0 wl0 wds0.1 wds0.2"
>         option proto    static
>         option ipaddr   192.168.1.1
>         option netmask  255.255.255.0

No. The wds0.x names are assigned dynamically and should not be used in this fashion.

comment:7 Changed 11 years ago by mikeyman77

Thats the only workaround I could find that worked.

comment:8 in reply to: ↑ 1 Changed 10 years ago by pini

Replying to anonymous:

try something like this. i think the config format has changed at some time. example below works for me with atheros wifi but should work on broadcom wifi too.
/etc/config/wireless

> config wifi-device  wifi0
>         option type     atheros
>         option channel  1
> #       option diversity 1
> #       option txantenna 0
> #       option rxantenna 0
> #       option distance  2000
> # disable radio to prevent an open ap after reflashing:
>         option disabled 0
> 
> config wifi-iface
>         option device   wifi0
>         option network  lan
>         option mode     ap
>         option ssid     OpenWrt
>         option hidden   0
> #       option txpower  15
> #       option bgscan   enable
>         option encryption none
> 
> config wifi-iface
>        option device   wifi0
>        option network  lan
>        option mode     wds
>        option ssid     OpenWrt-WDS
>        option bssid    xx:xx:xx:xx:xx:xx
>        option hidden   0
>        option encryption none

This solution works out of the box on my WRT54G. Thanks!

comment:9 Changed 10 years ago by nbd

  • Resolution set to worksforme
  • Status changed from new to closed

comment:10 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.