Modify

Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#15670 closed defect (fixed)

Ap Sta mode with mixed encryption fails

Reported by: webtron Owned by: developers
Priority: high Milestone: Chaos Calmer 15.05
Component: kernel Version: Trunk
Keywords: Cc:

Description

I'm compiling r40509 with 1 sta mode and 2 ap's. I have a problem where if 1 ap is open and the other psk the open ap clients keep re associating every 20 seconds or so. If I change the open ap to psk it becomes stable. This works without problem on previous revision(35181).

Wed Apr 23 06:50:23 2014 daemon.info hostapd: wlan0-1: STA LaptopMAC IEEE 802.11: authenticated
Wed Apr 23 06:50:23 2014 daemon.info hostapd: wlan0-1: STA LaptopMAC IEEE 802.11: associated (aid 1)
Wed Apr 23 06:50:48 2014 daemon.info hostapd: wlan0-1: STA LaptopMAC IEEE 802.11: authenticated
Wed Apr 23 06:50:48 2014 daemon.info hostapd: wlan0-1: STA LaptopMAC IEEE 802.11: associated (aid 1)
Wed Apr 23 06:51:07 2014 daemon.info hostapd: wlan0-1: STA LaptopMAC IEEE 802.11: authenticated
Wed Apr 23 06:51:07 2014 daemon.info hostapd: wlan0-1: STA LaptopMAC IEEE 802.11: associated (aid 1)
Wed Apr 23 06:51:33 2014 daemon.info hostapd: wlan0-1: STA LaptopMAC IEEE 802.11: authenticated
Wed Apr 23 06:51:33 2014 daemon.info hostapd: wlan0-1: STA LaptopMAC IEEE 802.11: associated (aid 1)
Wed Apr 23 06:51:51 2014 daemon.info hostapd: wlan0-1: STA LaptopMAC IEEE 802.11: authenticated
Wed Apr 23 06:51:51 2014 daemon.info hostapd: wlan0-1: STA LaptopMAC IEEE 802.11: associated (aid 1)
Wed Apr 23 06:52:16 2014 daemon.info hostapd: wlan0-1: STA LaptopMAC IEEE 802.11: authenticated
Wed Apr 23 06:52:16 2014 daemon.info hostapd: wlan0-1: STA LaptopMAC IEEE 802.11: associated (aid 1)
Wed Apr 23 06:52:41 2014 daemon.info hostapd: wlan0-1: STA LaptopMAC IEEE 802.11: authenticated
Wed Apr 23 06:52:41 2014 daemon.info hostapd: wlan0-1: STA LaptopMAC IEEE 802.11: associated (aid 1)
Wed Apr 23 06:53:04 2014 daemon.info hostapd: wlan0-1: STA LaptopMAC IEEE 802.11: authenticated
Wed Apr 23 06:53:04 2014 daemon.info hostapd: wlan0-1: STA LaptopMAC IEEE 802.11: associated (aid 1)
Wed Apr 23 06:53:27 2014 daemon.info hostapd: wlan0-1: STA LaptopMAC IEEE 802.11: authenticated
Wed Apr 23 06:53:27 2014 daemon.info hostapd: wlan0-1: STA LaptopMAC IEEE 802.11: associated (aid 1)
Wed Apr 23 06:53:53 2014 daemon.info hostapd: wlan0-1: STA LaptopMAC IEEE 802.11: authenticated
Wed Apr 23 06:53:53 2014 daemon.info hostapd: wlan0-1: STA LaptopMAC IEEE 802.11: associated (aid 1)
Wed Apr 23 06:54:15 2014 daemon.info hostapd: wlan0-1: STA LaptopMAC IEEE 802.11: authenticated
Wed Apr 23 06:54:15 2014 daemon.info hostapd: wlan0-1: STA LaptopMAC IEEE 802.11: associated (aid 1)
Wed Apr 23 06:54:38 2014 daemon.info hostapd: wlan0-1: STA LaptopMAC IEEE 802.11: authenticated
Wed Apr 23 06:54:38 2014 daemon.info hostapd: wlan0-1: STA LaptopMAC IEEE 802.11: associated (aid 1)
Wed Apr 23 06:55:01 2014 daemon.info hostapd: wlan0-1: STA LaptopMAC IEEE 802.11: authenticated
Wed Apr 23 06:55:01 2014 daemon.info hostapd: wlan0-1: STA LaptopMAC IEEE 802.11: associated (aid 1)
Wed Apr 23 06:55:24 2014 daemon.info hostapd: wlan0-1: STA LaptopMAC IEEE 802.11: authenticated
Wed Apr 23 06:55:24 2014 daemon.info hostapd: wlan0-1: STA LaptopMAC IEEE 802.11: associated (aid 1)
Wed Apr 23 06:55:50 2014 daemon.info hostapd: wlan0-1: STA LaptopMAC IEEE 802.11: authenticated
Wed Apr 23 06:55:50 2014 daemon.info hostapd: wlan0-1: STA LaptopMAC IEEE 802.11: associated (aid 1)
onfig wifi-device 'radio0'
    option type 'mac80211'
    option hwmode '11ng'
    option path 'pci0000:00/0000:00:00.0'
    list ht_capab 'SHORT-GI-20'
    list ht_capab 'SHORT-GI-40'
    list ht_capab 'TX-STBC'
    list ht_capab 'RX-STBC1'
    list ht_capab 'DSSS_CCK-40'
    option htmode 'HT20'
    option disabled '0'
    option channel '2'

config wifi-iface 'link'
    option device 'radio0'
    option mode 'sta'
    option network 'wan'
    option encryption 'psk'
    option ssid 'uplink'
    option key 'bridgekey'
    option disabled '0'

config wifi-iface 'public'
    option device 'radio0'
    option network 'lan'
    option mode 'ap'
    option ssid 'Guest'
    option isolate '1'
    option key '12345678'
    option encryption 'none'

config wifi-iface 'private'
    option device 'radio0'
    option mode 'ap'
    option network 'ap2'
    option isolate '0'
    option hidden '0'
    option encryption 'psk'
    option ssid 'privatewifi'
    option disabled '0'
    option key 'privatekey'

Attachments (0)

Change History (8)

comment:1 Changed 4 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in current versions

comment:2 Changed 3 years ago by webtron

  • Resolution fixed deleted
  • Status changed from closed to reopened

After getting around this problem by patching revision(35181) I have finally come back to compile the latest trunk. This is actually worse now with CHAOS CALMER (Bleeding Edge, r44634) than it was with r40509. Now I can only have one sta and one ap if i enable any more ap interfaces all the ap interfaces stop working for XP completely and constantly reconnect on Android. They do work on Linux and Windows 7.

comment:3 Changed 3 years ago by nbd

What kind of device are you using?

comment:4 Changed 3 years ago by webtron

Sorry Ubiquiti Bullet M2 and Pico M2

comment:5 Changed 3 years ago by anonymous

I just downloaded the binary from https://downloads.openwrt.org/snapshots/trunk/ar71xx/generic/ version CHAOS CALMER (Bleeding Edge, r44634) to test if it was something in my build but got the same results. The odd thing is hostapd doesn't acknowledge any attempt to connect with XP when there is more than one ap enabled in the /etc/config/wireless. If I disable the second ap interface hostapd responds normally to XP and connects. When I test with Ubuntu 14.04 or Windows 7 it works properly with multiple ap's. With Android hostapd responds but associates over and over every couple of seconds when more than one ap is enabled.

comment:6 Changed 3 years ago by webtron

Sorry I wasn't logged in for the last anonymous post. The only other different thing I can see is the sta interface comes up first(wlan0)in the later revisions and comes up last(wlan0-2) in the earlier versions that work. I've also tried with the sta interface connected to an ap running wds and one without and got no difference.

comment:7 Changed 3 years ago by nbd

  • Resolution set to fixed
  • Status changed from reopened to closed

fixed in r44696

comment:8 Changed 3 years ago by webtron

Thanks I've finally got back to test this and it's fixed.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.