Modify

Opened 4 years ago

Last modified 3 years ago

#15666 new defect

No VDSL on BT Openreach VG3503J V1 & V2

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: Cc:

Description

First of thanks John for the support with this unit.

Trying to start dsl_control :
{{{kmod: module is already loaded - ltq_ptm_vr9
failed to find /lib/firmware/vdsl.bin}
}}}

Another poster highlighted line 166 ?
/network/config/ltq-vdsl-app/files/dsl_control

 [ -z "${firmware}" ] && firmware=/lib/firmware/vdsl.bin
166	        [ -f "${firmware}" ] || {
167	                echo failed to find $firmware

Also
/ticket/12468.html ?

Attachments (0)

Change History (5)

comment:1 Changed 4 years ago by anonymous

I'll try changing line in network/config/ltq-vdsl-app/files/dsl_control 165/166

[ -z "${firmware}" ] && firmware=/lib/firmware/vdsl.bin 
to
[ -z "${firmware}" ] && firmware=/lib/firmware/vdsl.bin" "av" "ptm"

Line 173 target/linux/lantiq/base-files/etc/uci-defaults/02_network

target/linux/lantiq/base-files/etc/uci-defaults/02_network

Any help or pointers with this would be very welcome!

As the ECI modem is not much use without vdsl ;)
Thanks!

comment:2 Changed 4 years ago by anonymous

Still no luck with this-

Tried editing firmware=/lib/firmware/vdsl.bin [in config/ltq-vdsl-app/files/dsl_control]

Might be something simple- just a correct line needs inputting.

Any help most welcome !

Thanks

comment:3 Changed 4 years ago by anonymous

Correct me if I am wrong, but I believe that vdsl.bin is not distributed with openwrt due to licensing issues.

For the BT Openreach VG3503J, you should download ECI_Arcadyan_VDSL_modem.zip from http://www.openreach.co.uk/orpg/home/products/super-fastfibreaccess/super-fastfibreaccess/landrgnu.do. In that archive, you find the DSL firmware binaries in dsl_vr9_firmware_xdsl-05.04.07.09.01.06_05.04.04.04.01.01.tar.gz located in the dl subfolder. Extract xcpe_hw.bin and save it on the modem as /lib/firmware/vdsl.bin. After that you should be able to get the status with /etc/init.d/dsl_control status.

comment:4 Changed 4 years ago by anonymous

Thanks!
Your quite correct as John makes note of it way back in Changeset 36315.

please note that the vdsl firmware is non redistributable. you can find it in the GPL drop that BT provides.

Feel free to close the ticket.

comment:5 Changed 3 years ago by anonymous

look at the OEM source provided http://www.openreach.co.uk/orpg/home/products/super-fastfibreaccess/super-fastfibreaccess/landrgnu/downloads/code/ECI_Arcadyan_VDSL_modem.zip the dsl firmware uses dsl_vr9_firmware_xdsl-05.04.06.0D.01.06_05.04.02.09.01.01.tar.gz not the recommended dsl_vr9_firmware_xdsl-05.04.07.09.01.06_05.04.04.04.01.01.tar.gz* also this is missing from the OEM source, there is however

dsl_vr9_firmware_xdsl-05.04.06.13.01.06_05.04.02.09.01.01.tar.gz
dsl_vr9_firmware_xdsl-05.04.07.09.01.06_05.04.04.04.01.01.tar.gz *

the OEM source feeds also point to http://downloads.openwrt.org/sources/dsl_vr9_firmware_xdsl-05.04.06.0D.01.06_05.04.02.09.01.01.tar.gz as well as localhost for the download. which i am still to find.

checking the files i have would indeed show a difference, so im assuming the needed one is missing but possibly in the wild.

james@ub6401:~/tmp/dsl$ ls -lha
total 988K
drwxrwxr-x 2 james james 4.0K Jan 17 14:18 .
drwxrwxr-x 5 james james 4.0K Jan 17 14:18 ..
-rw-rw-r-- 1 james james 484K Mar 30 2012 dsl_vr9_firmware_xdsl-05.04.06.13.01.06_05.04.02.09.01.01.tar.gz
-rw-rw-r-- 1 james james 487K Mar 30 2012 dsl_vr9_firmware_xdsl-05.04.07.09.01.06_05.04.04.04.01.01.tar.gz

c0b2c21375b4cf7c15c92ee4f4028e0d dsl_vr9_firmware_xdsl-05.04.06.13.01.06_05.04.02.09.01.01.tar.gz
447d918dd868ba0954c47ffaa01e5661 dsl_vr9_firmware_xdsl-05.04.07.09.01.06_05.04.04.04.01.01.tar.gz

james@ub6401:~/tmp/dsl$ mkdir ./06
james@ub6401:~/tmp/dsl$ tar -zxvf dsl_vr9_firmware_xdsl-05.04.06.13.01.06_05.04.02.09.01.01.tar.gz -C ./06/
LICENSE.txt
0e9e04a956c3b6e3c82f1d1536618890 xcpe_hw.bin

james@ub6401:~/tmp/dsl$ mkdir ./07
james@ub6401:~/tmp/dsl$ tar -zxvf dsl_vr9_firmware_xdsl-05.04.07.09.01.06_05.04.04.04.01.01.tar.gz -C ./07/
LICENSE.txt
8c06e49468c4d943a76ceaa81dbd8f3e xcpe_hw.bin

if anyone has a valid source please post here.

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.