Modify

Opened 4 years ago

Closed 4 years ago

#15651 closed defect (no_response)

Nonfunctional Routed AP wifi on Buffalo WZR-HP-G300NH

Reported by: anonymous Owned by: developers
Priority: high Milestone: Chaos Calmer 15.05
Component: base system Version: Trunk
Keywords: Cc:

Description

I tested an old r40392 build and it works fine whereas r40435 appears to be nonfunctional:

Some changes made between r40393 and r40435 broke routed AP wifi for Buffalo WZR-HP-G300NH

Issue is seemingly unchanged in latest r40537.

Currently Wifi ESSID is unavailable to clients despite the wifi led on the router is actve.

LuCI interfaces status shows no IP for the interfaces assigned exclusively to wifi

Attachments (0)

Change History (14)

comment:1 Changed 4 years ago by anonymous

hostapd: update to version 2014-04-04 is apparently causing failure to setup routed wifi

reverting the abovementioned r40394 changeset solve this issue.

comment:2 Changed 4 years ago by anonymous

the following syslog errors came from an affected r40535 build where Wifi ESSID is unavailable to clients and wlan0 fails to get an IP

PS: make config option to support user-regdomain is enabled

Sat Apr 26 13:18:41 2014 kern.info kernel: [  238.480000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Sat Apr 26 13:18:49 2014 kern.info kernel: [  245.590000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Sat Apr 26 13:18:49 2014 daemon.notice netifd: radio0 (1878): Configuration file: /var/run/hostapd-phy0.conf
Sat Apr 26 13:18:49 2014 daemon.notice netifd: radio0 (1878): wlan0: interface state UNINITIALIZED->COUNTRY_UPDATE
Sat Apr 26 13:18:49 2014 daemon.notice netifd: radio0 (1878): ACS: Automatic channel selection started, this may take a bit
Sat Apr 26 13:18:49 2014 daemon.notice netifd: radio0 (1878): wlan0: interface state COUNTRY_UPDATE->ACS
Sat Apr 26 13:18:49 2014 daemon.notice netifd: radio0 (1878): wlan0: ACS-STARTED 
Sat Apr 26 13:18:49 2014 daemon.notice netifd: radio0 (1878): Failed to check if DFS is required; ret=-1
Sat Apr 26 13:18:49 2014 daemon.notice netifd: radio0 (1878): handle_probe_req: send failed
Sat Apr 26 13:18:49 2014 daemon.notice netifd: radio0 (1878): Failed to check if DFS is required; ret=-1
Sat Apr 26 13:18:49 2014 daemon.notice netifd: radio0 (1878): handle_probe_req: send failed
Sat Apr 26 13:18:49 2014 daemon.notice netifd: radio0 (1878): Failed to check if DFS is required; ret=-1
Sat Apr 26 13:18:49 2014 daemon.notice netifd: radio0 (1878): handle_probe_req: send failed
Sat Apr 26 13:18:49 2014 daemon.notice netifd: radio0 (1878): cat: can't open '/var/run/wifi-phy0.pid': No such file or directory
Sat Apr 26 13:18:49 2014 daemon.notice netifd: radio0 (1878): Command failed: Invalid argument
Sat Apr 26 13:18:49 2014 kern.info kernel: [  245.840000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Sat Apr 26 13:18:49 2014 daemon.notice netifd: Interface 'wlan' is enabled

comment:3 Changed 4 years ago by anonymous

specifically crafted r40569 (removed r40394 changeset) running hostapd-20131120 works fine here without attempting any of the following:

Looking into DFS reladed bugreports (#14867, #15620, ...)I tested vanilla r40569 featuring hostapd-2014-04-04 along with patch to add ieee80211h=1 in hostapd conf file but the issue persists.

syslog

Sat Apr 26 16:00:29 2014 kern.info kernel: [  690.010000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Sat Apr 26 16:00:37 2014 kern.info kernel: [  697.980000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Sat Apr 26 16:00:37 2014 daemon.notice netifd: radio0 (1837): Configuration file: /var/run/hostapd-phy0.conf
Sat Apr 26 16:00:37 2014 daemon.notice netifd: radio0 (1837): wlan0: interface state UNINITIALIZED->COUNTRY_UPDATE
Sat Apr 26 16:00:37 2014 daemon.notice netifd: radio0 (1837): ACS: Automatic channel selection started, this may take a bit
Sat Apr 26 16:00:37 2014 daemon.notice netifd: radio0 (1837): wlan0: interface state COUNTRY_UPDATE->ACS
Sat Apr 26 16:00:37 2014 daemon.notice netifd: radio0 (1837): wlan0: ACS-STARTED 
Sat Apr 26 16:00:37 2014 daemon.notice netifd: radio0 (1837): wlan0: ACS-COMPLETED freq=2447 channel=8
Sat Apr 26 16:00:37 2014 daemon.notice netifd: radio0 (1837): Using interface wlan0 with hwaddr 00:(edited) and ssid "wlan"
Sat Apr 26 16:00:37 2014 daemon.notice netifd: radio0 (1837): Interface initialization failed
Sat Apr 26 16:00:37 2014 daemon.notice netifd: radio0 (1837): wlan0: interface state ACS->DISABLED
Sat Apr 26 16:00:37 2014 daemon.notice netifd: radio0 (1837): wlan0: AP-DISABLED 
Sat Apr 26 16:00:37 2014 daemon.notice netifd: radio0 (1837): ACS: Possibly channel configuration is invalid, please report this along with your config file.
Sat Apr 26 16:00:37 2014 daemon.notice netifd: radio0 (1837): cat: can't open '/var/run/wifi-phy0.pid': No such file or directory
Sat Apr 26 16:00:37 2014 daemon.notice netifd: radio0 (1837): Command failed: Invalid argument
Sat Apr 26 16:00:37 2014 kern.info kernel: [  698.130000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Sat Apr 26 16:00:37 2014 daemon.notice netifd: Interface 'wlan' is enabled

hostapd.sh: hostapd_prepare_device_config function changed to add

hostapd_prepare_device_config() {
	local config="$1"
	local driver="$2"

	local base="${config%%.conf}"
	local base_cfg=

	json_get_vars country country_ie beacon_int doth

	hostapd_set_log_options base_cfg

	set_default country_ie 1
        set_default doth 1 

	[ -n "$country" ] && {
		append base_cfg "country_code=$country" "$N"
		[ "$country_ie" -gt 0 ] && append base_cfg "ieee80211d=1" "$N"
		[ "$doth" -gt 0 ] && append base_cfg "ieee80211h=1" "$N"
	}
	[ -n "$hwmode" ] && append base_cfg "hw_mode=$hwmode" "$N"

	local brlist= br
	json_get_values basic_rate_list basic_rate
	for br in $basic_rate_list; do
		hostapd_add_basic_rate brlist "$br"
	done
	[ -n "$brlist" ] && append base_cfg "basic_rates=$brlist" "$N"
	[ -n "$beacon_int" ] && append base_cfg "beacon_int=$beacon_int" "$N"

	cat > "$config" <<EOF
driver=$driver
$base_cfg
EOF
}

hostapd conf fails despite explicitly included

ieee80211d=1 
ieee80211h=1 


comment:4 follow-up: Changed 4 years ago by nbd

please try r40571

comment:5 in reply to: ↑ 4 Changed 4 years ago by anonymous

Replying to nbd:

please try r40571

Thanks,

I tested r40572 without setting ieee80211d and ieee80211h

syslog states " ACS: Possibly channel configuration is invalid, please report this along with your config file."

config wifi-device 'radio0'
	option type 'mac80211'
	option macaddr '00:...' (edited) 
	list ht_capab 'SHORT-GI-40'
	list ht_capab 'DSSS_CCK-40'
	option txpower '14'
	option diversity '1'
	option country 'DE'
	option channel 'auto'
	option log_level '2'

Sat Apr 26 23:22:21 2014 daemon.notice netifd: radio0 (5135): Configuration file: /var/run/hostapd-phy0.conf
Sat Apr 26 23:22:21 2014 daemon.notice netifd: radio0 (5135): wlan0: interface state UNINITIALIZED->COUNTRY_UPDATE
Sat Apr 26 23:22:21 2014 daemon.notice netifd: radio0 (5135): ACS: Automatic channel selection started, this may take a bit
Sat Apr 26 23:22:21 2014 daemon.notice netifd: radio0 (5135): wlan0: interface state COUNTRY_UPDATE->ACS
Sat Apr 26 23:22:21 2014 daemon.notice netifd: radio0 (5135): wlan0: ACS-STARTED 
Sat Apr 26 23:22:21 2014 daemon.notice netifd: radio0 (5135): wlan0: ACS-COMPLETED freq=2472 channel=13
Sat Apr 26 23:22:21 2014 daemon.notice netifd: radio0 (5135): Using interface wlan0 with hwaddr 00:(edited) and ssid "wlan"
Sat Apr 26 23:22:21 2014 daemon.notice netifd: radio0 (5135): Interface initialization failed
Sat Apr 26 23:22:21 2014 daemon.notice netifd: radio0 (5135): wlan0: interface state ACS->DISABLED
Sat Apr 26 23:22:21 2014 daemon.notice netifd: radio0 (5135): wlan0: AP-DISABLED 
Sat Apr 26 23:22:21 2014 daemon.notice netifd: radio0 (5135): ACS: Possibly channel configuration is invalid, please report this along with your config file.
Sat Apr 26 23:22:21 2014 daemon.notice netifd: radio0 (5135): Command failed: Invalid argument
Sat Apr 26 23:22:21 2014 kern.info kernel: [ 1221.620000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

syslog states ' ELOOP: remaining socket: sock=18 eloop_data=0x809f28 user_data=(nil) handler=0x413659'

config wifi-device 'radio0'
	option type 'mac80211'
	option macaddr '00:...' (edited) 
	list ht_capab 'SHORT-GI-40'
	list ht_capab 'DSSS_CCK-40'
	option txpower '14'
	option diversity '1'
	option log_level '2'
	option channel '1'
	option country 'DE'
Sun Apr 27 00:17:16 2014 daemon.notice netifd: radio0 (2078): Configuration file: /var/run/hostapd-phy0.conf
Sun Apr 27 00:17:16 2014 daemon.notice netifd: radio0 (2078): wlan0: interface state UNINITIALIZED->COUNTRY_UPDATE
Sun Apr 27 00:17:16 2014 daemon.notice netifd: radio0 (2078): Using interface wlan0 with hwaddr 00:(edited) and ssid "wlan"
Sun Apr 27 00:17:16 2014 daemon.notice netifd: radio0 (2078): Interface initialization failed
Sun Apr 27 00:17:16 2014 daemon.notice netifd: radio0 (2078): wlan0: interface state COUNTRY_UPDATE->DISABLED
Sun Apr 27 00:17:16 2014 daemon.notice netifd: radio0 (2078): wlan0: AP-DISABLED 
Sun Apr 27 00:17:16 2014 daemon.notice netifd: radio0 (2078): wlan0: Unable to setup interface.
Sun Apr 27 00:17:16 2014 daemon.notice netifd: radio0 (2078): ELOOP: remaining socket: sock=18 eloop_data=0x809f28 user_data=(nil) handler=0x413659
Sun Apr 27 00:17:16 2014 daemon.notice netifd: radio0 (2078): cat: can't open '/var/run/wifi-phy0.pid': No such file or directory
Sun Apr 27 00:17:16 2014 daemon.notice netifd: radio0 (2078): Command failed: Invalid argument
Sun Apr 27 00:17:16 2014 daemon.notice netifd: radio0 (2078): Device setup failed: HOSTAPD_START_FAILED

comment:6 Changed 4 years ago by nbd

please show me the output of the following commands:

iw reg get
iw phy0 info

comment:7 Changed 4 years ago by anonymous

this output was taken on r40572 (r40569+hostapd-20131120 give the same output)

root@OpenWrt:~# iw reg get
country DE: DFS-ETSI
        (2400 - 2483 @ 40), (N/A, 20)
        (5150 - 5350 @ 80), (N/A, 20), NO-OUTDOOR
        (5470 - 5725 @ 80), (N/A, 27), DFS
        (57240 - 65880 @ 2160), (N/A, 40), NO-OUTDOOR
root@OpenWrt:~# iw phy0 info
Wiphy phy0
        max # scan SSIDs: 4
        max scan IEs length: 2257 bytes
        Coverage class: 0 (up to 0m)
        Device supports AP-side u-APSD.
        Device supports T-DLS.
        Available Antennas: TX 0x7 RX 0x7
        Configured Antennas: TX 0x7 RX 0x7
        Supported interface modes:
                 * IBSS
                 * managed
                 * AP
                 * AP/VLAN
                 * WDS
                 * monitor
                 * mesh point
                 * P2P-client
                 * P2P-GO
        Band 1:
                Capabilities: 0x104e
                        HT20/HT40
                        SM Power Save disabled
                        RX HT40 SGI
                        No RX STBC
                        Max AMSDU length: 3839 bytes
                        DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: 8 usec (0x06)
                HT TX/RX MCS rate indexes supported: 0-15
                Frequencies:
                        * 2412 MHz [1] (17.0 dBm)
                        * 2417 MHz [2] (17.0 dBm)
                        * 2422 MHz [3] (17.0 dBm)
                        * 2427 MHz [4] (17.0 dBm)
                        * 2432 MHz [5] (17.0 dBm)
                        * 2437 MHz [6] (17.0 dBm)
                        * 2442 MHz [7] (17.0 dBm)
                        * 2447 MHz [8] (17.0 dBm)
                        * 2452 MHz [9] (17.0 dBm)
                        * 2457 MHz [10] (17.0 dBm)
                        * 2462 MHz [11] (17.0 dBm)
                        * 2467 MHz [12] (17.0 dBm)
                        * 2472 MHz [13] (17.0 dBm)
                        * 2484 MHz [14] (disabled)
        valid interface combinations:
                 * #{ managed, WDS } <= 2048, #{ AP, mesh point } <= 8, #{ IBSS } <= 1, #{ P2P-client, P2P-GO } <= 1,
                   total <= 2048, #channels <= 1, STA/AP BI must match
                 * #{ IBSS, AP, mesh point } <= 1,
                   total <= 1, #channels <= 1, STA/AP BI must match, radar detect widths: { 20 MHz (no HT), 20 MHz }

        HT Capability overrides:
                 * MCS: ff ff ff ff ff ff ff ff ff ff
                 * maximum A-MSDU length
                 * supported channel width
                 * short GI for 40 MHz
                 * max A-MPDU length exponent
                 * min MPDU start spacing

comment:8 follow-ups: Changed 4 years ago by anonymous

Hello, r40572 works great on my wzr-hp-g300nh for a day without any wifi dropout. Hope this information would help

comment:9 in reply to: ↑ 8 ; follow-up: Changed 4 years ago by anonymous

Replying to anonymous:

Hello, r40572 works great on my wzr-hp-g300nh for a day without any wifi dropout. Hope this information would help

Mine apparently works fine as long as hostapd-20131120 is in place.
Thus it cannot be an hardware issue on this side.

Despite pursuing the hypothesis of a configuration triggered issue I still can't pinpoint what cause wifi setup to fail here.

I thought there isn't much to be tested in my wireless configuration but since another router works I'll have to make a better guess then.

comment:10 in reply to: ↑ 9 ; follow-up: Changed 4 years ago by anonymous

Replying to anonymous:

I thought there isn't much to be tested in my wireless configuration but since another router works I'll have to make a better guess then.

Looks like I can trigger the faulty behavior at will enabling ath9k specific ieee80211w option in wifi-iface

config 'wifi-iface'
        option 'device'     'radio0'
        option 'network'    'mywlan'
        option 'mode'       'ap'
        option 'ssid'       'wlan'
        option 'encryption' 'psk2+ccmp'
        option 'key'        'secret passphrase'
	option 'ieee80211w' '1'
	

comment:11 in reply to: ↑ 8 Changed 4 years ago by anonymous

Replying to anonymous:

Hello, r40572 works great on my wzr-hp-g300nh for a day without any wifi dropout. Hope this information would help

Btw, Thanks for the information.

comment:12 in reply to: ↑ 10 Changed 4 years ago by taishi@…

I can confirm this exact behavior when enabling ieee80211w with (fairly same) configuration parameters as #10

Replying to anonymous:

Replying to anonymous:

I thought there isn't much to be tested in my wireless configuration but since another router works I'll have to make a better guess then.

Looks like I can trigger the faulty behavior at will enabling ath9k specific ieee80211w option in wifi-iface

config 'wifi-iface'
        option 'device'     'radio0'
        option 'network'    'mywlan'
        option 'mode'       'ap'
        option 'ssid'       'wlan'
        option 'encryption' 'psk2+ccmp'
        option 'key'        'secret passphrase'
	option 'ieee80211w' '1'
	

comment:13 Changed 4 years ago by nbd

please try r41815

comment:14 Changed 4 years ago by nbd

  • Resolution set to no_response
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.