Modify

Opened 4 years ago

Closed 4 years ago

#15635 closed defect (fixed)

pptpd unable to accept connections

Reported by: axet@… Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: Cc:

Description

pptpd unable to accept connection with wired error message: unrecognized option '???????????????.168.54.25'

this ip from server side:

config service 'pptpd'
  option 'enabled' '1'
  option 'localip' '192.168.54.1'
  option 'remoteip' '192.168.54.25-30'

config 'login'
  option 'username' 'axet'
  option 'password' '1111'
Sun Apr 20 21:53:06 2014 daemon.info pptpd[2323]: CTRL: Client 192.168.54.216 control connection started
Sun Apr 20 21:53:06 2014 daemon.info pptpd[2323]: CTRL: Starting call (launching pppd, opening GRE)
Sun Apr 20 21:53:06 2014 daemon.warn miniupnpd[1646]: unsupported NAT-PMP version : 2
Sun Apr 20 21:53:06 2014 daemon.err pppd[2324]: unrecognized option '???????????????.168.54.25'
Sun Apr 20 21:53:06 2014 daemon.err pptpd[2323]: GRE: read(fd=6,buffer=41e76c,len=8196) from PTY failed: status = -1 error = Input/output error, usually caused by unexpected termination of pppd, check option syntax and pppd logs
Sun Apr 20 21:53:06 2014 daemon.err pptpd[2323]: CTRL: PTY read or GRE write failed (pty,gre)=(6,7)
Sun Apr 20 21:53:06 2014 daemon.debug pptpd[2323]: CTRL: Reaping child PPP[2324]
Sun Apr 20 21:53:06 2014 daemon.info pptpd[2323]: CTRL: Client 192.168.54.216 control connection finished
Sun Apr 20 21:53:06 2014 daemon.err pptpd[2323]: CTRL: Couldn't write packet to client.
Sun Apr 20 21:53:06 2014 daemon.err pptpd[2323]: CTRL: Couldn't write packet to client.

Attachments (0)

Change History (4)

comment:1 Changed 4 years ago by blogic

which target/arch are you using ?

i tested this on ralink SoC just now and the default uci config gives me functional pptpd

comment:2 Changed 4 years ago by twerrt

apperently here is no email notifications...

im using tplink tl wr842nd http://wiki.openwrt.org/toh/tp-link/tl-wr842nd

my build scripts https://github.com/axet/openwrt-tl-wr842nd-v2

it is MIPS

comment:3 Changed 4 years ago by hnyman

probably duplicate of #15428 (although that is about AA12.09).

comment:4 Changed 4 years ago by hauke

  • Resolution set to fixed
  • Status changed from new to closed

This was fixed in r40671.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.