Modify

Opened 4 years ago

Last modified 4 years ago

#15629 reopened defect

Error in syslog

Reported by: alphasparc@… Owned by: developers
Priority: high Milestone: Chaos Calmer 15.05
Component: kernel Version: Trunk
Keywords: Cc:

Description

Latest Trunk

Sat Apr 19 19:53:05 2014 kern.info kernel: [   30.450000] device wlan0 entered promiscuous mode
Sat Apr 19 19:53:06 2014 user.emerg syslog: RTNETLINK answers: Invalid argument
Sat Apr 19 19:53:06 2014 user.emerg syslog: We have an error talking to the kernel
Sat Apr 19 19:53:06 2014 user.emerg syslog: RTNETLINK answers: Invalid argument
Sat Apr 19 19:53:06 2014 user.emerg syslog: We have an error talking to the kernel
Sat Apr 19 19:53:06 2014 user.emerg syslog: RTNETLINK answers: Invalid argument
Sat Apr 19 19:53:06 2014 user.emerg syslog: We have an error talking to the kernel
Sat Apr 19 19:53:06 2014 user.emerg syslog: RTNETLINK answers: Invalid argument
Sat Apr 19 19:53:06 2014 user.emerg syslog: We have an error talking to the kernel
Sat Apr 19 19:53:06 2014 user.emerg syslog: RTNETLINK answers: Invalid argument
Sat Apr 19 19:53:06 2014 user.emerg syslog: We have an error talking to the kernel
Sat Apr 19 19:53:06 2014 user.emerg syslog: RTNETLINK answers: Invalid argument
Sat Apr 19 19:53:06 2014 user.emerg syslog: We have an error talking to the kernel
Sat Apr 19 19:53:06 2014 user.emerg syslog: RTNETLINK answers: Invalid argument
Sat Apr 19 19:53:06 2014 user.emerg syslog: We have an error talking to the kernel
Sat Apr 19 19:53:06 2014 user.emerg syslog: RTNETLINK answers: Invalid argument
Sat Apr 19 19:53:06 2014 user.emerg syslog: We have an error talking to the kernel
Sat Apr 19 19:53:06 2014 user.emerg syslog: RTNETLINK answers: Invalid argument
Sat Apr 19 19:53:06 2014 user.emerg syslog: We have an error talking to the kernel
Sat Apr 19 19:53:06 2014 user.emerg syslog: RTNETLINK answers: Invalid argument
Sat Apr 19 19:53:06 2014 user.emerg syslog: We have an error talking to the kernel
Sat Apr 19 19:53:06 2014 user.emerg syslog: RTNETLINK answers: Invalid argument
Sat Apr 19 19:53:06 2014 user.emerg syslog: We have an error talking to the kernel
Sat Apr 19 19:53:06 2014 user.emerg syslog: RTNETLINK answers: Invalid argument
Sat Apr 19 19:53:06 2014 user.emerg syslog: We have an error talking to the kernel
Sat Apr 19 19:53:06 2014 user.emerg syslog: RTNETLINK answers: Invalid argument
Sat Apr 19 19:53:06 2014 user.emerg syslog: We have an error talking to the kernel
Sat Apr 19 19:53:06 2014 user.emerg syslog: RTNETLINK answers: Invalid argument
Sat Apr 19 19:53:06 2014 user.emerg syslog: We have an error talking to the kernel
Sat Apr 19 19:53:06 2014 user.emerg syslog: RTNETLINK answers: Invalid argument
Sat Apr 19 19:53:06 2014 user.emerg syslog: We have an error talking to the kernel
Sat Apr 19 19:53:06 2014 user.emerg syslog: RTNETLINK answers: Invalid argument
Sat Apr 19 19:53:06 2014 user.emerg syslog: We have an error talking to the kernel
Sat Apr 19 19:53:07 2014 kern.info kernel: [   31.650000] br-lan: port 2(wlan0) entered forwarding state

Attachments (0)

Change History (6)

comment:1 Changed 4 years ago by blogic

  • Resolution set to too_vague
  • Status changed from new to closed

not an ubox error, its network related.

unfortunately you forgot to make a real bug report explaining your setup

comment:2 Changed 4 years ago by anonymous

  • Resolution too_vague deleted
  • Status changed from closed to reopened

I have been using the same configuration
A DHCP WAN link (Cable Modem) with 6in4 Hurricane Electric Tunnel
This config has been working fine until the netifd commit then it started to generate the error in syslog.
This is not a error in my network config because I simply backup and old config on a older revision without any error and restored it after building the latest revision.

comment:3 Changed 4 years ago by blogic

still no info about the hardware and you reference the netfid commit. which one is it ?

please put in some effort to describe the bug instead of making an effort to expalin that the fault is not yours.

comment:4 Changed 4 years ago by anonymous

Hardware WR1043ND
I think it is this commmit
/changeset/40529.html
Because I had been building trunk consistently lately and the error message only appeared recently.

comment:5 Changed 4 years ago by anonymous

Network Config here

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface 'lan'
	option ifname 'eth0.1'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '64'

config interface 'wan'
	option proto 'dhcp'
	option _orig_ifname 'ppp0'
	option _orig_bridge 'false'
	option ifname 'eth0.2'
	option mtu '1440'
	option peerdns '0'

config switch
	option name 'rtl8366rb'
	option reset '1'
	option enable_vlan '1'
	option enable_vlan_4k '1'

config switch_vlan
	option device 'rtl8366rb'
	option vlan '1'
	option ports '1 2 3 4 5t'

config switch_vlan
	option device 'rtl8366rb'
	option vlan '2'
	option ports '0 5t'

config interface 'wan6'
	option proto '6in4'
	option ifname '@wan'
	option peeraddr '*.*.*.*'
	option ip6addr '2001:*::2/64'
	option tunnelid '*'
	option password '*'
	option ip6prefix '2001:*::/64'
	option username '*****'
	option mtu '1420'

config interface 'guest'
	option proto 'static'
	option ipaddr '192.168.0.1'
	option netmask '255.255.255.0'

comment:6 Changed 4 years ago by anonymous

Wireless Config here

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/ath9k'
	option macaddr '*:*:*:*:*:*'
	list ht_capab 'SHORT-GI-40'
	list ht_capab 'DSSS_CCK-40'
	option country 'US'
	option channel '7'
	option txpower '24'
	option hwmode '11ng'
	option htmode 'HT40-'
	option noscan '1'
	option short_preamble '1'

config wifi-iface
	option device 'radio0'
	option mode 'ap'
	option ssid 'SSID'
	option encryption 'psk2+ccmp'
	option key '*'
	option network 'guest'
	option macaddr 'B0:48:7A:B0:08:4B'
	option disabled '1'

config wifi-iface
	option device 'radio0'
	option mode 'ap'
	option ssid 'SSID'
	option network 'lan'
	option encryption 'psk2+ccmp'
	option key '*'

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.