Modify

Opened 4 years ago

Closed 4 years ago

#15621 closed defect (fixed)

r40526 hostapd-utils_2014-04-04-1_mpc85xx.ipk is not installable on TL-WDR4900 file clash with base-files

Reported by: tim@… Owned by: developers
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: Cc:

Description

root@OpenWrt:/tmp# opkg install hostapd-utils_2014-04-04-1_mpc85xx.ipk
Installing hostapd-utils (2014-04-04-1) to root...
Collected errors:

  • check_data_file_clashes: Package hostapd-utils wants to install file /etc/rc.button/wps

But that file is already provided by package * base-files

  • opkg_install_cmd: Cannot install package hostapd-utils.

root@OpenWrt:/tmp# uname -a
Linux OpenWrt 3.10.36 #1 Fri Apr 18 01:20:29 PDT 2014 ppc GNU/Linux
root@OpenWrt:/tmp# cat /etc/openwrt_*
DISTRIB_ID="OpenWrt"
DISTRIB_RELEASE="Bleeding Edge"
DISTRIB_REVISION="r40526"
DISTRIB_CODENAME="barrier_breaker"
DISTRIB_TARGET="mpc85xx/generic"
DISTRIB_DESCRIPTION="OpenWrt Barrier Breaker r40526"
DISTRIB_TAINTS=""
r40526

The file /etc/rc.button/wps

contains this:

#!/bin/sh

for dir in /var/run/hostapd-*; do

[ -d "$dir" ]
continue

hostapd_cli -p "$dir" wps_pbc

done

... so won't work without hostapd_cli installed - so maybe this needs to go from base-files ?

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in r40528

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.