Modify

Opened 4 years ago

Closed 4 years ago

#15620 closed defect (fixed)

wlan0 (5GHz) disappears soon after config r40526 TP-Link TL-WDR4900 ath9k mpc85xx

Reported by: tim@… Owned by: developers
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: Cc:

Description

wlan0 (5GHz interface) normally disappears straight after it is configured. A few times, it's worked (on boot-up), but now I can't reproduce that.

I've done a little kernel device driver dev work in the past, and would be happy to do a debug build if you think helpful...

Using bash:

root@OpenWrt:/etc/config# wifi up ; for i in {1..12} ; do ifconfig wlan0; sleep 0.05 ; done
ifconfig: wlan0: error fetching interface information: Device not found
ifconfig: wlan0: error fetching interface information: Device not found
ifconfig: wlan0: error fetching interface information: Device not found
ifconfig: wlan0: error fetching interface information: Device not found
ifconfig: wlan0: error fetching interface information: Device not found
wlan0 Link encap:Ethernet HWaddr F8:1A:67:5A:C3:BE

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wlan0 Link encap:Ethernet HWaddr F8:1A:67:5A:C3:BE

BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wlan0 Link encap:Ethernet HWaddr F8:1A:67:5A:C3:BE

BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wlan0 Link encap:Ethernet HWaddr F8:1A:67:5A:C3:BE

BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

ifconfig: wlan0: error fetching interface information: Device not found
ifconfig: wlan0: error fetching interface information: Device not found
ifconfig: wlan0: error fetching interface information: Device not found

running "wifi up" results in this in dmesg:

[ 1762.728649] device wlan1 left promiscuous mode
[ 1762.733209] br-lan: port 2(wlan1) entered disabled state
[ 1763.030633] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 1763.049221] device wlan0 entered promiscuous mode
[ 1763.054038] br-lan: port 2(wlan0) entered forwarding state
[ 1763.059553] br-lan: port 2(wlan0) entered forwarding state
[ 1763.069055] device wlan0 left promiscuous mode
[ 1763.073551] br-lan: port 2(wlan0) entered disabled state
[ 1763.161865] IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready
[ 1763.180718] device wlan1 entered promiscuous mode
[ 1763.185529] br-lan: port 2(wlan1) entered forwarding state
[ 1763.191073] br-lan: port 2(wlan1) entered forwarding state
[ 1763.352429] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready

Attachments (1)

enable-dfs.patch (943 bytes) - added by tim@… 4 years ago.
Enable DFS support in hostapd.conf (via uci)

Download all attachments as: .zip

Change History (5)

comment:1 Changed 4 years ago by nbd

anything relevant in the output of logread?

Changed 4 years ago by tim@…

Enable DFS support in hostapd.conf (via uci)

comment:2 Changed 4 years ago by anonymous

This turns out to be due to DFS not being enabled for hostapd (ieee80211h=1 in hostapd.conf).

I wasn't expecting wlan0 to actually disappear if hostapd couldn't be launched...

I created the patch attached, and then saw this:

http://patchwork.openwrt.org/patch/4933/

which is very similar...

comment:3 Changed 4 years ago by tim@…

See also #14867

comment:4 Changed 4 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

dfs support added in r40690

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.