Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#15601 closed defect (invalid)

IPV6 NAT modules missing absent

Reported by: 1@… Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: kernel Version: Trunk
Keywords: nat, ipv6, missing, ip6tables Cc:

Description

Similarly to ticket #13446, modules nf_nat_ipv6 and ip6table_nat are missing again from Barrier Breaker kernel, trunk r40462:

root@OpenWrt:~# cat /etc/openwrt_version 
r40462
root@OpenWrt:~# cat /etc/openwrt_release 
DISTRIB_ID="OpenWrt"
DISTRIB_RELEASE="Bleeding Edge"
DISTRIB_REVISION="r40462"
DISTRIB_CODENAME="barrier_breaker"
DISTRIB_TARGET="ar71xx/generic"
DISTRIB_DESCRIPTION="OpenWrt Barrier Breaker r40462"
DISTRIB_TAINTS=""
root@OpenWrt:~# ip6tables -L -t nat
ip6tables v1.4.21: can't initialize ip6tables table `nat': Table does not exist (do you need to insmod?)
Perhaps ip6tables or your kernel needs to be upgraded.
root@OpenWrt:~# opkg list | grep ipv6
kmod-ipv6 - 3.10.34-1
root@OpenWrt:~# opkg list | grep ip6
ip6tables - 1.4.21-1
kmod-ip6tables - 3.10.34-1
libip6tc - 1.4.21-1
root@OpenWrt:~# opkg files kmod-ip6tables
Package kmod-ip6tables (3.10.34-1) is installed on root and has the following files:
/etc/modules.d/42-ip6tables
/lib/modules/3.10.34/ip6t_ah.ko
/lib/modules/3.10.34/nf_defrag_ipv6.ko
/lib/modules/3.10.34/ip6t_REJECT.ko
/lib/modules/3.10.34/ip6t_rt.ko
/lib/modules/3.10.34/ip6t_eui64.ko
/lib/modules/3.10.34/ip6table_raw.ko
/lib/modules/3.10.34/ip6t_mh.ko
/lib/modules/3.10.34/ip6table_mangle.ko
/lib/modules/3.10.34/ip6t_ipv6header.ko
/lib/modules/3.10.34/ip6table_filter.ko
/lib/modules/3.10.34/ip6_tables.ko
/lib/modules/3.10.34/nf_conntrack_ipv6.ko
/lib/modules/3.10.34/ip6t_frag.ko
/lib/modules/3.10.34/ip6t_hbh.ko
root@OpenWrt:~#

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by nbd

  • Resolution set to not_a_bug
  • Status changed from new to closed

Install ip6tables-mod-nat

comment:2 Changed 4 years ago by anonymous

  • Resolution not_a_bug deleted
  • Status changed from closed to reopened

Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for ip6tables-mod-nat:
  • kernel (= 3.10.36-1-a75333b9effde4c67f0ca96ad1e686af) *
  • opkg_install_cmd: Cannot install package ip6tables-mod-nat.

comment:3 Changed 4 years ago by cyrus

  • Resolution set to invalid
  • Status changed from reopened to closed

You cannot install kernel modules with an older image.

You have to reflash latest trunk and immediately afterwards install the package.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.