Modify

Opened 4 years ago

Closed 4 years ago

#15600 closed defect (no_response)

Trunk compile error

Reported by: Erde Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: base system Version: Trunk
Keywords: vmlinux compile Cc:

Description

...
  AS      arch/mips/lib/strnlen_user.o
  CC      arch/mips/lib/uncached.o
  AR      arch/mips/lib/lib.a
  LINK    vmlinux
  LD      vmlinux.o
  MODPOST vmlinux.o
  GEN     .version
  CHK     include/generated/compile.h
  UPD     include/generated/compile.h
  CC      init/version.o
  LD      init/built-in.o
net/built-in.o: In function `lib80211_crypto_tkip_init':
net/wireless/lib80211_crypt_tkip.c:(.init.text+0x6650): undefined reference to `lib80211_register_crypto_ops'
make[5]: *** [vmlinux] Error 1
make[5]: Leaving directory `/home/openwrt/openwrt/build_dir/target-mips_34kc_uClibc-0.9.33.2/linux-ar71xx_generic/linux-3.10.36'
make[4]: *** [/home/openwrt/openwrt/build_dir/target-mips_34kc_uClibc-0.9.33.2/linux-ar71xx_generic/linux-3.10.36/.image] Error 2
make[4]: Leaving directory `/home/openwrt/openwrt/target/linux/ar71xx'
make[3]: *** [install] Error 2
make[3]: Leaving directory `/home/openwrt/openwrt/target/linux'
make[2]: *** [target/linux/install] Error 2
make[2]: Leaving directory `/home/openwrt/openwrt'
make[1]: *** [/home/openwrt/openwrt/staging_dir/target-mips_34kc_uClibc-0.9.33.2/stamp/.target_install] Error 2
make[1]: Leaving directory `/home/openwrt/openwrt'
make: *** [world] Error 2

I have no idea what the problem is.

PS: Fix your registeration system. I can't create a user account.

Attachments (0)

Change History (6)

comment:1 Changed 4 years ago by jow

Did you alter the default kernel configuration using make kernel_menuconfig?

comment:2 Changed 4 years ago by Erde

Good guess. Yes I did. I got rid of the undefined reference by removing LIB80211_CRYPT_TKIP via kernel_menuconfig, but rest of the problem is still there. I don't know what change could cause such a problem.

Should the kernel settings stay as defaults? I can just start over by rm'ing .config and doing make clean?

comment:3 follow-up: Changed 4 years ago by Erde

Good guess. Yes I did. I got rid of the undefined reference by removing LIB80211_CRYPT_TKIP from kernel_menuconfig, but rest of the problem is still there. I don't know what change could cause such a problem.

comment:4 in reply to: ↑ 3 Changed 4 years ago by Erde

Sorry about that duplicate. I don't know how that got posted when I restored my browser session.

comment:5 Changed 4 years ago by jow

OpenWrt builds its wireless stack from external compat-wireless, not from kernel sources therefore it rarely makes sense to enable wireless stuff in the kernel, it will clash with the mac80211 packaging.

The kernel_menuconfig command will alter the kernel default config templates inplace, so you should see the changes it made using "git diff" or "svn diff". You can revert those changes by doing "git checkout" / "svn revert" on the affected config templates.

Afterwards run "make target/linux/prepare" to prepare a fresh kernel tree with an OpenWrt-default .config.

comment:6 Changed 4 years ago by nbd

  • Resolution set to no_response
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.