Modify

Opened 4 years ago

Last modified 4 years ago

#15586 new defect

USB Back-UPS ES 700G not detected

Reported by: vsuchard@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: usb Cc:

Description

Not able to detect USB Back-UPS ES 700G in my TL-WR1043ND
When I do plug USB cable into the router get:

[10373.710000] usb 1-1: new low-speed USB device number 14 using ehci-platform
[10388.890000] usb 1-1: device descriptor read/64, error -145

My lsusb:

root@tplink:~# lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

On my linux box (Fedora20) it works like:

[206790.551567] usb 2-2: new low-speed USB device number 13 using xhci_hcd
[206790.607199] usb 2-2: New USB device found, idVendor=051d, idProduct=0002
[206790.607202] usb 2-2: New USB device strings: Mfr=3, Product=1, SerialNumber=2
[206790.607204] usb 2-2: Product: Back-UPS ES 700G FW:871.O3 .I USB FW:O3
[206790.607205] usb 2-2: Manufacturer: APC
[206790.607206] usb 2-2: SerialNumber: 5B1333T06519
[206790.607689] usb 2-2: ep 0x81 - rounding interval to 64 microframes, ep desc says 80 microframes
[206790.919862] hid-generic 0003:051D:0002.0005: hiddev0,hidraw2: USB HID v1.10 Device [APC Back-UPS ES 700G FW:871.O3 .I USB FW:O3 ] on usb-0000:00:14.0-2/input0

lsusb

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 013: ID 051d:0002 American Power Conversion Uninterruptible Power Supply
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Installed knod-usb on my router:

root@tplink:~# opkg list-installed| grep usb
kmod-usb-core - 3.10.36-1
kmod-usb-hid - 3.10.36-1
kmod-usb2 - 3.10.36-1
libusb-1.0 - 1.0.9-1
libusb-compat - 0.1.4-1
nut-driver-usbhid-ups - 2.6.5-2
usbutils - 007-1

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by vsuchard@…

when use kmod-usb3 get:

[  163.980000] usb 1-1: new low-speed USB device number 6 using ehci-platform

comment:2 Changed 4 years ago by ppvazquezfer@…

Some Atheros chips do not support low and full speed usb devices due to a hardware limitation. There are people that solved this issue using a usb hub with low/full speed support.

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.