Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#15428 closed defect (fixed)

pppd broken in AA r40348

Reported by: covokoff@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Attitude Adjustment 12.09
Keywords: pppd broken Cc:

Description

I have pptpd server on MR3020 TpLink router.

Sep 8 15:45:10 OpenWrt daemon.info pptpd[989]: CTRL: Client 192.168.1.121 control connection started
Sep 8 15:45:10 OpenWrt daemon.info pptpd[989]: CTRL: Starting call (launching pppd, opening GRE)
Sep 8 15:45:11 OpenWrt daemon.err pppd[990]: unrecognized option '???????????????168.1.1'
Sep 8 15:45:11 OpenWrt daemon.err pptpd[989]: GRE: read(fd=6,buffer=416518,len=8196) from PTY failed: status = -1 error = Input/output error, usually caused by unexpected termination of pppd, check option syntax and pppd logs
Sep 8 15:45:11 OpenWrt daemon.err pptpd[989]: CTRL: PTY read or GRE write failed (pty,gre)=(6,7)
Sep 8 15:45:11 OpenWrt daemon.debug pptpd[989]: CTRL: Reaping child PPP[990]
Sep 8 15:45:11 OpenWrt daemon.info pptpd[989]: CTRL: Client 192.168.1.121 control connection finished
Sep 8 15:45:11 OpenWrt daemon.err pptpd[989]: CTRL: Couldn't write packet to client.
Sep 8 15:45:11 OpenWrt daemon.err pptpd[989]: CTRL: Couldn't write packet to client.

Attachments (0)

Change History (10)

comment:1 Changed 4 years ago by anonymous

using r40380, the same problem like "unrecognized option '???????????????168.1.1'"

comment:2 Changed 4 years ago by anonymous

using r40528, still the same problem, error is "daemon.err pppd[5040]: unrecognized option '???????????????168.0.20'"

comment:3 Changed 4 years ago by anonymous

The same error daemon.err pppd[2295]: unrecognized option '???????????????.199'

That option is the "remoteip" in /etc/ppp/pptpd, but doesn't should give error.

comment:4 Changed 4 years ago by anonymous

Tried to comment remoteip option, this is the log:

Sun Apr 20 01:25:24 2014 daemon.info pptpd[3188]: MGR: Manager process started
Sun Apr 20 01:25:24 2014 daemon.info pptpd[3188]: MGR: Maximum of 100 connections available
Sun Apr 20 01:25:51 2014 daemon.info pptpd[3192]: CTRL: Client xx.xx.xx.66 control connection started
Sun Apr 20 01:25:51 2014 daemon.info pptpd[3192]: CTRL: Starting call (launching pppd, opening GRE)
Sun Apr 20 01:25:51 2014 daemon.err pppd[3193]: unrecognized option '???????????????8.1.1'
Sun Apr 20 01:25:51 2014 daemon.err pptpd[3192]: GRE: read(fd=7,buffer=41e76c,len=8196) from PTY failed: status = -1 error = Input/output error, usually caused by unexpected termination of pppd, check option syntax and pppd logs
Sun Apr 20 01:25:51 2014 daemon.err pptpd[3192]: CTRL: PTY read or GRE write failed (pty,gre)=(7,8)
Sun Apr 20 01:25:51 2014 daemon.debug pptpd[3192]: CTRL: Reaping child PPP[3193]
Sun Apr 20 01:25:51 2014 daemon.info pptpd[3192]: CTRL: Client xx.xx.xx.66 control connection finished
Sun Apr 20 01:25:51 2014 daemon.err pptpd[3192]: CTRL: Couldn't write packet to client.
Sun Apr 20 01:25:51 2014 daemon.err pptpd[3192]: CTRL: Couldn't write packet to client.

comment:5 Changed 4 years ago by anonymous

comment:6 Changed 4 years ago by anonymous

Yep. that worked! however, to setup the whole source just to recompile pptpd took some time, but well... after all it worked.
Hope openwrt developers catch up with a more recent version of pptp soon.

Thanks!!

comment:7 Changed 4 years ago by hnyman

A patch to upgrade pptpd to v.1.4.0 has been submitted to the mailing list. The patch should be applicable both to trunk and to AA12.09 packages.
http://patchwork.openwrt.org/patch/5280/

The patch bumps pptpd to 1.4.0 and seems to fix the problem. Below is log output with identical config:

pptpd 1.3.4:

Fri May  2 19:02:01 2014 user.info syslog: module is already loaded - arc4
Fri May  2 19:02:01 2014 user.info syslog: module is already loaded - sha1_generic
Fri May  2 19:02:01 2014 user.info syslog: module is already loaded - slhc
Fri May  2 19:02:01 2014 user.info syslog: module is already loaded - crc-ccitt
Fri May  2 19:02:01 2014 user.info syslog: module is already loaded - ppp_generic
Fri May  2 19:02:01 2014 user.info syslog: module is already loaded - ppp_async
Fri May  2 19:02:01 2014 user.info syslog: module is already loaded - ppp_mppe
Fri May  2 19:02:01 2014 daemon.info pptpd[3615]: MGR: Maximum of 100 connections reduced to 11, not enough IP addresses given
Fri May  2 19:02:01 2014 daemon.info pptpd[3616]: MGR: Manager process started
Fri May  2 19:02:01 2014 daemon.info pptpd[3616]: MGR: Maximum of 11 connections available
Fri May  2 19:11:03 2014 daemon.info pptpd[3630]: CTRL: Client 192.168.1.2 control connection started
Fri May  2 19:11:04 2014 daemon.info pptpd[3630]: CTRL: Starting call (launching pppd, opening GRE)
Fri May  2 19:11:04 2014 daemon.err pppd[3631]: unrecognized option XXXXXXXXXXXXX168.0.20'
Fri May  2 19:11:04 2014 daemon.err pptpd[3630]: GRE: read(fd=6,buffer=41e76c,len=8196) from PTY failed: status = -1 error = Input/output error, usually caused by unexpected termination of pppd, check option syntax and pppd logs
Fri May  2 19:11:04 2014 daemon.err pptpd[3630]: CTRL: PTY read or GRE write failed (pty,gre)=(6,7)
Fri May  2 19:11:04 2014 daemon.debug pptpd[3630]: CTRL: Reaping child PPP[3631]
Fri May  2 19:11:04 2014 daemon.info pptpd[3630]: CTRL: Client 192.168.1.2 control connection finished
Fri May  2 19:11:04 2014 daemon.err pptpd[3630]: CTRL: Couldn't write packet to client.
Fri May  2 19:11:04 2014 daemon.err pptpd[3630]: CTRL: Couldn't write packet to client.


pptpd 1.4.0:

Fri May  2 19:21:44 2014 user.info syslog: module is already loaded - arc4
Fri May  2 19:21:44 2014 user.info syslog: module is already loaded - sha1_generic
Fri May  2 19:21:44 2014 user.info syslog: module is already loaded - slhc
Fri May  2 19:21:44 2014 user.info syslog: module is already loaded - crc-ccitt
Fri May  2 19:21:44 2014 user.info syslog: module is already loaded - ppp_generic
Fri May  2 19:21:44 2014 user.info syslog: module is already loaded - ppp_async
Fri May  2 19:21:44 2014 user.info syslog: module is already loaded - ppp_mppe
Fri May  2 19:21:44 2014 daemon.info pptpd[3676]: MGR: Maximum of 100 connections reduced to 11, not enough IP addresses given
Fri May  2 19:21:44 2014 daemon.info pptpd[3677]: MGR: Manager process started
Fri May  2 19:21:44 2014 daemon.info pptpd[3677]: MGR: Maximum of 11 connections available
Fri May  2 19:21:54 2014 daemon.info pptpd[3680]: CTRL: Client 192.168.1.2 control connection started
Fri May  2 19:21:55 2014 daemon.info pptpd[3680]: CTRL: Starting call (launching pppd, opening GRE)
Fri May  2 19:21:55 2014 daemon.notice pppd[3681]: pppd 2.4.5 started by root, uid 0
Fri May  2 19:21:55 2014 daemon.info pppd[3681]: Using interface ppp0
Fri May  2 19:21:55 2014 daemon.notice pppd[3681]: Connect: ppp0 <--> /dev/pts/1
Fri May  2 19:21:55 2014 daemon.warn pppd[3681]: Warning - secret file /etc/ppp/chap-secrets has world and/or group access
Fri May  2 19:21:55 2014 daemon.notice pppd[3681]: peer from calling number 192.168.1.2 authorized
Fri May  2 19:21:55 2014 daemon.notice pppd[3681]: MPPE 128-bit stateless compression enabled
Fri May  2 19:21:55 2014 daemon.notice pppd[3681]: local  IP address 192.168.0.1
Fri May  2 19:21:55 2014 daemon.notice pppd[3681]: remote IP address 192.168.0.20

comment:8 Changed 4 years ago by hauke

  • Resolution set to fixed
  • Status changed from new to closed

This was fixed in r40671.

comment:9 Changed 4 years ago by hnyman

I think that the patch needs to be applied also to /packages_12.09 before we can really say that this bug regarding AA has been fixed.

https://dev.openwrt.org/browser/branches/packages_12.09/net/pptpd/Makefile

I applied the same patch yesterday also to AA12.09 packages and pptpd compiled ok. I did not test the actual binary.

comment:10 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.