Modify

Opened 4 years ago

Closed 4 years ago

#15417 closed defect (fixed)

add missing dependency to lsblk

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: libmount lsblk Cc:

Description

fix lsblk build error

Package lsblk is missing dependencies for the following libraries:
libmount.so.1

add libmount to depedency in Makefile

Index: package/utils/util-linux/Makefile
===================================================================
--- package/utils/util-linux/Makefile   (revision 40295)
+++ package/utils/util-linux/Makefile   (working copy)
@@ -240,7 +240,7 @@
 define Package/lsblk
 $(call Package/util-linux/Default)
   TITLE:=list block devices
-  DEPENDS:= +libblkid
+  DEPENDS:= +libblkid +libmount
   SUBMENU=disc
 endef

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by blogic

  • Resolution set to fixed
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.