Modify

Opened 4 years ago

Last modified 3 years ago

#15342 new defect

rtl8192cu driver has some problems

Reported by: 43344319@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: rtl8192cu Cc:

Description

[   32.072000] br-lan: port 2(ra0) entered forwarding state
[   32.076000] br-lan: port 2(ra0) entered forwarding state
[   34.080000] br-lan: port 2(ra0) entered forwarding state
[   39.844000] jffs2: Too few erase blocks (4)
[  111.424000] rtl8192cu: MAC auto ON okay!
[  111.468000] rtl8192cu: Tx queue select: 0x05
[  113.260000] rtl8192cu: MAC auto ON okay!
[  113.312000] rtl8192cu: Tx queue select: 0x05
[  115.064000] rtl8192cu: MAC auto ON okay!
[  115.116000] rtl8192cu: Tx queue select: 0x05
[  130.968000] br-lan: port 2(ra0) entered disabled state
[  131.684000] rtl8192cu: MAC auto ON okay!
[  131.732000] rtl8192cu: Tx queue select: 0x05
[  134.132000] EEPROM:Read from [Factory] offset 0x0,length 0x200.
[  139.268000] 0x1300 = 00064380
[  139.272000] br-lan: port 2(ra0) entered forwarding state
[  139.276000] br-lan: port 2(ra0) entered forwarding state
[  139.296000] wlan0: authenticate with 14:e6:e4:34:8a:ec
[  139.328000] wlan0: send auth to 14:e6:e4:34:8a:ec (try 1/3)
[  139.336000] wlan0: authenticated
[  139.344000] wlan0: associate with 14:e6:e4:34:8a:ec (try 1/3)
[  139.392000] wlan0: RX AssocResp from 14:e6:e4:34:8a:ec (capab=0x431 status=0 aid=2)
[  139.400000] wlan0: associated
[  141.280000] br-lan: port 2(ra0) entered forwarding state
[  143.456000] wlan0: deauthenticated from 14:e6:e4:34:8a:ec (Reason: 2)
[  144.304000] wlan0: authenticate with 14:e6:e4:34:8a:ec
[  144.328000] wlan0: send auth to 14:e6:e4:34:8a:ec (try 1/3)
[  144.348000] wlan0: authenticated
[  144.360000] wlan0: associate with 14:e6:e4:34:8a:ec (try 1/3)
[  144.368000] wlan0: RX AssocResp from 14:e6:e4:34:8a:ec (capab=0x431 status=0 aid=2)
[  144.376000] wlan0: associated
[  160.756000] br-lan: port 2(ra0) entered disabled state
[  160.760000] br-lan: port 1(eth2.1) entered disabled state
[  160.784000] device eth2.1 left promiscuous mode
[  160.788000] br-lan: port 1(eth2.1) entered disabled state
[  160.808000] device ra0 left promiscuous mode
[  160.812000] br-lan: port 2(ra0) entered disabled state
[  160.904000] device eth2.1 entered promiscuous mode
[  160.944000] device ra0 entered promiscuous mode
[  160.968000] br-lan: port 2(ra0) entered forwarding state
[  160.972000] br-lan: port 2(ra0) entered forwarding state
[  160.976000] br-lan: port 1(eth2.1) entered forwarding state
[  160.984000] br-lan: port 1(eth2.1) entered forwarding state
[  161.264000] wlan0: deauthenticating from 14:e6:e4:34:8a:ec by local choice (reason=3)
[  161.484000] br-lan: port 2(ra0) entered disabled state
[  162.280000] rtl8192cu: MAC auto ON okay!
[  162.324000] rtl8192cu: Tx queue select: 0x05
[  162.988000] br-lan: port 1(eth2.1) entered forwarding state
[  163.004000] ESW: Link Status Changed - Port2 Link Down
[  164.620000] EEPROM:Read from [Factory] offset 0x0,length 0x200.
[  167.732000] ESW: Link Status Changed - Port2 Link UP
[  169.768000] 0x1300 = 00064380
[  169.772000] br-lan: port 2(ra0) entered forwarding state
[  169.776000] br-lan: port 2(ra0) entered forwarding state
[  169.788000] wlan0: authenticate with 14:e6:e4:34:8a:ec
[  169.812000] wlan0: send auth to 14:e6:e4:34:8a:ec (try 1/3)
[  169.856000] wlan0: authenticated
[  169.892000] wlan0: associate with 14:e6:e4:34:8a:ec (try 1/3)
[  169.920000] wlan0: RX AssocResp from 14:e6:e4:34:8a:ec (capab=0x431 status=0 aid=2)
[  169.928000] wlan0: associated
[  171.780000] br-lan: port 2(ra0) entered forwarding state
[  342.372000] wlan0: deauthenticated from 14:e6:e4:34:8a:ec (Reason: 7)
[  342.408000] wlan0: authenticate with 14:e6:e4:34:8a:ec
[  342.424000] wlan0: send auth to 14:e6:e4:34:8a:ec (try 1/3)
[  342.436000] wlan0: authenticated
[  342.444000] wlan0: associate with 14:e6:e4:34:8a:ec (try 1/3)
[  342.464000] wlan0: RX AssocResp from 14:e6:e4:34:8a:ec (capab=0x431 status=0 aid=1)
[  342.472000] wlan0: associated
[  579.304000] wlan0: deauthenticated from 14:e6:e4:34:8a:ec (Reason: 7)
[  579.332000] wlan0: authenticate with 14:e6:e4:34:8a:ec
[  579.348000] wlan0: send auth to 14:e6:e4:34:8a:ec (try 1/3)
[  579.356000] wlan0: authenticated
[  579.364000] wlan0: associate with 14:e6:e4:34:8a:ec (try 1/3)
[  579.396000] wlan0: RX AssocResp from 14:e6:e4:34:8a:ec (capab=0x431 status=0 aid=2)
[  579.404000] wlan0: associated
[ 1248.344000] wlan0: deauthenticated from 14:e6:e4:34:8a:ec (Reason: 2)
[ 1249.212000] wlan0: authenticate with 14:e6:e4:34:8a:ec
[ 1249.232000] wlan0: send auth to 14:e6:e4:34:8a:ec (try 1/3)
[ 1249.240000] wlan0: authenticated
[ 1249.248000] wlan0: associate with 14:e6:e4:34:8a:ec (try 1/3)
[ 1249.284000] wlan0: RX AssocResp from 14:e6:e4:34:8a:ec (capab=0x431 status=0 aid=2)
[ 1249.292000] wlan0: associated
[ 1302.324000] wlan0: deauthenticated from 14:e6:e4:34:8a:ec (Reason: 7)
[ 1302.352000] wlan0: authenticate with 14:e6:e4:34:8a:ec
[ 1302.372000] wlan0: send auth to 14:e6:e4:34:8a:ec (try 1/3)
[ 1302.380000] wlan0: authenticated
[ 1302.388000] wlan0: associate with 14:e6:e4:34:8a:ec (try 1/3)
[ 1302.408000] wlan0: RX AssocResp from 14:e6:e4:34:8a:ec (capab=0x431 status=0 aid=1)
[ 1302.416000] wlan0: associated

The rtl8192cu driver in compat-wireless-2014-01-23.1.

I use this rtl8192cu card to connect the wireless signal success,And access to the Internet,But a few minutes later could not access the net,After I click the reconnect button, and normal Internet access.

Please fix this BUG,Thanks.

Attachments (1)

AR9331_log.txt (1.8 KB) - added by birdbug 4 years ago.
AR9331 log

Download all attachments as: .zip

Change History (7)

comment:1 follow-ups: Changed 4 years ago by anonymous

For me it doesn't even want to connect at all. AP mode and STA mode both don't work, but I'm not sure if my problem is related to yours.

comment:2 in reply to: ↑ 1 Changed 4 years ago by anonymous

Replying to anonymous:

For me it doesn't even want to connect at all. AP mode and STA mode both don't work, but I'm not sure if my problem is related to yours.

STA mode can work,but a few minutes later the rtl8192cu will not work.

comment:3 Changed 4 years ago by anonymous

Why no people to solve the problem?

Changed 4 years ago by birdbug

AR9331 log

comment:4 in reply to: ↑ 1 Changed 4 years ago by birdbug

Replying to anonymous:

For me it doesn't even want to connect at all. AP mode and STA mode both don't work, but I'm not sure if my problem is related to yours.

Yes, the same problem on AR71xx. I found the problem was solved about 2 years ago, but i was found again on trunk(r36692).I checked and tried all the patches of the problem, but it was still alive.
@nbd

comment:5 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:6 Changed 3 years ago by anonymous

deauthenticated (Reason: 7=CLASS3_FRAME_FROM_NONASSOC_STA)

class3 frame from nonassociated sta should speak for itself:

a client out there is doing a DOS on your link.

tested and confirmed.

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.