Modify

Opened 4 years ago

Closed 3 years ago

#15282 closed defect (duplicate)

Alfa Hornet-UB board WPS and RESET button GPIO reversed

Reported by: lsoltero@… Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: kernel Version: Trunk
Keywords: Hornet-UB reset wps Cc:

Description

on the Alfa Hornet-UB board the GPIO definitions for the WPS and RESET buttons are reversed. Here is a patch that fixes the issue.

--- a/target/linux/ar71xx/files/arch/mips/ath79/mach-hornet-ub.c
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-hornet-ub.c
@@ -28,8 +28,8 @@

#define HORNET_UB_GPIO_LED_WAN 17
#define HORNET_UB_GPIO_LED_WPS 27


-#define HORNET_UB_GPIO_BTN_RESET 11
-#define HORNET_UB_GPIO_BTN_WPS 12
+#define HORNET_UB_GPIO_BTN_RESET 12
+#define HORNET_UB_GPIO_BTN_WPS 11

#define HORNET_UB_GPIO_USB_POWER 26

Attachments (1)

0001-Fix-duplicate-tickets-14136-and-15282-Hornet-UB-GPIO.patch (2.8 KB) - added by janne.cederberg@… 3 years ago.
Git patch for ticket (same as on #14136)

Download all attachments as: .zip

Change History (4)

comment:1 Changed 3 years ago by janne.cederberg@…

This ticket is a duplicate of #14136. My accident attached the patch twice and didn't find how to remove one.

Patching as suggested on #14136/#15282 will result in a situation where simply pressing the RESET button on the bottom will cause FACTORY RESET to be run. This is due to GPIO high/low state being incorrect as a result of the above change and virtually the RESET
button is in the pressed-down state the entire time. When it is then physically pressed, that causes the opposite, release, to be triggered and since to the board it seemed that the button was pressed long before it was released, the FACTORY RESET results.

The attached patch works as expected. I have verified both the incorrect functionality as well as after fixing the issue as described in the patch and flashing the resulting firmware to a Hornet-UB board.

Changed 3 years ago by janne.cederberg@…

Git patch for ticket (same as on #14136)

comment:2 Changed 3 years ago by jberg

This change has been committed to trunk as of http://git.openwrt.org/?p=openwrt.git;a=commitdiff;h=beed4d82d6a0154b0cd5f7b84e2180215ace6718 and will be present in Chaos Calmer release. I've updated the corresponding GPIO info on http://wiki.openwrt.org/toh/alfa.network/hornet-ub#gpio

A thank you goes to lsoltero for keeping the issue alive toward Chaos Calmer after jrosen posted it for Barrier Breaker (#14136)!

[This ticket could/should be closed but I don't have sufficient permissions to do so.]

comment:3 Changed 3 years ago by rmilecki

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #14136

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.