Modify

Opened 4 years ago

Closed 4 years ago

#15281 closed defect (fixed)

php missing in latest ar71xx trunk

Reported by: dustbowl@… Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: Cc:

Description

php5/php-cgi is missing in latest trunk. what else is missing, and why?

Attachments (0)

Change History (6)

comment:1 in reply to: ↑ description Changed 4 years ago by hnyman

Replying to dustbowl@…:

what else is missing, and why?

Nice open-ended question...
This is missing: http://buildbot.openwrt.org:8010/broken_packages/ar71xx/
(That list is updated during the buildbot snapshot process, so the contents change at each build. Contents will be different in a few hours.)

In general, the default compiler was updated to gcc 4.8 a few days ago and that has broken some packages due to to more strict warnings and MIPS16 code.

Regarding php, it is on that broken packages log, and at the first glance it looks like the breakage might be due to curl, which got broken due to polarssl upgrade r39930, which breakage has already been fixed by r39931.

The previous snapshot was based on r39930, so curl was broken in that.

The current r39931 snapshot being uploaded at this moment (http://buildbot.openwrt.org:8010/builders/ar71xx/builds/449) might again include both curl and php, if the reason for php breakage was curl.

comment:2 Changed 4 years ago by anonymous

Sorr sorry, yes I noticed it too now that last days compile broke here and there, anyway, it would be nice to have these "secret" links somewhere on the ticket system in the top area, also this link where the build schedule is, and how the status is, I have forgotten how the link was.

Also: the ticket system should run on another server as the buildbot/all the trunk stuff. Because it's annoying if you get a nginx gateway error or idle timeout all the time here, mostly caused by back ground builing or uploading.

comment:3 Changed 4 years ago by jow

They are on entirely different datacenters.

comment:4 Changed 4 years ago by anonymous

Then fix your datacenters, I guess? It was just a guess that this causes this. But your ticket system, this site, is so many times offline/pings out or gives nxginx "bad gateway" errors.

comment:5 Changed 4 years ago by jow

Awesome suggestion ;) Never could thought of that myself... the matter is not as easy as it looks from the outside and it is being worked on.

comment:6 Changed 4 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.