Modify

Opened 4 years ago

Last modified 4 years ago

#15244 reopened defect

Multi-ssid Allocation Error

Reported by: banglang.huang@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Attitude Adjustment 12.09
Keywords: wifi ssid Cc:

Description

Hi all,

My device's (DB120) network down when I configure 8 ssid on it, below is the error message:

root@OpenWrt:/# /sbin/wifi up
disable_mac80211 is a shell function
disable_mac80211 is a shell function
enable_mac80211 is a shell function
Command failed: Not found
Command failed: Not found
Command failed: Not found
Command failed: Not found
Command failed: Not found
Command failed: Not found
Command failed: Not found
Command failed: Not found
[ 3852.540000] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 3852.570000] device wlan0 entered promiscuous mode
[ 3852.620000] ADDRCONF(NETDEV_UP): wlan0: link is not ready
uci: Entry not found
[ 3852.680000] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 3852.710000] device wlan0-1 entered promiscuous mode
[ 3852.710000] ADDRCONF(NETDEV_UP): wlan0-1: link is not ready
[ 3852.730000] ADDRCONF(NETDEV_CHANGE): wlan0-1: link becomes ready
[ 3852.740000] device wlan0-2 entered promiscuous mode
[ 3852.760000] ADDRCONF(NETDEV_UP): wlan0-2: link is not ready
[ 3852.780000] ADDRCONF(NETDEV_CHANGE): wlan0-2: link becomes ready
[ 3852.790000] device wlan0-3 entered promiscuous mode
[ 3852.800000] ADDRCONF(NETDEV_UP): wlan0-3: link is not ready
[ 3852.820000] ADDRCONF(NETDEV_CHANGE): wlan0-3: link becomes ready
[ 3852.830000] device wlan0-4 entered promiscuous mode
[ 3852.850000] ADDRCONF(NETDEV_UP): wlan0-4: link is not ready
[ 3852.870000] ADDRCONF(NETDEV_CHANGE): wlan0-4: link becomes ready
[ 3852.880000] device wlan0-5 entered promiscuous mode
[ 3852.900000] ADDRCONF(NETDEV_UP): wlan0-5: link is not ready
[ 3852.920000] ADDRCONF(NETDEV_CHANGE): wlan0-5: link becomes ready
[ 3852.930000] device wlan0-6 entered promiscuous mode
[ 3852.950000] ADDRCONF(NETDEV_UP): wlan0-6: link is not ready
[ 3852.970000] ADDRCONF(NETDEV_CHANGE): wlan0-6: link becomes ready
[ 3852.980000] device wlan0-7 entered promiscuous mode
[ 3853.000000] ADDRCONF(NETDEV_UP): wlan0-7: link is not ready
[ 3853.010000] ADDRCONF(NETDEV_CHANGE): wlan0-7: link becomes ready
Command failed: Not found
Command failed: Not found
Command failed: Not found
Command failed: Not found
Command failed: Not found
Command failed: Not found
Command failed: Not found
Command failed: Not found
enable_mac80211 is a shell function
cat: write error: No space left on device
Command failed: Not found
cat: write error: No space left on device
Command failed: Not found
cat: write error: No space left on device
Command failed: Not found
cat: write error: No space left on device
Command failed: Not found
cat: write error: No space left on device
Command failed: Not found
cat: write error: No space left on device
Command failed: Not found
cat: write error: No space left on device
Command failed: Not found
cat: write error: No space left on device
Command failed: Not found
cat: write error: No space left on device

Attachments (0)

Change History (5)

comment:1 Changed 4 years ago by nbd

  • Resolution set to too_vague
  • Status changed from new to closed

No idea what kind of modifications, version, config, etc. you're using.

comment:2 Changed 4 years ago by banglang.huang@…

  • Resolution too_vague deleted
  • Status changed from closed to reopened

My testbed is Atheros DB120, 12.09 Attitude Adjustment openwrt,

Content of /etc/config/wireless:
config wifi-device radio0

option type mac80211
option channel 11
option hwmode 11ng
option path 'platform/ar934x_wmac'
option htmode HT20
list ht_capab LDPC
list ht_capab SHORT-GI-20
list ht_capab SHORT-GI-40
list ht_capab TX-STBC
list ht_capab RX-STBC1
list ht_capab DSSS_CCK-40
# REMOVE THIS LINE TO ENABLE WIFI:
option disabled 0

config wifi-iface

option device radio0
option network lan
option mode ap
option ssid OpenWrt1
option encryption none

config wifi-iface

option device radio0
option network lan
option mode ap
option ssid OpenWrt2
option encryption none

config wifi-iface

option device radio0
option network lan
option mode ap
option ssid OpenWrt3
option encryption none

config wifi-iface

option device radio0
option network lan
option mode ap
option ssid OpenWrt4
option encryption none

config wifi-iface

option device radio0
option network lan
option mode ap
option ssid OpenWrt5
option encryption none

config wifi-iface

option device radio0
option network lan
option mode ap
option ssid OpenWrt6
option encryption none


config wifi-iface

option device radio0
option network lan
option mode ap
option ssid OpenWrt7
option encryption none

config wifi-iface

option device radio0
option network lan
option mode ap
option ssid OpenWrt8
option encryption none

config wifi-device radio1

option type mac80211
option channel 36
option hwmode 11na
option path 'pci0000:00/0000:00:00.0'
option htmode HT20
list ht_capab LDPC
list ht_capab SHORT-GI-20
list ht_capab SHORT-GI-40
list ht_capab TX-STBC
list ht_capab RX-STBC1
list ht_capab DSSS_CCK-40
# REMOVE THIS LINE TO ENABLE WIFI:
option disabled 0

config wifi-iface

option device radio1
option network lan
option mode ap
option ssid OpenWrt1
option encryption none

config wifi-iface

option device radio1
option network lan
option mode ap
option ssid OpenWrt2
option encryption none

config wifi-iface

option device radio1
option network lan
option mode ap
option ssid OpenWrt3
option encryption none

config wifi-iface

option device radio1
option network lan
option mode ap
option ssid OpenWrt4
option encryption none

config wifi-iface

option device radio1
option network lan
option mode ap
option ssid OpenWrt5
option encryption none

config wifi-iface

option device radio1
option network lan
option mode ap
option ssid OpenWrt6
option encryption none


config wifi-iface

option device radio1
option network lan
option mode ap
option ssid OpenWrt7
option encryption none

config wifi-iface

option device radio1
option network lan
option mode ap
option ssid OpenWrt8
option encryption none

comment:3 Changed 4 years ago by banglang.huang@…

Also modified the /sbin/wifi file,
change the output properties:
2>/dev/null >/dev/null to 2>&1

comment:4 Changed 4 years ago by anonymous

Hey, I had found where the 'Command failed:Not found' occurs,
in /lib/network/config.sh , line:74,
function setup_interface() {

...
ubus call network.interface.$config add_device {\"name\" : $iface}

}

because there is no information on the ubus table when the $config is equal "wlan0".

comment:5 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.