Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#15243 closed defect (duplicate)

r39888 / ath9k / warning in recv.c

Reported by: bittorf@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

it doesnt seem to have an impact, it's just a report:

Mar 13 05:59:32 ' [up 40423s 5619712 bytes free] /bin/sh [daemon.alert] kernellog() ath9k/recv.c:
[40418.620000] ath: phy0: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x42000020 DMADBG_7=0x000286c0
[40418.630000] ath: phy0: Could not stop RX, we could be confusing the DMA engine when we start RX up
[40418.640000] ------------[ cut here ]------------
[40418.650000] WARNING: at /home/bastian/owrtbuild/openwrt/build_dir/target-mips_34kc_uClibc-0.9.33.2/linux-ar71xx_generic/compat-wireless-2014-01-23.1/drivers/net/wireless/ath/ath9k/recv.c:491 ath_stoprecv+0x108/0x132c [ath9k]()
[40418.670000] Modules linked in: ath9k ath9k_common pppoe ppp_async iptable_nat ath9k_hw ath pppox ppp_generic nf_nat_ipv4 nf_conntrack_ipv4 mac80211 ipt_MASQUERADE cfg80211 xt_time xt_tcpudp xt_tcpmss xt_statistic xt_state xt_nat xt_multiport xt_mark xt_mac xt_limit xt_length xt_hl xt_ecn xt_dscp xt_conntrack xt_comment xt_TCPMSS xt_REDIRECT xt_NETMAP xt_LOG xt_HL xt_DSCP xt_CT xt_CLASSIFY slhc nf_nat_irc nf_nat_ftp nf_nat nf_defrag_ipv4 nf_conntrack_irc nf_conntrack_ftp libcrc32c iptable_raw iptable_mangle iptable_filter ipt_ULOG ipt_REJECT ipt_ECN ip_tables crc16 crc_ccitt compat sch_teql sch_tbf sch_sfq sch_red sch_prio sch_htb sch_gred sch_dsmark sch_codel em_text em_nbyte em_meta em_cmp cls_basic act_police act_ipt act_skbedit act_mirred em_u32 cls_u32 cls_tcindex cls_flow cls_route cls_fw sch_hfsc sch_ingress ledtrig_usbdev ledtrig_netdev ip6t_REJECT ip6t_rt ip6t_hbh ip6t_mh ip6t_ipv6header ip6t_frag ip6t_eui64 ip6t_ah ip6table_raw ip6table_mangle ip6table_filter ip6_tables x_tables nf_conntrack_ipv6 nf_conntrack nf_defrag_ipv6 tun ipv6 arc4 crypto_blkcipher zram lzo_compress lzo_decompress zsmalloc leds_gpio ledtrig_timer ledtrig_default_on ehci_platform ehci_hcd gpio_button_hotplug usbcore nls_base usb_common crc32c crypto_hash
[40418.780000] CPU: 0 PID: 10032 Comm: kworker/u2:1 Not tainted 3.10.32 #5
[40418.780000] Workqueue: phy0 ath_reset_work [ath9k]
[40418.790000] Stack : 80650180 802c4938 80fe7a94 000001eb 80ff7cc4 81866030 80f5a7f8 81838810
[40418.790000]    00000088 80078f38 00002730 80093190 81829ef8 81866030 802d3498 80665d04
[40418.790000]    80665d04 80078f38 00000003 8008f4c0 80ff7cc4 00000000 00000005 801acfd0
[40418.790000]    00000000 00000000 00000000 00000000 00000000 00000000 70687930 00000000
[40418.790000]    00000000 00000000 00000000 00000000 80e19400 80e19500 80fe552c 80665cb0
[40418.790000]    ...
[40418.820000] Call Trace:
[40418.830000] [<8006e200>] show_stack+0x48/0x70
[40418.830000] [<80076ab8>] warn_slowpath_common+0x78/0xa8
[40418.840000] [<80076b70>] warn_slowpath_null+0x18/0x24
[40418.840000] [<80fe7a94>] ath_stoprecv+0x108/0x132c [ath9k]
[40418.850000] [<80fe2f10>] ath9k_deinit_device+0x2c0/0xa9c [ath9k]
[40418.850000] [<80fe53dc>] ath9k_p2p_ps_timer+0x31c/0x424 [ath9k]
[40418.860000]
[40418.860000] ---[ end trace 73b335d6a0fdc992 ]---

root@box:~ cat /sys/kernel/debug/ieee80211/phy0/ath9k/reset
    Baseband Hang:  0
Baseband Watchdog:  0
   Fatal HW Error:  0
      TX HW error:  0
     TX Path Hang:  0
      PLL RX Hang:  0
         MAC Hang:  0
     Stuck Beacon:  5
        MCI Reset:  0

root@box:~ cat /proc/uptime
49944.54 47807.77

root@box:~ uci show wireless
wireless.radio0=wifi-device
wireless.radio0.type=mac80211
wireless.radio0.country=US
wireless.radio0.channel=11
wireless.radio0.frag=off
wireless.radio0.noscan=1
wireless.radio0.path=platform/ath9k
wireless.radio0.hwmode=11ng
wireless.radio0.ht_capab=SHORT-GI-40 DSSS_CCK-40
wireless.radio0.beacon_int=100
wireless.@wifi-iface[0]=wifi-iface
wireless.@wifi-iface[0].device=radio0
wireless.@wifi-iface[0].network=wlan
wireless.@wifi-iface[0].mode=adhoc
wireless.@wifi-iface[0].bssid=02:ca:ff:ee:00:11
wireless.@wifi-iface[0].ssid=bb

root@box:~ iw dev wlan0 info                                                                                                       
iInterface wlan0
        ifindex 8
        wdev 0x2
        addr f4:ec:38:c9:bf:54
        ssid bb
        type IBSS
        wiphy 0
        channel 11 (2462 MHz), width: 20 MHz (no HT), center1: 2462 MHz

root@box:~ cat /etc/HARDWARE 
TP-LINK TL-WR1043ND

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by nbd

  • Resolution set to duplicate
  • Status changed from new to closed

The WARN_ON belongs to the DMA related error message. Duplicate of #9654

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.