Modify

Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#15209 closed defect (fixed)

[ar71xx] ssh login takes twice as much time as usual

Reported by: Damian Kaczkowski <damian.kaczkowski+openwrt@…> Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: Cc:

Description

tl-wr1043nd v1
BB trunk r39865

In newest trunk ssh login seems to take about twice as much time as before (about 7-8 sec). Could someone please confirm this? Could this be caused by GCC upgrade in r39860 ? On r39854 ssh login is much faster (~3 sec).

I have also noticed that CONFIG_USE_MIPS16 symbol have changed in my .config between r39854 and r39865. Could this be related? Here is the diff log between those revs:

	+CONFIG_USE_MIPS16=y
	-CONFIG_GCC_VERSION_4_6_LINARO=y
	-CONFIG_GCC_VERSION="4.6-linaro"
	-CONFIG_GCC_VERSION_4_6=y
	+CONFIG_GCC_VERSION_4_8_LINARO=y
	+CONFIG_GCC_VERSION="4.8-linaro"
	+CONFIG_GCC_VERSION_4_8=y

Attachments (0)

Change History (7)

comment:1 Changed 4 years ago by anonymous

reverse DNS lookups take this login time

if you want diable it

--- options.h
+++ options.h
@@ -171,7 +171,9 @@
 #endif
 
 /* Whether to do reverse DNS lookups. */
-/*#define DO_HOST_LOOKUP */
+#ifndef NO_HOST_LOOKUP
+#define DO_HOST_LOOKUP
+#endif

add
CPPFLAGS +-DNO_HOST_LOOKUP

comment:2 Changed 4 years ago by anonymous

mips16 on 32mb ram device is increases the Operative memory consumption

defaut minimal openwrt trunk image with -march=24kc

mips16 ~10mb free
no-mips16 15mb free

comment:3 Changed 4 years ago by hnyman

I tested with my own ar71xx/wndr3700 build, and disabling MIPS16 for dropbear seems to be enough to cut the login time back.

comment:4 Changed 4 years ago by Damian Kaczkowski <damian.kaczkowski+openwrt@…>

Hmm, then what are the benefits of MPS16 if it increases CPU and (as reported) also memory usage? Is it true that it increases memory usage?

comment:5 Changed 3 years ago by jogo

  • Resolution set to fixed
  • Status changed from new to closed

Fixed with r42250.

comment:6 Changed 3 years ago by daniel.petre

Can this patch be backported to BB?
I can see the before mentioned behaviour on small routers like mr3020 or mr3040.
Thanks!

Last edited 3 years ago by daniel.petre (previous) (diff)

comment:7 Changed 3 years ago by jogo

Backported to BB in r42258.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.