Modify

Opened 4 years ago

Last modified 4 years ago

#15194 new defect

USB 1.1 HID not working

Reported by: kc.snijders@… Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: usb 1.1 Cc:

Description

I'm using a TP-LINK 1043 V2.
Getting errors when connecting a mice or keypad:

[ 21.410000] usb 1-1: device descriptor read/64, error -145
[ 36.700000] usb 1-1: device descriptor read/64, error -145
[ 36.930000] usb 1-1: new low-speed USB device number 3 using ehci-platform
[ 52.110000] usb 1-1: device descriptor read/64, error -145
[ 67.400000] usb 1-1: device descriptor read/64, error -145
[ 67.630000] usb 1-1: new low-speed USB device number 4 using ehci-platform
[ 78.090000] usb 1-1: device not accepting address 4, error -145
[ 78.210000] usb 1-1: new low-speed USB device number 5 using ehci-platform

Attachments (1)

dmesg.txt (11.6 KB) - added by kc.snijders@… 4 years ago.
dmesg

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by kc.snijders@…

dmesg

comment:1 Changed 4 years ago by pepvf@…

Some Atheros SoCs haven't USB 1.x support. One solution is to attach the device to an usb hub that supports 1.x and 2.0 modes.

According to the dmesg attached the usb device is managed by the ehci driver:
[ 6.230000] usb 1-1: new low-speed USB device number 2 using ehci-platform
The ohci driver doesn't found compatible hardware:
[ 5.970000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
while ehci finds:
[ 5.840000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[ 5.850000] ehci-platform: EHCI generic platform driver
[ 5.850000] ehci-platform ehci-platform.0: EHCI Host Controller
[ 5.860000] ehci-platform ehci-platform.0: new USB bus registered, assigned bus number 1
[ 5.870000] ehci-platform ehci-platform.0: TX-TX IDP fix enabled
[ 5.870000] ehci-platform ehci-platform.0: irq 48, io mem 0x1b000000
[ 5.900000] ehci-platform ehci-platform.0: USB 2.0 started, EHCI 1.00
[ 5.900000] hub 1-0:1.0: USB hub found
[ 5.910000] hub 1-0:1.0: 1 port detected
[ 5.910000] ehci-platform ehci-platform.1: EHCI Host Controller
[ 5.920000] ehci-platform ehci-platform.1: new USB bus registered, assigned bus number 2
[ 5.930000] ehci-platform ehci-platform.1: TX-TX IDP fix enabled
[ 5.930000] ehci-platform ehci-platform.1: irq 49, io mem 0x1b400000
[ 5.960000] ehci-platform ehci-platform.1: USB 2.0 started, EHCI 1.00
[ 5.960000] hub 2-0:1.0: USB hub found
[ 5.970000] hub 2-0:1.0: 1 port detected

comment:2 Changed 4 years ago by kc.snijders@…

Ok thank you for the answer. Are there also other solutions without using an extra USB hub ? Adding a USB2 hub works indeed..

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.