Modify

Opened 11 years ago

Closed 10 years ago

Last modified 6 years ago

#1517 closed defect (worksforme)

r6036 causes kmod-alsa not to build on 2.6 ... wtf?

Reported by: seniorr@… Owned by: developers
Priority: normal Milestone:
Component: packages Version:
Keywords: Cc:

Description

Why was this patch added? It results in no kmod-alsa for 2.6, which is odd, because it was working fine on 2.6 earlier. Can the committer explain please?

Attachments (0)

Change History (4)

comment:1 Changed 11 years ago by nbd

  • Resolution set to invalid
  • Status changed from new to closed

the alsa driver from the kernel tree is used on 2.6

comment:2 Changed 10 years ago by seniorr@…

  • Resolution invalid deleted
  • Status changed from closed to reopened

On a wgt634u 2.6 kernel compile, kmod-alsa package is still not built as of r8753. This still looks bogus:

Symbol: PACKAGE_kmod-alsa [=n]
 Prompt: kmod-alsa.............................. Advanced Linux Sound Ar
   Defined at tmp/.config-package.in:9653
   Depends on: USB_SUPPORT && LINUX_2_4
   Location:
    -> Kernel modules
      -> Other modules

The remark above "the alsa driver from the kernel tree is used on 2.6" doesn't make any sense.

comment:3 Changed 10 years ago by seniorr@…

Okay, so it makes a *little* sense, since you don't need an out-of-tree alsa driver with 2.6, but how *else* do you get an kmod-alsa package for 2.6?

comment:4 Changed 10 years ago by blogic

  • Resolution set to worksforme
  • Status changed from reopened to closed

use kmod-soundcore on current trunk

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.