Modify

Opened 12 years ago

Closed 12 years ago

#151 closed defect (duplicate)

no WPA due to nas crash after about one day...

Reported by: anonymous Owned by: nbd
Priority: high Milestone:
Component: base system Version: 1.0
Keywords: wpa nas crash wds Cc:

Description

Hello,

I have some instability in that after about a day of operation I can not associate in
WPA mode due to the nas process having crashed (vanished from the process list).

I'm running rc4, in a WPA setup with one WDS link that is configured but the neighbor
currently down, so the interaction with the wds watchdog could contribute to the cause
of nas crashing but this is mere speculation.

Relevant configuration:

wl0_akm=psk
wl0_crypto=aes
wl0_closed=1

I call this relevant in particular due to the observation that with

wl0_akm=psk psk2
wl0_crypto=aes+tkip
wl0_closed=0

for some tests this setup seems to have been stable for more than a day.
(but I have problems associating with my laptop, but thats a different
story likely not caused by openwrt)

Whichever way, due to the relative importance of nas, especially for remote
units relying on wlan connectivity for management, I suggest nas to be
monitored and restarted, via init, some watchdog, or at least a
"while true" shell script.

For the same reason, I am labeling this to be "critical".

Attachments (0)

Change History (2)

comment:1 Changed 12 years ago by nbd

  • Owner changed from developers to nbd
  • Status changed from new to assigned

comment:2 Changed 12 years ago by nbd

  • Resolution set to duplicate
  • Status changed from assigned to closed

covered by #164

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.